ポイントを使用する

ホーム フォーラム バグ報告 ポイントを使用する

このトピックには8件の返信が含まれ、2人の参加者がいます。3 年、 11 ヶ月前 fuku さんが最後の更新を行いました。

9件の投稿を表示中 - 1 - 9件目 (全9件中)
  • 投稿者
    投稿
  • #71664

    fuku
    参加者

    ——————————————-
    WordPress のバージョン:WordPress 3.9.2
    Welcart のバージョン:バージョン 1.4.6
    ご利用のテーマ:独自
    症状を確認したブラウザ:Chrome firefox
    サーバー(会社名、サービス名):sakura
    SSLの利用: yes
    WordPress のパーマリンク設定: カスタム構造 /item/%post_id%
    ——————————————–

    数年前からWelcartを使っております。
    本日、wordpress welcart のバージョンアップを行ったところ、
    カート内、内容確認画面にて、「利用するポイント」に現在ポイントの一部の数値を入れ、
    「ポイントを使用する」ボタンを押すと、

    「Security check1」

    とだけ表示された画面になるようになってしまいました。
    Welcartのバージョンを1.4.5に戻して確認しましたが、同様でした。

    対処方法がありましたら、ご教示お願いします。

    #71667

    yskysmr
    キーマスター

    こんにちは。

    こちらですが、最近セキュリティ強化のためのチェックを入れていまして、それが上手く動作していないように思われます。
    オリジナルテーマをお使いとのことですが、wc_templates はご利用になっていますでしょうか。

    #71672

    fuku
    参加者

    はい。cart内ですと、下記3点を使用しています。

    /wc_templates/cart/wc_cart_error_page.php
    /wc_templates/cart/wc_completion_page.php
    /wc_templates/cart/wc_customer_page.php

    よろしくお願いいたします。

    #71673

    yskysmr
    キーマスター

    wc_confirm_page.php は、使っていないのですね…。

    それでは、ちょっとサイトを拝見させていただきたいのですが、お問い合わせフォームより、サイトの URL を教えていただけますでしょうか。

    #71674

    fuku
    参加者

    wc_confirm_page.php
    の記載で、気が付きましたが、
    /templates/confirm.php
    は使っておりました。

    /templates/confirm.php

    /wc_templates/wc_confirm_page.php
    に載せ替えて、動作確認したところ、問題ありませんでした。

    現在、
    /templates/ から /wc_templates/
    を必要に応じて移し替えておりましたが、混在は問題ありますでしょうか?
    /templates/には、、まだcart.phpが残っております。

    #71675

    yskysmr
    キーマスター

    fuku 様

    ちょっと、よくわからないのですが、「載せ替えて」とか「移し替えて」と言うのは、どういう使い方をされていますでしょうか。

    wc_templates のご利用方法は、以下をご参照ください。
    https://www.welcart.com/community/archives/2878

    プラグインフォルダ/usc-e-shop/templates/confirm.php は、Welcart の内蔵テンプレートです。こちらは、ご利用のテーマ配下に /wc_templates/wc_confirm_page.php が存在しないときに自動的に参照しています。プラグインフォルダ配下の confirm.php は、直接編集しないようにしてください。Welcart のアップデート時に上書きされてしまいます。

    confirm.php(=内容確認画面)をオリジナルテーマに合わせて編集したい場合に、/wc_templates/wc_confirm_page.php を使います。他のテンプレートも使い方は同じです。
    また、/templates/confirm.php をそのままご利用のテーマ配下に置いただけでは、confirm.php を使っていることにはなりません。

    以上を踏まえまして、fuku 様のサイトの症状は、/wc_templates/wc_confirm_page.php を使っていただければ、再現されないと思いますのでご確認ください。

    #71676

    fuku
    参加者

    あいまいな表現で失礼しました。
    Welcart1.0以前から利用させて頂いておりましたので、当初
    プラグインフォルダ配下の confirm.php をテーマ配下に置き、
    functions.php に add_filter を記述して利用していた名残でした。

    プラグインから退避していたものは削除して、/wc_templates/に
    いたします。

    ご回答ありがとうございます。

    #71677

    yskysmr
    キーマスター

    fuku 様

    そうでしたか…。長らくのご利用、ありがとうございます。1.0系以前のものより、いきなり1.4系にアップデートされたのでしょうか…。過去の受注データはちゃんと移行されていますでしょうか。なんかいろいろ心配になってきました。

    「Security check1」のエラーは解消されましたでしょうか。

    #71678

    fuku
    参加者

    定期的にアップデートはして来ており、いきなりではありませんのでご心配の点は大丈夫かと…。過去の受注データの移行上の問題はありません。

    Welcart1.0以降の時点で、/wc_templates/ にすぐに切り替えればよかったのでしょうが、
    そのままでも問題なさそうでしたので、必要に応じてファイル単位で /wc_templates/ に移行させていました。

    「Security check1」のエラーは無事解消されております。

    引き続きどうぞよろしくお願いいたします。

9件の投稿を表示中 - 1 - 9件目 (全9件中)

このトピックに返信するにはログインが必要です。