動作環境

Welcart は以下の環境で動作することを確認しています。

  • WordPress 3.0 以降
    Welcart の最新版を利用するには、WordPress 3.0 以降が必要となります。それぞれできるだけ最新版をご利用ください。

  • サーバー
    基本的にWordPress が利用できるサーバーであればOKです。但しPHP のセーフモードには完全対応していません。

  • SSL
    個人情報を保護するためにもSSL の導入は強くお勧めいたします。
    一部のサーバーにはWelcart でSSL が利用できないものがあります。契約前に「WordPress のようなCMS でSSL を通すページと通さないページを切り分ける事ができるか」を確認しておくと良いです。


【共用SSL を利用する場合の注意点】
共用SSL はサーバー会社ごとに仕様が異なります。ユーザーごとにサブドメインが割り当てられているサーバーでは問題ありませんが、同じドメインでその配下のパスでユーザーを振り分けているタイプのものはセキュリティーに問題が発生します。
上記の共用SSL での動作とは単に動作したというだけで、セキュリティーを考慮すると推奨できるものではありません。ショップを運営する場合は、独自ドメインの取得と独自ドメインSSL の適用を強くお勧めいたします



【他のプラグインやテーマとの併用】
Welcart はマルチ言語プラグインとの併用はできません。またJavaScript を使用しているプラグインやテーマを併用する場合は、うまく動作しないことがあります。他のプラグインとの併用は動作をよく確かめて利用するようにしてください。
現時点(2011/1/10)で動作を確認しているプラグインは次の通りです。

  • Akismet
  • All in One SEO Pack
  • Breadcrumb NavXT
  • Contact Form 7
  • Google Analytics for WordPress
  • Lightbox 2
  • Maintenance Mode
  • My Category Order
  • Google XML Sitemaps
  • TinyMCE Advanced
  • WordPress Database Backup
  • WP-PageNavi
  • WP Multibyte Patch