Re: [解決済み] Welcart0.7でバグ

2010 年 9 月 10 日

ホーム フォーラム バグ報告 [解決済み] Welcart0.7でバグ Re: [解決済み] Welcart0.7でバグ

#60229

subaru
参加者

横レス失礼いたします。

nanbu様、素晴らしいプラグインを提供いただきありがとうございます。

ところで、私もyasuさんとほぼ同じ症状が発生しております。

■症状:カートに1種類以上の商品を入れることができない。(先にいれた商品がクリアされる。)

以下に環境・状況を報告させていただきます。

  1. 「SSLを使用しない」場合はカート内は正常動作いたします。
  2. Coreserverの共有SSLを使用しておりますので、『https://ss1.coressl.jp/(ドメイン名)/』というパスで切り分けるタイプのSSLです。
  3. config.php に define(‘USCES_KEY’, ‘********’);を追加しても症状は同じです。
  4. パーマリンクは、/%category%/%post_id%/で設定してあります。
  5. 『0.7』『Development Version(9月9日分)』とも、カート内に関しては同じ症状が発生します。
  6. パスを変更するプラグインは使用しておりません。

Coreserverの、WPに関するセーフモード対策は抑えているつもりなのですが、

やはりパス切り分け型の共用SSLの場合は回避できない症状なのでのでしょうか。

もし解決のために必要でしたら、さくらインターネットなどでもインストールしてみるつもりです。

当ショップはまだWEBは公開前のため、サーバーやwelcartのバージョンを変更することにより対応することは可能ですが、何かの参考になればと思い、投稿させていただきました。お手数ですが、ご検討していただけたら幸いです。