「会員登録」「パスワードをお忘れですか?」 「新規ご入会はこちら」の不具合

ホーム フォーラム 使い方全般 「会員登録」「パスワードをお忘れですか?」 「新規ご入会はこちら」の不具合

このトピックには5件の返信が含まれ、3人の参加者がいます。3 週間、 5 日前 emuninim22 さんが最後の更新を行いました。

6件の投稿を表示中 - 1 - 6件目 (全6件中)
  • 投稿者
    投稿
  • #90580

    emuninim22
    参加者

    お世話になります。

    「会員登録」のボタンを押すと、ログイン画面に飛び、
    「パスワードをお忘れですか?」 「新規ご入会はこちら」を押してもリンク先には飛ばず同じページをループする事象となっています。

    商品をカートに入れてから会員登録して(または、しないで)の購入は可能な状態です。

    事象の解決策をご教示ください。

    ——————————————-
    WordPress のバージョン:5.5
    Welcart のバージョン:1.9.31
    PHP のバージョン:7.3.21
    Welcart専用の拡張プラグインとバージョン:(例 DL Seller 3.0.8、SKU Select 1.1.4)
    ご利用のテーマ:ICONIC
    症状を確認したブラウザ:Chrome
    サーバー:WordPress.com のネームサーバーを使用
    SSLの利用:常時SSL
    ——————————————–

    #90583

    Konoha
    参加者

    私も同様の事象になりました。
    こちらもWordpress 5.5による不具合と思われます。

    素人的な予測ですが…
    おそらく、新規会員登録やパスワード処理で使われているURLの引数が

    ?page=newmember
    ?page=lostmemberpassword

    など、既にWordpress上で予約(使用)されている引数を使用していて、
    その引数をGETで使用すると、パーマリンクから消されてしまうのでは…
    と考えています。
    試しに「page=」を「memberpage=」などに変更したら画面遷移しましたので。

    もしかしたらWordpress 5.5のセキュリティ強化の一環なのかもしれませんね。

    的外れでしたらすみません。

    #90593

    yskysmr
    キーマスター

    こんにちは。

    ご報告ありがとうございます。仰るとおりの症状を確認いたしました。
    WordPress 5.5 で、パーマリンク設定が基本以外のとき、この症状が発生するようです。
    検証して対応いたしますので、しばらくお待ちいただけますでしょうか。
    この度はご不便をおかけしまして、申し訳ございません。

    #90628

    emuninim22
    参加者

    yskysmr様

    ーーーーーーーーーーーーーーーーーーーー
    2020年8月17日 9:40 AM

    こんにちは。

    ご報告ありがとうございます。仰るとおりの症状を確認いたしました。
    WordPress 5.5 で、パーマリンク設定が基本以外のとき、この症状が発生するようです。
    検証して対応いたしますので、しばらくお待ちいただけますでしょうか。
    この度はご不便をおかけしまして、申し訳ございません。
    ーーーーーーーーーーーーーーーーーーーー
    お世話になります。
    その後、検証対応は如何でしょうか?

    現在、トラブルは起こっておりませんが、間も無く新商品の販売も控えておりますので、
    ご状況をお知らせいただけると幸いです。

    >konohaさん
    同症状なのですね。アドバイスをありがとうございます。画面遷移する方法はあるのですね。
    ただ、素人ですので、それを、「パスワードをお忘れですか?」 に組み込めないので、事務局様のご対応を待ちたいと思います。

    宜しくお願いします。

    #90629

    Konoha
    参加者

    >emuninim22様

    この問題に関しましては、新しいバージョンのWelcartアップデートにより修正されました。

    https://www.welcart.com/archives/12260.html

    アップデート後、私の方では問題なく画面遷移しています。

    #90631

    emuninim22
    参加者

    >Konoha様

    ご返信をありがとうございます。
    1.9.32 で解消されたのですね。教えてくださりありがとうございました。

    その1.9.32を有効化しようとすると、エラーになってしまいました。(別トピック立ててます)
    どうすれば良いのか、困惑中です。。

6件の投稿を表示中 - 1 - 6件目 (全6件中)

このトピックに返信するにはログインが必要です。