「条件に合う投稿はありませんでした。」 となってしまう。

2010 年 9 月 9 日

ホーム フォーラム 使い方全般 「条件に合う投稿はありませんでした。」 となってしまう。

このトピックには5件の返信が含まれ、2人の参加者がいます。7 年、 3 ヶ月前 nanbu さんが最後の更新を行いました。

6件の投稿を表示中 - 1 - 6件目 (全6件中)
  • 投稿者
    投稿
  • #49946

    zoo
    参加者

    お世話になります。はじめて投稿します。

    テスト環境(別のサーバ「チカッパ」)から本番環境(Webアリーナ)に移行しました。

    トップページは正常に表示しているのですが、

    (「お勧め商品」のカテゴリーの商品はトップページに表示)

    お勧め商品、商品カテゴリーをクリックすると「条件に合う投稿はありませんでした。」となってしまします。

    固定ページの「お問い合わせ」、「利用ガイド」、「カート」などは正常に表示します。

    また、営業日設定もトップページの「営業日カレンダー」に正常に反映します。

    なにか基本的な設定を抜かしていいるのでしょうか?

    移行方法

    1)本番にWordPress3.01を新規にインストール

    2)テスト:phpMyadminで全テーブルをエキスポート(SQL)、wp_options.siteurlなどを本番URLに変更。

    3)本番:phpMyadminでインポートしました。このインポートでは特にエラーは起こっていません

    ただ、

    「Welcart Shop 基本設定」

    「Welcart Shop メール設定」

    「Welcart Shop 配送設定」が空白でインポートしていないのが気になります。

    空白部分は手動で入力しました。

    商品マスタ、カテゴリーは正常にインポートしていました。

    4)uploads(画像関係)は別途FTPで本番にアップロード。

    テーマは「uCart Default Theme 2.0」初期設定のまま。

    パーマリンクは「月と投稿名」テスト環境と同じ。


    環境

    ホスティングサーバーはWebアリーナ

    サーバー Apache

    MySQL 5.1.36-community-log

    PHP     5.1.6

    WordPress 3.01

    Welcart Version0.7

    ドキュメントルートの.htaccess で「子ドメイン」の設定をしています。

    # Main RewriteRule for multidomain.

    RewriteCond %{HTTP_HOST} ^(shop.example.com)

    RewriteCond %{REQUEST_URI} !^/(shop.example.com)/

    RewriteRule ^(.*)$ /%{HTTP_HOST}/$1/ [L]

    WordPress のコアファイルは”shop.example.com/eshop”にインストールしています。

    /home/shop.example.com/eshop/.htaccess

    # BEGIN WordPress

    <IfModule mod_rewrite.c>

    RewriteEngine On

    RewriteBase /eshop/

    RewriteRule ^index.php$ – [L]

    RewriteCond %{REQUEST_FILENAME} !-f

    RewriteCond %{REQUEST_FILENAME} !-d

    RewriteRule . /eshop/index.php [L]

    </IfModule>

    # END WordPress

    WordPress のアドレス (URL)、サイトのアドレス (URL)は

     shop.example.com/eshop/

    のままです。


    以上よろしくお願いします。

    #60319

    nanbu
    参加者

    こんにちは。

    アップグレードは移行の前ですか?その時は全て正常だったと言うことでよろしいでしょうか。

    お勧め商品、商品カテゴリーというのはWelcart ウィジェットのことでしょうか。

    いずれにしてもカテゴリーリンクの様ですが、表示されないときのURLをチェックしてください。URLで指定されているカテゴリーがちゃんと登録されているかカテゴリーをチェックしてみてください。

    また、商品編集画面でカテゴリーが指定されているか確認してみてください。

    #60320

    zoo
    参加者

    早速ご返事ありがとうございます。

    0.6のときも0.7のときも最初から「条件に合う投稿はありませんでした」同じ現象です。

    Welcart ウィジェットの「お勧め商品」「最近の投稿」

    には登録した商品が表示されます。

    ウィジェット「商品カテゴリー」には登録したカテゴリーが表示されています。

    「お勧め商品」「最近の投稿」の商品名をクリックする

    また

    「商品カテゴリー」のカテゴリーをクリックすると

    「条件に合う投稿はありませんでした」となります。

    商品編集画面でカテゴリーを指定しているのは確認しました。

    URLはカテゴリーのスラッグと一致しています。

    http://xxxxx/eshop/category/item/rope/

    固定ページだけは正常に動作しています。

    新規商品も登録できます。

    だだメディアのアップロードがエラーとなります。


    ディレクトリ /xxxxx/eshop/wp-content/uploads/2010/09 を作成できませんでした。この親ディレクトリのアクセス権はサーバーによる書き込みを許可していますか ?


    ファイル属性は755で問題ないと思うのですが

    .htaccess の設定が絡んでるような気もするのですが、不案内でよくわかりえません。

    以上、ご報告です。

    #60321

    nanbu
    参加者

    Welcart のアップグレードは関係なさそうですね。

    ディレクトリの作成ができないのは、パーミッションの問題かPHPセーフモードの場合などに起こるようです。

    サーバー移行の際、MySQLの文字コードは考慮されましたか?

    なんだか問題だらけで収拾がつかない感じですが、一つずつ解決していったほうが良さそうですね。

    まずは、テスト環境で既にある問題を解決して、テストサーバーでアップグレードを行い、問題なければ本番環境に移行という流れで行ってはどうでしょうか。

    #60322

    zoo
    参加者

    nanbu様、経過の報告

    「子ドメイン」(Webアリーナ)は諦め、

    example.com/shop/

    普通のURLでアクセスするようにしました。

    問題のあったデータベースはそのままにして、

    別のデータベースにSQLでインポート。

    正常に動作しました。


     カテゴリーのクリックで、商品一覧の表示

     商品クリックでカードページの表示


    SQLの編集ではUTF-8でおこないました

    メディアのアップロードは

    設定->メディアの「アップロードするファイルの保存場所」

    がSQLの置換えのときサーバーのフルパスに書き換わったためでした。

    「wp-content/uploads」デフォルトに戻すとOK。

    単純なケアレスミスでした。

    それにしても、固定ページのURLは問題なくて、投稿(商品)のURLでは,

    Not Foundになるのがどうも腑に落ちないです。

    問題のあったWordPressとデータベースはそのままあるので、時間があれば調べてみようと思います。

    どうもお世話になりました。

    問題解決ではありませんが、取り合えす問題は回避しました。

    #60323

    nanbu
    参加者

    こんにちは。

    固定ページは問題なかったんですね。

    「子ドメイン」を利用して、商品ではなく通常の投稿記事はどんな結果になったか興味が有ります。

6件の投稿を表示中 - 1 - 6件目 (全6件中)

このトピックに返信するにはログインが必要です。