[未解決] カスタムフィールドの選択肢に「wccs_」で始まるものが表示されない

2013 年 2 月 12 日

ホーム フォーラム その他 [未解決] カスタムフィールドの選択肢に「wccs_」で始まるものが表示されない

このトピックには4件の返信が含まれ、3人の参加者がいます。4 年、 10 ヶ月前 kazz さんが最後の更新を行いました。

5件の投稿を表示中 - 1 - 5件目 (全5件中)
  • 投稿者
    投稿
  • #52266

    kazz
    参加者

    動作に関するご質問の場合は必ずご記入ください。


    WordPress のバージョン:3.5.1

    Welcart のバージョン:1.2.3

    ご利用のテーマ:独自

    症状を確認したブラウザ:IE9、Chrome24


    商品マスタのカスタムフィールドを登録する際、選択肢に「wccs_」で始まるものが表示されません。

    いつからそうなったのかははっきりしないのですが、少なくともWelcart1.2.1のときは表示されていました。

    カスタムフィールドを新規追加で手入力すれば、普通に登録されますし、サイトの表示にも反映されます。

    #66164

    nanbu
    参加者

    こんにちは。

    こちらの環境では、一度登録されたカスタムフィールドは、wccs_に関わらず問題なく選択肢としてセレクトに表示されております。

    何か他のプラグインが影響している可能性は無いでしょうか。一度他のプラグインを全て停止して動作確認をしてみてはいかがでしょうか。

    #66165

    kazz
    参加者

    Welcartを除くすべてのプラグインを停止してみましたが、やはり「wccs_」で始まるものだけが表示されません。

    「wccs_」以外は問題なく表示されています。

    他に確認することなどありますでしょうか?

    #66166

    yasumax
    キーマスター

    こんにちは。

    ご利用のテーマが独自ということですが、「wc_templates」はそのテーマの中にはありますか?

    テーマ内に「wc_tempaltes」がある場合、「wc_item_single.php」内に以下のコードがあるかご確認ください。

    <?php if( $item_custom = usces_get_item_custom( $post->ID, 'list', 'return' ) ) : ?>

    <div class="field"><?php echo $item_custom; ?></div>

    <?php endif; ?>

    「usces_get_item_custom」というテンプレートタグで、「wccs_」と接頭辞がついたカスタムフィールドを出力しています。

    #66167

    kazz
    参加者

    yasuma様、ご返信ありがとうございます。

    サイトの商品画面には問題なく「wccs_」で始まるカスタムフィールドの値は表示されています。

    商品登録画面のカスタムフィールドの選択肢に「wccs_」で始まるカスタムフィールド名が表示されないのです。

5件の投稿を表示中 - 1 - 5件目 (全5件中)

このトピックに返信するにはログインが必要です。