[未解決] カート部分SSLの設置について

2010 年 9 月 7 日

ホーム フォーラム 使い方全般 [未解決] カート部分SSLの設置について

このトピックには8件の返信が含まれ、2人の参加者がいます。7 年、 3 ヶ月前 drapon さんが最後の更新を行いました。

9件の投稿を表示中 - 1 - 9件目 (全9件中)
  • 投稿者
    投稿
  • #49937

    drapon
    参加者

    いつもお世話になっております。

    どうしても解決手段が見当たらなかった為、こちらにてご質問させて頂ければと思います。

    現在下記の環境にてショッピングサイトの構築を行っております。

    kagoya専用サーバー3G 401

    PHP 5.2.13

    wordpress:3.1

    welcart:0.6

    カート部分にSSLを導入したく、

    「ジオトラスト クイックSSLプレミアム」の取得を行い、

    導入まで行いました。

    過去のフォーラム等を参考にさせて頂き、システム設定を下記のように行っております。

    ・Use SSLへのチェック

    ・WordPress のアドレス (SSL)

     →https://www.example.com

    ・ブログのアドレス (SSL)の入力

     →https://www.example.com

    しかしながら、カートにアクセスを行いましても、

    httpsのアドレスにリンクはするものの、

    アドレスバーの横にSSLサーバ証明書が表示されません。

    試しに、test.html等をアップロードしhttps://~でアクセスを

    行いますとアドレスバーの横にはSSLサーバ証明書が表示されます。

    test.phpでは証明書の表示がされません。

    phpのみSSLでの表示がうまくいかない為、サーバー側の設定かと思い、カゴヤ・ジャパン サポートセンターに問い合わせを行いました所、

    「http://から始まるURLにリダイレクトするようなご設定をしておりませんか」という内容の回答を頂きました。

    他に利用しているプラグインを止めてみたり、リダイレクト処理を行っている箇所を探してみたものの原因がわかりません。

    もしリダイレクト処理を行っている箇所や、

    その他、原因の可能性等がございましたらご教授頂けますと幸いでございます。

    何卒よろしくお願いいたします。

    #60262

    nanbu
    参加者

    こんにちは。

    Welcart はりダイレクトを行っていません。

    パーマリンクを使っていませんか?もし使っていましたら.htaccess のmod_rewriteの部分はどうなっていますでしょうか。

    それと、test.php には何が書かれているのでしょう。

    #60263

    drapon
    参加者

    ご返信ありがとうございます。

    パーマリンクは使っておりません。

    デフォルトのままでしたので.htaccessも利用を行っておりません。

    また、test.phpの件ですが、

    「test.phpでは証明書の表示がされません」と記述しておりましたが、改めて確認を行ったところ証明書の表示はされておりました。

    test.phpには現在下記の内容のみ書いてあります。

    <?php echo “Hello World”; ?>

    #60264

    drapon
    参加者
    #60265

    nanbu
    参加者

    サイトを見てみたいので下記宛にURLを送っていただけますか?

    nanbuアットusconsort.com(アットは@)

    #60266

    drapon
    参加者

    先ほどメールをお送りいたしました。

    メール内にも記述したのですが、

    先ほど、別のディレクトリにWPのインストールとWelcart0.7をインストールし、SSLを試してみましたところ、カート上はSSLの表示を行う事が出来ました。

    カート部分のカスタマイズを行ったのが原因かもしれません。

    もう一度改めて見直してみたいと思います。

    #60267

    nanbu
    参加者

    ショップ、拝見させて頂きました。

    こちらはWindows Chrome で確認していますがSSLは通っているようです。

    ただ警告が出ています。ノンSSLを通して読み込もうとしているコンテンツがあるのでしょう。その辺をチェックしてみてください。

    #60268

    nanbu
    参加者

    こんにちは。

    拝見させていただいたときは問題ないように見えたのですが、バグがあったのでその影響の可能性が高いです。

    Development Version をお試しください。

    お願いいたします。

    #60269

    drapon
    参加者

    わざわざありがとうございます。

    ちょっと今事情があって更新作業をおこなえないので、後日試してみます。

    その後また、こちらのフォーラムにて報告させて頂きますのでよろしくお願いいたします。

9件の投稿を表示中 - 1 - 9件目 (全9件中)

このトピックに返信するにはログインが必要です。