解決済バージョンアップしたらエラー表示

フォーラム インストール 【解決済】バージョンアップしたらエラー表示

  • このトピックには13件の返信、6人の参加者があり、最後にHalonetにより2週、 3日前に更新されました。
14件の投稿を表示中 - 1 - 14件目 (全14件中)
  • 投稿者
    投稿
  • #94458
    kokoru-hn
    参加者

    いつもお世話になっております。
    1日のバージョンアップをしましたらトップページと管理画面にエラーが表示
    原因がわかりません。
    Warning: array_diff(): ・・usc-e-shop/functions/utility.php ・・・

    WordPress のバージョン:WORDPRESS 5.7.2
    Welcart のバージョン:Version 2.2.5.2107011
    PHP のバージョン:7.4.19
    ご利用のテーマ:Calm
    症状を確認したブラウザ:全ページと管理画面
    サーバー【重要】:さくらインターネット スタンダード

    ※Googleでエラーログを検索してみたら同じようなログが表示されているサイトがありました。

    Attachments:
    You must be logged in to view attached files.
    #94460
    furuta
    キーマスター

    kokoru-hn様

    こんにちは。
    まずは、テーマを「Welcart Basic」に変更していただき
    症状をご確認いただけますでしょうか。
    「Welcart Basic」はこちらより入手可能でございます。

    #94461
    kokoru-hn
    参加者

    ありがとうございます。
    何も変わらず、エラーメッセージが出たままです。

    トップページに表示されているログは
    wp-content/plugins/usc-e-shop/functions/utility.php on line 1127
    wp-content/plugins/usc-e-shop/functions/utility.php on line 1128

    です。

    #94462
    check_d
    参加者

    私もまったく同じ状況です。
    対策があれば教えてください。

    #94463
    Halonet
    参加者

    ウチも全く同じ状況で困っています。
    対処方法を教えていただけないでしょうか。

    #94464
    wakuwakushop
    参加者

    私も同じ状況が発生しました。
    直し方が分からなかったので、
    こちらからWelcartの前のバージョンをダウンロードして、手動で入れ替えました。
    https://ja.wordpress.org/plugins/usc-e-shop/advanced/
    (ページ最下部に「以前のバージョン」ダウンロードボタンがありました)
    とりあえず前のバージョンで運用しています。
    不具合が直りますように。
    ——————————————-
    WordPress のバージョン:5.7.2
    Welcart のバージョン: 2.2.4 を2.2.5へ更新したら不具合が発生しました。
    PHP のバージョン:7.4.19
    Welcart専用の拡張プラグインとバージョン:なし
    ご利用のテーマ:WelcartBasic の自作子テーマ
    症状を確認したブラウザ:Google Chrome
    サーバー【重要】:さくらインターネットビジネスプロ
    ——————————————–
    エラー内容↓
    ——————————————–
    【管理画面ログイン後】
    Warning: array_diff(): Expected parameter 1 to be an array, string given in /****当方アドレス***/usc-e-shop/functions/utility.php on line 1127

    Warning: array_values() expects parameter 1 to be array, null given in /****当方アドレス***/usc-e-shop/functions/utility.php on line 1128

    Warning: Cannot modify header information – headers already sent by (output started at /****当方アドレス***/usc-e-shop/functions/utility.php:1127) in /****当方アドレス***/all-in-one-wp-security-and-firewall/other-includes/wp-security-rename-login-feature.php on line 390

    Warning: Cannot modify header information – headers already sent by (output started at /****当方アドレス***/usc-e-shop/functions/utility.php:1127) in /****当方アドレス***/all-in-one-wp-security-and-firewall/other-includes/wp-security-rename-login-feature.php on line 406

    Warning: Cannot modify header information – headers already sent by (output started at /****当方アドレス***/usc-e-shop/functions/utility.php:1127) in /****当方アドレス***/wp-includes/functions.php on line 6362

    Warning: Cannot modify header information – headers already sent by (output started at /****当方アドレス***/usc-e-shop/functions/utility.php:1127) in /****当方アドレス***/wp-includes/pluggable.php on line 991

    Warning: Cannot modify header information – headers already sent by (output started at /****当方アドレス***/usc-e-shop/functions/utility.php:1127) in /****当方アドレス***/wp-includes/pluggable.php on line 992

    Warning: Cannot modify header information – headers already sent by (output started at /****当方アドレス***/usc-e-shop/functions/utility.php:1127) in /****当方アドレス***/wp-includes/pluggable.php on line 993

    Warning: Cannot modify header information – headers already sent by (output started at /****当方アドレス***/usc-e-shop/functions/utility.php:1127) in /****当方アドレス***/wp-includes/pluggable.php on line 1329

    Warning: Cannot modify header information – headers already sent by (output started at /****当方アドレス***/usc-e-shop/functions/utility.php:1127) in /****当方アドレス***/wp-includes/pluggable.php on line 1332

    【ショップトップページ】
    Warning: array_diff(): Expected parameter 1 to be an array, string given in /****当方アドレス***/usc-e-shop/functions/utility.php on line 1127

    Warning: array_values() expects parameter 1 to be array, null given in /****当方アドレス***/usc-e-shop/functions/utility.php on line 1128

    #94465
    sagawa
    キーマスター

    kokoru-hn様
    check_d様
    Halonet様
    wakuwakushop様

    1点確認です。
    [管理画面 > Welcart Shop > クレジットカード決済設定]で何も決済モジュールを選択されていない状態でエラーが出ておりますでしょうか?
    何も選択されていない場合に、このエラーになることを確認しました。
    修正いたしますので、しばらくお待ちいただきますようお願いいたします。
    尚、開発中でなければデバッグモードを false にしていただければエラーメッセージは表示されなくなります。

    #94466
    sagawa
    キーマスター

    wakuwakushop様

    wakuwakushop様の場合は、このエラーとは別のエラーも含まれているように見受けられます。
    修正版がリリースされましたら、再度ご確認いただければと思います。

    #94467
    check_d
    参加者

    sagawa様;

    ご指摘いただいた通り、利用の都合上決済モジュールは選択しておりません。

    #94468
    sagawa
    キーマスター

    kokoru-hn様
    check_d様
    Halonet様
    wakuwakushop様

    取り急ぎDevelopment Version にて修正をいたしました。
    こちらからダウンロードしてご利用ください。

    #94469
    kokoru-hn
    参加者

    sagawa様
    ご対応ありがとうございます。無事戻りました。

    #94470
    wakuwakushop
    参加者

    sagawa様
    私も、先ほどお知らせいただいたDLから手動アップデートして、無事にバージョンアップできました!
    ご対応いただきましてありがとうございました。
    今後とも宜しくお願い致します。

    #94473
    check_d
    参加者

    sagawa様;

    こちらも無事正常に復旧いたしました。ありがとうございました。

    #94491
    Halonet
    参加者

    sagawa様

    お返事遅くなりました。
    ご対応ありがとうございました。

14件の投稿を表示中 - 1 - 14件目 (全14件中)
  • このトピックに返信するにはログインが必要です。