ペイジェント利用でのテスト接続でエラー

2016 年 6 月 7 日

ホーム フォーラム 使い方全般 ペイジェント利用でのテスト接続でエラー

このトピックには4件の返信が含まれ、2人の参加者がいます。9 ヶ月、 1 週前 Shiratori さんが最後の更新を行いました。

5件の投稿を表示中 - 1 - 5件目 (全5件中)
  • 投稿者
    投稿
  • #79210

    Shiratori
    Participant

    お世話になります。下記環境で動作をしています。
    ——————————————-
    WordPress のバージョン:WordPress 4.3.4
    Welcart のバージョン:Version 1.8.3.1606013
    ご利用のテーマ:BizVektor
    症状を確認したブラウザ:chrome,IE11
    サーバー(会社名、サービス名):お名前.com
    SSLの利用: 有り アルファSSL
    WordPress のパーマリンク設定:デフォルト
    ——————————————–

    ペイジェント決済の契約が済み、テスト接続のための環境を作っています。
    独自SSLを契約しておりサイト全体をSSL化しています。
    購入テストをしようと決済ページにジャンプしようとするとブラウザが下記の文字表示になってしまいます。

    ペイジェント決済を使わない、振込みなどの決済方法を選択すると購入処理は完了してメール等の受信も正常にできました。

    フォーラムの過去ログ等を見ると、development versionを使うと良いのかと思ったのですが公式プラグインページに行っても通常バージョンしか見つけられませんでした。

    アドバイスのほどなにとぞよろしくお願いいたします。

    以下ブラウザ表示文字——————————————–

    Warning: fsockopen(): SSL operation failed with code 1. OpenSSL Error messages: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed in /***/wp-content/plugins/usc-e-shop/classes/usceshop.class.php on line 7345

    Warning: fsockopen(): Failed to enable crypto in /***/wp-content/plugins/usc-e-shop/classes/usceshop.class.php on line 7345

    Warning: fsockopen(): unable to connect to ssl://sandbox.paygent.co.jp:443 (Unknown error) in /***/wp-content/plugins/usc-e-shop/classes/usceshop.class.php on line 7345

    Warning: Cannot modify header information – headers already sent by (output started at /***/wp-content/plugins/usc-e-shop/classes/usceshop.class.php:7345) in /***/wp-content/plugins/usc-e-shop/classes/usceshop.class.php on line 7350

    ※決済モジュールパスが長いため/***に置き換えています

    • このトピックは Shiratoriが9 ヶ月、 2 週間前に変更しました。
    #79325

    Shiratori
    Participant

    先日本記事にて投稿させていただきました。
    その後、Development Versionへの変更と、
    ペイジェントの契約内容がwelcart様利用であることの確認を行いました。

    再度、welcartオンラインマニュアルに従いクレジット決済設定を行いテスト環境での決済を行ったのですが、やはり同様のエラー画面となりました。
    銀行振り込み(前払い)を選択した場合は問題なく注文処理が完了しました。
    SSL・TLSでの通信に関連するトラブルなのだと思いますが、具体的にどの部分を解決すれば良いか分からず・・・対処方法についてアドバイス頂けますでしょうか。
    よろしくお願いいたします。

    —–購入後画面には以下の表示が出ます。
    Warning: fsockopen(): SSL operation failed with code 1. OpenSSL Error messages: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed in /***/classes/usceshop.class.php on line 7350

    Warning: fsockopen(): Failed to enable crypto in /***/classes/usceshop.class.php on line 7350

    Warning: fsockopen(): unable to connect to ssl://sandbox.paygent.co.jp:443 (Unknown error) in /***/classes/usceshop.class.php on line 7350

    Warning: Cannot modify header information – headers already sent by (output started at /***/classes/usceshop.class.php:7350) in /***/classes/usceshop.class.php on line 7355

    —–acting_transaction.logファイルには以下の記載がありました。
    [2016-06-14 11:43:55] paygent_card : TLS(v1.2) Error
    [2016-06-14 11:43:55] paygent_card : SSL Error

    ——————————————-
    WordPress のバージョン:4.5.2
    Welcart のバージョン:Development Version(表示はVersion 1.8.4.1606101)
    ご利用のテーマ:
    症状を確認したブラウザ:chrome、IE
    サーバー(会社名、サービス名):お名前.com
    SSLの利用:アルファSSL
    WordPress のパーマリンク設定:/%postname%/
    ——————————————–

    #79331

    yskysmr
    キーマスター

    こんにちは。

    SSL 証明書のエラーだと思われます。お使いの SSL 証明書をご確認ください。Welcart がペイジェントと通信を行うところでエラーが発生しているというエラーメッセージですので、Welcart を修正して直るというようなものではございません。

    #79345

    Shiratori
    Participant

    yskysmr様

    返信いただきありがとうございます。
    SSL証明書のエラーということで、サーバーならびに決済会社にも問合せを行い回答待ちです。

    ひとつお伺いしたいのですが、今回サーバーで使用しているSSLが
    SNI SSLというネームベースのSSLです。

    以前からあるIPアドレスベースのSSLと異なりますが、
    welcartではこのSNI SSLでの動作はOKとなりますでしょうか?

    #79457

    Shiratori
    Participant

    お世話になっております。

    その後以下のSSLエラーについて調べたところ
    PHP5.6以降のバージョンによって発生する可能性があるらしく
    サーバーのPHPバージョンを確認したところ5.6xでした。
    そのため、PHPバージョンを安定版の5.5xに変更したところ
    エラーは解消され、クレジットカードのテスト決済が無事完了いたしました。

    OpenSSL Error messages: error:14090086

    お手数をおかけしました。今後ともよろしくお願い致します。

5件の投稿を表示中 - 1 - 5件目 (全5件中)

このトピックに返信するにはログインが必要です。