共有SSL利用時にヘッダの画像が表示されない

2013 年 3 月 8 日

ホーム フォーラム 使い方全般 共有SSL利用時にヘッダの画像が表示されない

このトピックには2件の返信が含まれ、2人の参加者がいます。4 年、 7 ヶ月前 saboo さんが最後の更新を行いました。

3件の投稿を表示中 - 1 - 3件目 (全3件中)
  • 投稿者
    投稿
  • #52362

    saboo
    参加者

    動作に関するご質問の場合は必ずご記入ください。


    WordPress のバージョン:3.5.1

    Welcart のバージョン:1.2.3

    ご利用のテーマ:TwentyEleven(子テーマ)

    症状を確認したブラウザ:firefox

    サーバー(会社名、サービス名):minibird

    SSLの利用: 共用SSL

    WordPress のパーマリンク設定:/%category%/%postname%/


    カート、会員登録などのWelcart関連のページでのみ、ヘッダの画像が表示されない現象が起きています。

    ソースを見ると、表示されないヘッダ画像のURLが以下のようになっています。

    https://example.com/wp-content/uploads/2013/02/header-coffee-1000×200-gs.jpg

    以下の、(1),(2)のどちらかだと表示可能ですが、上記のようになってしまっているため、表示されなくなっています。

    (1) https://example-com.ssl-netowl.jp/wp-content/uploads/2013/02/header-coffee-1000×200-gs.jpg

    (2) http://example.com/wp-content/uploads/2013/02/header-coffee-1000×200-gs.jpg

    Welcart のシステム設定のSSL関連箇所は下記の通り設定しています。

    ・SSLを使用する→チェック

    ・WordPress のアドレス (SSL) → https://example-com.ssl-netowl.jp

    ・ブログのアドレス (SSL) → https://example-com.ssl-netowl.jp

    原因、対処方法などわかりましたら、ご教示お願い致します。

    #66295

    nanbu
    参加者

    こんにちは。

    SSL関連の他のプラグインは使用していないということでよろしいでしょうか。

    また、これはTwentyElevenを使用した時の症状であって、Welcart Default テーマでは問題ないということでよろしいでしょうか。

    #66296

    saboo
    参加者

    返信ありがとうございます。

    > SSL関連の他のプラグインは使用していないということでよろしいでしょうか。

    はい。現在は、本問題を回避するために、WordPress HTTPS プラグインを導入していますが、問い合わせした時はまだ導入していませんでした。

    > また、これはTwentyElevenを使用した時の症状であって、Welcart Default テーマでは問題ないということでよろしいでしょうか。

    Default テーマではまだ試していません。切り分けのために必要ですね、失礼しました。

    冒頭に書きましたように、急いでいたので、スマートなやり方では無いかもしれませんが、”WordPress HTTPS” というプラグインの力を借りて、今は回避させています。

    既に運用開始しており、プラグインをはずしたり、テーマをWelcartデフォルトにしたりすることは困難ですので、本件は、一旦クローズしてください。ありがとうございました。

3件の投稿を表示中 - 1 - 3件目 (全3件中)

このトピックに返信するにはログインが必要です。