商品コードに関係なく、blank画像が2枚追加されてしまう

2015 年 2 月 19 日

ホーム フォーラム バグ報告 商品コードに関係なく、blank画像が2枚追加されてしまう

このトピックには4件の返信が含まれ、2人の参加者がいます。2 年、 9 ヶ月前 azuazu22 さんが最後の更新を行いました。

5件の投稿を表示中 - 1 - 5件目 (全5件中)
  • 投稿者
    投稿
  • #73529

    azuazu22
    参加者

    いつもお世話になります。
    大変困ったことになっているので助けてください。

    商品を追加登録します。
    →blankの商品画像が2枚、勝手に登録されてしまう

    このときの商品コードは、メディアにないものをつけたとしても、必ず2枚blank画像が追加されてしまいます。

    どうやってもこのblank画像は消すことができません。

    実際起こっているURL
    http://crystalh-t.jp/archives/769
    商品画像は2枚なのですが、合計4枚と認識されています。

    画像登録をリセットすることはできないのでしょうか?
    このエラーをどうやって直せばいいのか教えてください。

    ——————————————-
    WordPress のバージョン:4.1–ja
    Welcart のバージョン:1.4.10
    ご利用のテーマ:小さなECサイトの…本をみて設定を反映しています。
    症状を確認したブラウザ:Firefox
    サーバー(会社名、サービス名):さくらインターネット
    SSLの利用: 
    WordPress のパーマリンク設定:数字ベース
    ——————————————–

    Attachments:
    You must be logged in to view attached files.
    #73532

    azuazu22
    参加者

    画像のキャッシュをクリアにする方法はないものでしょうか・・・。

    #73534

    yasumax
    キーマスター

    こんにちは。

    メイン画像が存在していないためblank画像が表示されているようです。
    管理画面[Welcart Shop]>[システム設定]の「商品サブ画像適用ルール」が「新しいルールを適用する」になっていた場合は、商品コードと同じ名前の画像をあらためて登録しなおしてみてください。

    #73539

    azuazu22
    参加者

    お返事をありがとうございます。

    設定では「新しいルールを使用しない」にしており、他には前方一致する画像が存在しない状態です。
    それでもblank画像が消えません。

    それどころか、新しく商品を追加しても、必ずblank画像が2枚追加されてしまう状態です。

    設定を「新しいルールを適用する」にして試してみました。
    メディア画像もハイフン二つに変更しました。
    表示されていた画像は入れ替わりますが、それでもblank画像は残ったまま消えません。。

    商品画像をみようとクリックするとずっと考え中になってしまい、とても困っています。
    他に解決策がありましたら、どうかお教えくださいm(__)m

    #73541

    azuazu22
    参加者

    すみません、いま突然直りました!

    メイン画像がなく、サブ画像のみの状態でした…
    メイン画像を設定したら、blank画像が無事に消えてくれました。

    お騒がせしまして申し訳ありませんでしたm(__)m

5件の投稿を表示中 - 1 - 5件目 (全5件中)

このトピックに返信するにはログインが必要です。