商品マスターの一括登録「ファイルを保存できませんでした。」

フォーラム 使い方全般 商品マスターの一括登録「ファイルを保存できませんでした。」

  • このトピックには9件の返信、4人の参加者があり、最後にliptonにより6年、 7ヶ月前に更新されました。
10件の投稿を表示中 - 1 - 10件目 (全10件中)
  • 投稿者
    投稿
  • #72446
    lipton
    参加者

    ——————————————-
    WordPress のバージョン:WordPress 3.9.1
    Welcart のバージョン:バージョン 1.4.2
    ご利用のテーマ:自作
    症状を確認したブラウザ:Chome
    サーバー(会社名、サービス名):さくらVPS
    SSLの利用:なし
    WordPress のパーマリンク設定:なし
    ——————————————–

    商品マスターの一括登録が、「ファイルを保存できませんでした。」
    となります。
    uploadsのパーミッションは、755になっており、
    itemcsv_log.txtのパーミションも、766になっております。
    別の原因はありますでしょうか。
    ご教示のほど、よろしくお願いします。

    #72448
    masuda-clair
    参加者

    https://www.welcart.com/community/forums/topic/%e5%95%86%e5%93%81%e4%b8%80%e6%8b%ac%e7%99%bb%e9%8c%b2%e3%81%8c%e3%81%a7%e3%81%8d%e3%81%aa%e3%81%84
    でも書いたのですが、どのような状況での一括登録でしょう?
    新規で登録の場合は「ID」に何か入っているとそのような状況になりますが

    • この返信は6年、 8ヶ月前にmasuda-clairが編集しました。
    #72458
    yskysmr
    キーマスター

    こんにちは。

    アップロードする csv のファイル名に、全角文字・記号・空白等は含まれていませんでしょうか。
    ファイル名によって失敗する場合もあるようです。

    #72460
    lipton
    参加者

    ご返信ありがとうございます。
    >新規で登録の場合は「ID」に何か入っているとそのような状況になりますが

    新規で、IDには何もはいっておりません。
    以前は、登録できていたのですが、急にこの状態になりました。
    また、商品コードも重複しておりません。

    >アップロードする csv のファイル名に、全角文字・記号・空白等は含まれていませんでしょうか。

    こちらも確認しましたが、半角英語のみでした。

    usc-e-shop/logs/itemcsv_log.txt
    につきましても、何も入ってない状態です。

    作り直した方が早いでしょうか。。。

    #72461
    yskysmr
    キーマスター

    このエラーは、データの内容以前に、csv のアップロードが失敗しているというものです。他にお心当たりはございませんでしょうか。データは何件ほど、というか、アップロードのファイルサイズはどれくらいになっていますでしょうか。

    #72465
    lipton
    参加者

    フォルダのサイズは7KBで、30件です。
    試しに、1行で試してみましたが、同じ結果となりました。

    どのようにしたらよろしいでしょうか。
    よろしくお願いします。

    #72468
    yskysmr
    キーマスター

    「以前はできていた」と仰っていますので、何も変えていないのに急にできなくなる、というようなことは、基本的にはないはずです。なにかお心当たりはございませんでしょうか。

    #72479
    lipton
    参加者

    内容のカスタムはしていますが、なにがCSVの登録に関わるかが検討がつきません。
    別の確認事項がありましたら、確認しますので、ご教示下さい。

    #72497
    nanbu
    キーマスター

    こんにちは。

    そのエラーメッセージは、アップロードしたファイルを、テンポラリーからuploadsフォルダにmoveできなかった時に出るものです。

    何らかの原因で、uploadsフォルダに書き込みができない可能性が高いかと思います。

    #72530
    lipton
    参加者

    ご回答ありがとうござます。
    プラグインを入れ直してみたり、uploadsフォルダの権限を777に変更してみたり
    しましたが、結局直りませんでした。
    どこかのファイルが壊れてしまったのかもしれないので
    作り直すことにします。
    ありがとうございました。

10件の投稿を表示中 - 1 - 10件目 (全10件中)
  • このトピックに返信するにはログインが必要です。