[解決済み] カートが不安定?(時々Not Found)

ホーム フォーラム 使い方全般 [解決済み] カートが不安定?(時々Not Found)

このトピックには11件の返信が含まれ、2人の参加者がいます。7 年、 8 ヶ月前 nanbu さんが最後の更新を行いました。

12件の投稿を表示中 - 1 - 12件目 (全12件中)
  • 投稿者
    投稿
  • #50256

    onlyone
    参加者

    お世話になっております。

    先日SSLも無事に設定でき、カートの準備も整いましたが

    この週末、ページを編集しながらカートを確認していると、

    時々Not Foundとなってしまいます。

    この週末2日間で3度確認しました。

    カートが正常に機能→Not Found→正常に機能(繰り返し)みたいな感じです。

    先日別の自分の投稿でご回答頂いた内容から

    ブラウザの問題かな?とも思いましたが

    どうもそうでは無いような感じです。

    PC再起動してみたりiPod touchからも確認してみましたが不安定な感じです。

    ▽先日の投稿

    https://www.welcart.com/forum/topic.php?id=568

    SSL設定する前はそんな事は無かったと思うので

    SSLが関係しているような気がしますが

    他に事例が無いかHP内を探してみましたが

    ちょっと原因が判りませんでした。

    アドバイスをお願い致します。


    Welcart のバージョン:0.9.2

    症状を確認したブラウザ:Sleipnir、Chrome、Safari

    サーバー(会社名、サービス名):エックスサーバー

    SSLの利用:専用SSL

    WordPress のパーリンク設定:/%category%/%post_id%.html/

    補足情報:他社で購入したテーマ


    #61484

    nanbu
    参加者

    こんにちは。

    どのルートからカートに入ったときになりますか?カーと投入ボタンを押した時、若しくはメニューのカートへのリンクから入った時、カートページで再読み込みなど。

    また、Not Found となった時のURL はどうなっているか確認してみてください。

    あと、パーマリンクですが最後にスラッシュを付けていますか?もし付いているのであれば外した方が良いかと思います。

    よろしくお願いします。

    #61485

    onlyone
    参加者

    ご回答ありがとうございます。

    > どのルートからカートに入ったときになりますか?

    殆どがカートに入れた時ですね。

    1度だけですがカート内の商品を削除した際に

    Not Foundが表示されたと思います。

    > また、Not Found となった時のURL はどうなっているか確認してみてください。

    また正常に戻ってるので(今朝はNot Foundでした)

    今はちょっと確認出来ない状態です。

    またNot Foundになったら正常に動いている現在のURLと見比べてみます。

    > あと、パーマリンクですが最後にスラッシュを付けていますか?

    すみません、付いていました。

    今朝より外しています。

    お昼過ぎにまた正常に戻った為、今は不具合の確認が出来ませんが

    またNot Foundになったら、上記内容を確認してみます。

    #61486

    onlyone
    参加者

    お世話になります。

    またNot Foundとなってしまいました。

    今回もカートに商品を入れた際ですね。

    そういえばNot Foundになる時は

    一度警告画面が表示されNot Foundになっていますね。

    (2度目以降は警告表示が無く、そのままNot Foundになります)

    なおURLは正常に機能していた時と全く一緒でした。

    宜しくお願い致します。

    #61487

    nanbu
    参加者

    >一度警告画面が表示されNot Foundになっていますね。

    もう少し詳しくお願いします。

    警告の内容は何とかいてありますか?

    警告画面から自動的にリダイレクトしてNot Found になってしまうと言う感じですか?

    警告を確認しているブラウザはChrome ですか?

    #61488

    onlyone
    参加者

    お世話になっております。

    > 警告の内容は何とかいてありますか?

    画面をキャプチャしたのでご確認下さい。

    ▽Chrome

    http://onlyone-production.info/top/wp-content/uploads/error01.gif

    ▽Sleipnir

    http://onlyone-production.info/top/wp-content/uploads/error02.gif

    > 警告画面から自動的にリダイレクトしてNot Found になってしまうと言う感じですか?

    いえ、自分で続行を押してNot Found ですね。

    > 警告を確認しているブラウザはChrome ですか?

    殆どのブラウザで確認していました。

    しかもこの返信を書いている最中に、

    Chromeは最初はNot Foundでしたが

    FireFox、Opera、が正常に機能してたので

    もう一度Chromeを確認しましたら

    また正常に機能していました。

    [Not Found] → Sleipnir、Chrome、Safari、

    [正常に機能] → FireFox、Opera、

       ↓

    [その後正常に機能] → Chrome、Safari、

    症状が出ているサイトを貼り付けておきますので

    御社でもご確認頂ければと思います。

    ▽商品はまだ上2つしか登録していません。

    http://dogtag-labo.com/store/category/dogtag/stainless

    お手数をお掛けして申し訳ありません。

    それでは宜しくお願い致します。

    #61489

    nanbu
    参加者

    dogtag-labo.com に対するSSL が有効になっていないのではないでしょうか。ルートにダミーのhtml を置いてSSL(http://dogtag-labo.com/dummy.html)でアクセスできるか確認してみてください。

    #61490

    onlyone
    参加者

    ご回答ありがとうございます。

    https://dogtag-labo.com/dummy.html

    問題無くアクセス出来ました。

    カートを確認してみましたが

    今は正常に機能しています。

    次にいつNot Foundになるか判りませんが

    再びNot Foundになったら

    ダミーURLも確認してみます。

    #61491

    onlyone
    参加者

    お世話になります。

    14:23にカートを確認しましたらNot Foundとなっていたので

    ダミーURLを確認しましたら、

    そちらもNot Foundとなってしまいました。

    状況報告のみですが宜しくお願い致します。

    #61492

    nanbu
    参加者

    WordPress を通さないファイルにアクセスできないと言うことは、残念ながら独自ドメインにSSLが有効になっていないと言うことです。サーバー会社にお問合せください。

    #61493

    onlyone
    参加者

    お世話になっております。

    結論から言えば自分のサーバー設定のミスでした。

    お手間をとらせてしまいまして申し訳ありません。

     

    原因ですが特に意図は無かったのですが、

    当店はwww無しでサイトURLを使用していました。

    そして今回SSL申込の際に(エックスサーバー)

    www無しで利用する為に

    まずは「www」を付けたコモンネームで申し込み。

    その後DNSレコード設定より、SSL用のIPアドレスを設定します。

    ▽エックスサーバー・マニュアル

    http://www.xserver.ne.jp/man_order_domain_ssl.php

    ココから先はマニュアルに書いてないのですが、

    従来から設定されているDNSレコード設定と

    新規にSSL設定をしたDNSレコード設定の2つが存在する事になり、

    SSLに繋がる時と繋がらない時があるのは

    2つのDNSレコード設定が混在していた為に起きた不具合という結果です。

    従来の設定を削除したので、SSL設定のDNSレコードのみとなったので

    これでカートは安定すると思います。

    ワードプレスも初めて、SSL設定も初めてという状態だったので

    DNSレコード設定の混在に気が付かなかったのですが

    (と言うより2種類DNSレコードには気が付いていましたが

     削除しなければいけないという事自体に気が付きませんでした。)

    これでやっと解決しました。

     

    余談ですが、前回の質問も今回の問題が無ければ

    SSL設定に躓く事が無かったんですね。(苦笑)

    SSL設定が出来たのは偶然SSL設定に繋がっただけの話でした。

    ▽前回の質問(SSL設定で躓いています)

    https://www.welcart.com/forum/topic.php?id=568

    色々とお手数をお掛けしまして申し訳ありません。

    本当にありがとうございました。

    #61494

    nanbu
    参加者

    いえいえ、なかなか気付きにくいところですから。

12件の投稿を表示中 - 1 - 12件目 (全12件中)

このトピックに返信するにはログインが必要です。