[解決済み] 配送方法エラー

2012 年 11 月 23 日

ホーム フォーラム 使い方全般 [解決済み] 配送方法エラー

このトピックには4件の返信が含まれ、2人の参加者がいます。4 年、 9 ヶ月前 mdr さんが最後の更新を行いました。

5件の投稿を表示中 - 1 - 5件目 (全5件中)
  • 投稿者
    投稿
  • #52021

    mdr
    参加者

    動作に関するご質問の場合は必ずご記入ください。


    WordPress のバージョン:3.4.2

    Welcart のバージョン:1.2.0

    ご利用のテーマ:オリジナル

    症状を確認したブラウザ:

    サーバー(会社名、サービス名):xServer

    SSLの利用: 無し

    WordPress のパーマリンク設定:


    お世話になっております。

    ショッピングカートの配送方法で

    『配送方法が誤っています。国際便を指定してください。』

    というエラーがでます。

    オーストラリアでWP-en、Welcar(en_AU)で使用しています。

    オンラインマニュアルを確認しながら、設定を確認したのですが原因がわかりません。

    参照ページ:https://www.welcart.com/documents/manual-2/配送設定

    ●配送方法を国内便とし、発送先を国外とした場合

    ●配送方法を国際便とし、発送先を国内とした場合

    とありますが、配送先はどこで設定するのでしょうか?

    ユーザー登録時の住所ということでしょうか?

    商品データの更新も行いました。

    ※何も編集せずにupdateを押しただけなのですが、日付等を変える必要があるのでしょうか?

    テスト環境(WP ver3.4.1 Welcart ver 1.1.10)では、正常に動いています。

    販売対象国、配送方法の設定画面を添付いたします。

    ご助言いただけますよう、よろしくお願いいたします。

    [attachment=8746,181] [attachment=8746,182] [attachment=8746,183]

    #65839

    yskysmr
    キーマスター

    こんにちは。

    『配送方法が誤っています。国際便を指定してください。』

    こちらのエラーは、販売元から国外にあたる国を配送先としたとき、配送対象地域が「国際便」でない配送方法が選ばれたということになります。

    (ややこしいですね・・・)

    ●配送方法を国内便とし、発送先を国外とした場合

    ●配送方法を国際便とし、発送先を国内とした場合

    とありますが、配送先はどこで設定するのでしょうか?

    ユーザー登録時の住所ということでしょうか?

    配送先は、カートの「発送・支払方法」の画面で設定します。「お客様情報と同じ」が選ばれているときは、ユーザー登録時の住所と同じですが、「別の発送先を指定する」を選んだとき、配送先住所が変わります。

    商品データの更新も行いました。

    ※何も編集せずにupdateを押しただけなのですが、日付等を変える必要があるのでしょうか?

    update を押すだけで大丈夫です。

    配送設定画面のキャプチャを拝見しますと、配送対象地域が「国内便」になっています。「国際便」対応の配送を用意し、国際便配送可能な商品に登録してみてもらえませんでしょうか。

    よろしくお願いいたします。

    #65840

    mdr
    参加者

    配送対象地域を「国際便」に変更したところ、機能いたしました。

    ※商品データの配送設定変更、アップデートは行っておりません。

    販売元、販売対象国ともにオーストラリアで、ユーザー登録情報と別の発送先もオーストラリア以外選択できないのですが、その場合も「国内便」ではなく「国際便」の扱いになるのでしょうか。

    テスト環境(WP ver3.4.1 Welcart ver 1.1.10)では、「国内便」で動作していました。1.2への更新内容に配送方法に関係する内容はなかったと思います。

    現在はオーストラリア国内のみの受付となっておりますが、今後は海外発送(オーストラリア国外)も検討しております。さらに国が増えた場合は、「国際便」の設定で何らかの影響が出る可能性はあるのでしょうか?

    動作はしましたが、引き続き検証してみます。

    #65841

    yskysmr
    キーマスター

    こんにちは。

    wp-config.php の ‘WPLANG’ を ‘en_AU’ にしてみてもらえませんでしょうか。販売元の国は、’WPLANG’ を参照しております。

    テスト環境のほうの ‘WPLANG’ はどうなっていますか?

    #65842

    mdr
    参加者

    WPの言語設定を’en_AU’に設定したところ、「国内便」で動作いたしました。

    テスト環境は’en_AU’になっていましたが、本サイトは’en’になっていました。

    どうもありがとうございました。

5件の投稿を表示中 - 1 - 5件目 (全5件中)

このトピックに返信するにはログインが必要です。