[未解決] WPを3.1にアップグレードしてからSSLでエラーが出るようになった

2011 年 3 月 2 日

ホーム フォーラム 使い方全般 [未解決] WPを3.1にアップグレードしてからSSLでエラーが出るようになった

このトピックには8件の返信が含まれ、2人の参加者がいます。6 年、 8 ヶ月前 yumesaki さんが最後の更新を行いました。

9件の投稿を表示中 - 1 - 9件目 (全9件中)
  • 投稿者
    投稿
  • #50288

    yumesaki
    参加者

    不具合の場合は必ずご記入ください。


    Welcart のバージョン:Version 0.9.3

    症状を確認したブラウザ:Safari 5、Firefox 3.6.14(いずれもMac)

    サーバー(会社名、サービス名):チカッパ

    SSLの利用:共用SSL

    WordPress のパーリンク設定:/%category%/%postname%/


    別トピックからの誘導で新規トピックを立てます。

    エラーが出る直前の商品投入ページのformのソースは以下の通りです。

    「ページが見つかりませんでした(404エラー)」になります。

    <form action="https://***-chicappa-****.ssl-chicappa.jp/example/index.php?page_id=66&uscesid=MDQ0M2QyNmI0OTJkMjAwNTNiODMxMTc0NDdhN2Q3MGM5MzU3NjY1OTM4MmVkNWJmX2FjdGluZw%3D%3D" method="post">

    #61611

    nanbu
    参加者

    こんにちは。

    action のURLが旧型のものとなっているようです。

    single_item.php を退避させていますか?

    #61612

    yumesaki
    参加者

    >>nanbu さん

    > single_item.php を退避させていますか?

     いいえ。テーマ以外は触っていません。

    #61613

    nanbu
    参加者

    ご利用中のパーマリンク設定では次のようなURLにならなくてはいけません。

    ****chicappa.jp/example/usces-cart/?uscesid=MDQ0M2****

    退避されていないのでしたら、下記のファイルを確認してみてください。

    usc-e-shop/templates/single_item.php 5行目

    $html .= '<form action="' . USCES_CART_URL . '" method="post">'."n";

    この様になっていますでしょうか。

    #61614

    yumesaki
    参加者

    >> nanbu さん

     以下の通りです(そのままコピペ)。

    $html .= '<form action="' . USCES_CART_URL . '" method="post">'."n";

    #61615

    nanbu
    参加者

    WordPress のパーマリンク設定が /%category%/%postname%/ であるならば、ソースのURLは、/index.php?page_id=66&uscesid= では無く、/uesces-cart/?uscesid= とならなくてはいけないはずなんですよね。

    パーリンク設定の設定を更新しなおしてみてはどうでしょうか。

    #61616

    yumesaki
    参加者

    >> nanbu さん

     ありがとうございます。

     駄目です。パーマリンクを他の書式にした場合はエラーなくカートに進めるのに /%category%/%postname%/ にすると404エラーになります。

     念の為 Welcart を削除してダウンロード&インストールしてもみましたが症状が出ます。

    #61617

    nanbu
    参加者

    同じ環境を作ってMACでテストしていますがこちらでは不具合は有りません。

    WordPress のアップグレードは自動アップグレードを使っていますよね。

    htaccess や他のプラグインのチェック(停止してみるなど)も行なってください。

    /%category%/%postname%/ にすると404エラーになる原因の一つとして、カートページ(固定ページ)のスラッグが「usces-cart」になっていない事が上げられます。

    一応考えられるのはこんなところですが、サーバーに入って調査する事も可能です。ご希望であれば「Welcart レスキュー」よりお問合せください。

    #61618

    yumesaki
    参加者

    >> nanbu さん

     ありがとうございます。

    WordPress のアップグレードは自動アップグレードを使っています。

    今回試した再インストールも、管理画面:プラグイン から停止&削除 → 新規追加で「Welcart e-Commerce」で検索 → 出て来たリストからインストールを実行。で行っています。

    カートページ(固定ページ)のスラッグは「usces-cart」になっていました。念の為に再度入力し直して上書き保存もしてみましたが改善せずです。

9件の投稿を表示中 - 1 - 9件目 (全9件中)

このトピックに返信するにはログインが必要です。