解決済管理画面の表示不具合

フォーラム 使い方全般 【解決済】管理画面の表示不具合

  • このトピックには5件の返信、2人の参加者があり、最後にikedaにより6ヶ月、 2週前に更新されました。
6件の投稿を表示中 - 1 - 6件目 (全6件中)
  • 投稿者
    投稿
  • #96351
    yoiko
    参加者

    こんにちは。いつもお世話になっております。

    サーバーの移転を行ってからWelcartの管理画面の表示に異常があります。
    (さくらのレンタルサーバ スタンダードプランからロリポップ ハイスピードプランへ引っ越し)
    注文・決済は問題無く行えています。

    以下の点になります。
    お手数をおかけして恐縮ですが、ご助言頂けましたら幸いです。

    1 商品マスターの「操作フィールド表示」が反応しない

    「操作フィールド表示」がリンク表示になっているのですが、クリックしても反応しません。

    2 本来ならタブのような外観で表示される部分がテキストの縦並びになっています。
    ※添付参照
    Welcart Shop メール設定の
    ・メールオプション
    * 自動送信メール
    * 手動送信メール
    * その他のメール

    カートページ設定の
    * 商品名の表示ルール
    * カートページに挿入する説明書き
    * カスタム・オーダーフィールド
    * カスタム・カスタマーフィールド
    * カスタム・デリバリーフィールド

    会員ページ設定、Welcart Shop システム設定、Welcart Shop クレジット決済設定も同様です。
    内容は全て隠れず縦に列挙されています。

    ただし、WCEX マルチプライスはルールのタブがそれぞれ表示されています。
    受注リスト、会員リスト、クーポン管理は表示オプション・操作フィールド表示ともに正常です。

    よろしくお願いいたします。

    追記
    コンソールにエラーが出ていますが、そちらの情報が必要な場合、全てコピーペーストしてもよろしいのでしょうか?
    かなりの分量になってしまうので念のためご教示頂けますと助かります。
    ——————————————-
    WordPress のバージョン:(例 5.6)5.9.2
    Welcart のバージョン:(例 2.1.1)2.5.7
    PHP のバージョン:(例 7.4)7.4.25
    Welcart専用の拡張プラグインとバージョン:(例 DL Seller 3.0.8、SKU Select 1.1.4)
    WCEX Coupon 1.2.1
    WCEX Multi Price 1.2.2
    ご利用の親テーマとバージョン :(例 Welcart Basic 1.4.0)Welcart Basic1.4.3
    ご利用の子テーマとバージョン :(例 Welcart Beldad 1.1 )Welcart Beldad1.1.2
    ご利用中の決済サービス : (例 WelcartPay)PayPal(CP)
    症状を確認したブラウザ:Firefox97.0.1
    サーバー【重要】:(会社名、サービス名)ロリポップ ハイスピードプラン
    ——————————————–

    Attachments:
    You must be logged in to view attached files.
    #96354
    ikeda
    キーマスター

    yoiko 様
    こんにちは。
    コンソールにエラーが出ているとのことですので、
    まずはそちらを解決していただく必要があるかと思います。
    プラグインがコンフリクトを起こしていないか、
    JavaScript を最適化していないかなどご確認いただけますでしょうか。
    また、プラグインかサーバーでキャッシュの設定をされていましたら
    そちらを解除していただけますでしょうか。
    どうぞよろしくお願いいたします。

    #96359
    yoiko
    参加者

    ikeda様
    いつもお世話になっております。
    ご返信ありがとうございます。

    ●プラグインがコンフリクトを起こしていないか
    Welcart関連以外を削除したり無効にする等試しましたが改善しません
    ●JavaScript を最適化していないかなどご確認いただけますでしょうか
    特に何も手をつけていません。移転前(さくらのレンタルサーバ時代)は普通に動作していました。
    ●また、プラグインかサーバーでキャッシュの設定をされていましたらそちらを解除していただけますでしょうか。
    設定はしておりません。

    例えば商品リストページについてコンソールを見ると
    4件のエラーがあり下記の記載があります。

    Mixed content: load all resources via HTTPS to improve the security of your site
    To resolve this issue, load all resources over a secure HTTPS connection.

    影響を受けるリソース
    4 件のリソース
    名前 制限の状況
    jquery.cookie.js?ver=5.9.2 ブロック中
    jquery.cookie.js?ver=5.9.2 ブロック中
    cropped-fav-32×32.png ブロック中
    cropped-fav-192×192.png ブロック中

    Content: The page at ‘https://example.jp/wp-admin/admin.php?page=usces_itemedit’ was loaded over HTTPS, but requested an insecure script ‘http://example.jp/wp-content/plugins/usc-e-shop/js/jquery/jquery.cookie.js?ver=5.9.2’. This request has been blocked; the content must be served over HTTPS.

    のようにhttpで始まるURLを呼び出しているのが原因のように読めるのですが、こちらはadmin.phpを書き換えれば解消するのでしょうか?

    色々お手数をおかけして恐縮ですが、よろしくお願いいたします。

    #96361
    ikeda
    キーマスター

    yoiko 様
    お世話になっております。
    SSL を利用されていますでしょうか。
    その場合、Really Simple SSL などの SSL化プラグインを使用されてはいないでしょうか?
    また、移転前と WordPress およびプラグインの状態が同じなのであれば、
    サーバーの環境設定に問題があるということも考えれるかと思いますので、
    設定をご確認いただけたらと思います。

    #96362
    yoiko
    参加者

    ikeda様
    こんにちは。ご返信ありがとうございます。

    ご指摘いただき、再度サイトヘルスを確認したところWordPressアドレスとサイトアドレスがhttp〜になっていました。
    httpsでショップ・ダッシュボードともにアクセス出来ていたので気付きませんでした。

    https〜に修正したところ問題が解消しました。

    基本的なところでつまずいてしまい大変失礼いたしました。

    #96363
    ikeda
    キーマスター

    yoiko 様
    ご解決されたとのことで安心いたしました。ご報告ありがとうございました。

6件の投稿を表示中 - 1 - 6件目 (全6件中)
  • このトピックに返信するにはログインが必要です。