解決済配送方法が更新できない

フォーラム 使い方全般 【解決済】配送方法が更新できない

  • このトピックには7件の返信、3人の参加者があり、最後にAliciaにより5ヶ月、 3週前に更新されました。
8件の投稿を表示中 - 1 - 8件目 (全8件中)
  • 投稿者
    投稿
  • #97099

    ——————————————-
    WordPress のバージョン:5.9.3
    Welcart のバージョン:2.6.8
    PHP のバージョン:7.3
    Welcart専用の拡張プラグインとバージョン:WCEX Multi Price1.2.2
    ご利用の親テーマとバージョン :Welcart Basic 1.4.3
    ご利用の子テーマとバージョン :
    症状を確認したブラウザ:グーグルクローム
    サーバー【重要】:カラフルボックス box2
    ——————————————–

    Welcart Shop 配送設定>配送方法で
    右側の
    配送対象地域、指定時間帯、送料固定、代引き不可、クール区分
    などを変更して、更新ボタン(削除の隣のボタン)を押しても、クルクル回るマークが一瞬出るだけで更新されません。
    左側の「優先順位を上げる」などは有効です。

    試しにダミーサイトにワードプレスをインストールし、Welcartのプラグインのみを入れて、配送方法だけ設定したのち変更してみましたが、やはりだめです。

    数年前から上記のようになると思っており、当時のサーバーはエックスサーバーだったので、エックスサーバーでも同様になるのではないかと思います。

    改善できると助かります。
    よろしくお願いいたします。

    #97110
    ikeda
    キーマスター

    生まれ年ワインショップ 様
    こんにちは。
    恐れ入りますがご指摘の症状は弊社環境では再現いたしませんので
    下記のことをお試しいただけますでしょうか。

    ・Welcart Basic テーマを最新版にしてみる
    ・Welcart 公式プラグイン以外のプラグインを一つずつ停止してみる

    また、配送方法はいくつくらい設定されているのでしょうか。
    どうぞよろしくお願いいたします。

    #97116
    ikeda
    キーマスター

    追記させていただきます。
    JavaScript のエラーが出ていないかもあわせてご確認いただけますでしょうか。
    エラーが出ている場合はまずそちらをご解決いただく必要ががあるかと存じます。

    #97120
    Alicia
    参加者

    数年前から上記のようになると思っており、当時のサーバーはエックスサーバーだったので、エックスサーバーでも同様になるのではないかと思います。

    当方エックスサーバー wpX ですが、問題ありません。

    おそらくコンソールでJavaScript のエラーが出ていると思います。
    もしそうなら、サーバー側の設定でWAFが JavaScript を遮断していないか確認してみて下さい。
    wpX では、WAF設定の中のXSS対策がONになっていると、Welcart のクレジット決済設定が沈黙します。配送設定は更新はできますが、コンソールは派手にエラーが出ています。

    あと、ダミーサイトで初期状態ということは、セキュリティー関係のプラグインも動作させてないということですので、初歩的な確認ですがブラウザを代えてみる、パソコンを代えてみる、回線を代えてみるで上流に向かって環境を変化させて実験してみるのはどうでしょうか。

    #97130

    ありがとうございます。試してみて、再度ご報告いたします。

    #97131
    Alicia
    参加者

    追記です。
    WAFは、設定変更してもすぐには反映されませんから、最低15分くらいは置いてから試してみて下さい。

    #97142

    皆様、ありがとうございます。
    結果からお伝えすると、カラフルボックスのWAF設定をOFFにすると更新できました。

    試してみた手順としては、
    ダミーサイトで初期状態のものは最新バージョンでプラグインも何も入れていない、まっさらな状態だったのですが、これを別のブラウザで試すがダメ

    スマホでwifi接続なしで試すがダメ

    エックスサーバーでダミーサイトを作ってみると、出来ました!

    Alicia様のご助言に従い、カラフルボックスでWAFをオフにしてみる

    既存サイトでも更新できました!

    この度は本当にありがとうございました。
    (以前エックスサーバーでもダメだったというのは私の勘違いか、移転前にエックスサーバーでもWAFを設定していたかのどちらかだと思います。あいまいな情報で申し訳ございません)

    #97143
    Alicia
    参加者

    よかったですね。
    詳しい情報提供ありがとうございます。

8件の投稿を表示中 - 1 - 8件目 (全8件中)
  • このトピックに返信するにはログインが必要です。