1.9.30にアップデートすると管理ページがエラーとなる

ホーム フォーラム インストール 1.9.30にアップデートすると管理ページがエラーとなる

タグ: 

このトピックには4件の返信が含まれ、2人の参加者がいます。7 ヶ月前 bonbon さんが最後の更新を行いました。

5件の投稿を表示中 - 1 - 5件目 (全5件中)
  • 投稿者
    投稿
  • #89816

    bonbon
    参加者

    ——————————————-
    WordPress のバージョン:5.4
    Welcart のバージョン:1.9.30
    PHP のバージョン: 5.6.30 (モジュール版)
    Welcart専用の拡張プラグインとバージョン:なし
    ご利用のテーマ:Welcart Basic
    症状を確認したブラウザ:chrome、edge、IE11
    サーバー:minim
    SSLの利用:常時SSL
    ——————————————–

    お世話になります。
    1.9.30にバージョンアップすると、管理ページがエラーとなり表示されなくなります。
    管理ページにログインすると「サイトに重大なエラーがありました。 詳細については、サイト管理者のメール受信ボックスを確認してください。」と表示されます。
    もちろん管理ページは表示されません。
    1.9.29に戻すと正常な状態に直ります。

    解決策がございましたら、ご教授ください。
    よろしくお願いいたします。

    #89827

    yskysmr
    キーマスター

    こんにちは。

    管理者あてにメールが届いているかと思いますが、そのメールの内容をこちらに転記していただくか、弊社までお送りいただきたいのですが、可能でしょうか。

    #89832

    bonbon
    参加者

    ありがとうございます。
    以下、メールの内容です。
    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    こんにちは。

    WordPress 5.2から、サイトでプラグインやテーマが致命的なエラーを発生させた場合にそれを検知してこの自動メールでお知らせする機能が追加されました。

    今回の場合、WordPress がプラグイン Welcart e-Commerce でエラーを捉えました。

    まずはじめに、ご自分のサイト (https://******/) を開き、目に見える問題がないか確認してください。次に、エラーが発生したページ (https://******/wp-admin/edit.php?post_type=page) を開き、同様に問題がないか確認してください。

    この問題をさらに調査するにはサーバーホストに連絡してみてください。

    もしサイトが壊れていてダッシュボードに正常に接続できない場合、WordPress には特別な「リカバリーモード」があります。これによりダッシュボードに安全にログインし、さらに調査をすることができます。

    https://******/?action=enter_recovery_mode&rm_token=******

    サイトを安全に保つため、このリンクは 1日 で有効期限が切れます。ですが、心配なく。有効期限後にこのエラーが再度発生すれば新しいリンクをお送りします。

    この問題を解決しようとする際、以下の情報を聞かれるかもしれません。
    WordPress バーション5.4
    現在のテーマ: Welcart Basic Child (バージョン 1.0.0)
    現在のプラグイン: Welcart e-Commerce (バージョン 1.9.30)
    PHP バージョン5.6.30

    エラー詳細
    ===============
    エラータイプ E_ERROR が /******/wp-content/plugins/usc-e-shop/includes/update_check.php ファイルの 45 行目で発生しました。 エラーメッセージ: Cannot use object of type WP_Error as array

    #89838

    yskysmr
    キーマスター

    bonbon 様

    Development Version を修正いたしました。お手数をおかけして申し訳ございませんが、以下のリンク先より Development Version をダウンロードし、アップデートしてご利用ください。

    ▼Welcart Docs
    https://www.welcart.com/documents/

    また、PHP は 7.3 にアップグレードされることをお勧めいたします。

    #89841

    bonbon
    参加者

    ご対応ありがとうございます。
    しかしご指示いただいたDevelopment Versionを使っても、未だ症状は改善されません。
    さきほどワードプレスから送信されたメールの内容も以前のものと変わらず、以下の通りです。

    またご指摘いただいたPHPバージョンですが、サーバーの仕様によりPHPバージョン変更は不可との事でした。

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    この問題を解決しようとする際、以下の情報を聞かれるかもしれません。
    WordPress バーション5.4
    現在のテーマ: Welcart Basic Child (バージョン 1.0.0)
    現在のプラグイン: Welcart e-Commerce (バージョン 1.9.30)
    PHP バージョン5.6.30

    エラー詳細
    ===============
    エラータイプ E_ERROR が /******/wp-content/plugins/usc-e-shop/includes/update_check.php ファイルの 45 行目で発生しました。 エラーメッセージ: Cannot use object of type WP_Error as array

5件の投稿を表示中 - 1 - 5件目 (全5件中)

このトピックに返信するにはログインが必要です。