1.9.30にアップデートすると管理ページがエラーとなる(症状未改善のため再投稿)

ホーム フォーラム インストール 1.9.30にアップデートすると管理ページがエラーとなる(症状未改善のため再投稿)

タグ: 

このトピックには8件の返信が含まれ、4人の参加者がいます。2 ヶ月、 2 週間前 ono さんが最後の更新を行いました。

9件の投稿を表示中 - 1 - 9件目 (全9件中)
  • 投稿者
    投稿
  • #90055

    bonbon
    参加者

    ——————————————-
    WordPress のバージョン:5.4
    Welcart のバージョン:1.9.30
    PHP のバージョン: 5.6.30 (モジュール版)
    Welcart専用の拡張プラグインとバージョン:なし
    ご利用のテーマ:Welcart Basic
    症状を確認したブラウザ:chrome、edge、IE11
    サーバー:minim
    SSLの利用:常時SSL
    ——————————————–
    お世話になります。
    1.9.30にバージョンアップすると、管理ページがエラーとなり表示されなくなります。
    管理ページにログインすると「サイトに重大なエラーがありました。 詳細については、サイト管理者のメール受信ボックスを確認してください。」と表示され、管理ページは表示されなくなります。
    1.9.29に戻すと正常な状態に直ります。
    Development Versionを使用しても全く同じ症状となります。
    下記はエラー発生時に届くメールの内容です。(Development Versionでも全く同じメール内容です)

    ~~メール内容ここから~~~~~~~~~~~

    WordPress 5.2から、サイトでプラグインやテーマが致命的なエラーを発生させた場合にそれを検知してこの自動メールでお知らせする機能が追加されました。
    今回の場合、WordPress がプラグイン Welcart e-Commerce でエラーを捉えました。
    まずはじめに、ご自分のサイト (https://******/) を開き、目に見える問題がないか確認してください。次に、エラーが発生したページ (https://******/wp-admin/edit.php?post_type=page) を開き、同様に問題がないか確認してください。
    この問題をさらに調査するにはサーバーホストに連絡してみてください。
    もしサイトが壊れていてダッシュボードに正常に接続できない場合、WordPress には特別な「リカバリーモード」があります。これによりダッシュボードに安全にログインし、さらに調査をすることができます。
    https://******/?action=enter_recovery_mode&rm_token=******
    サイトを安全に保つため、このリンクは 1日 で有効期限が切れます。ですが、心配なく。有効期限後にこのエラーが再度発生すれば新しいリンクをお送りします。
    この問題を解決しようとする際、以下の情報を聞かれるかもしれません。
    WordPress バーション5.4
    現在のテーマ: Welcart Basic Child (バージョン 1.0.0)
    現在のプラグイン: Welcart e-Commerce (バージョン 1.9.30)
    PHP バージョン5.6.30
    エラー詳細
    ===============
    エラータイプ E_ERROR が /******/wp-content/plugins/usc-e-shop/includes/update_check.php ファイルの 45 行目で発生しました。 エラーメッセージ: Cannot use object of type WP_Error as array

    ~~メール内容ここまで~~~~~~~~~~~

    解決策がございましたら、ご教授ください。
    よろしくお願いいたします。

    #90071

    nanbu
    参加者

    こんにちは

    ご指摘ありがとうございます。
    ご指摘の件は既に修正済みです。まもなくV1.9.31としてリリースされますが、お急ぎでしたら下記から修正版をダウンロードして、Welcart(usc-e-shop)を入れ替えてみてください。

    https://downloads.wordpress.org/plugin/usc-e-shop.zip

    #90081

    bonbon
    参加者

    ご対応ありがとうございます。
    しかしたった今ご指定のファイルをダウンロードし、適用しましたが、未だ症状は改善されません。
    同じく「サイトに重大なエラーがありました」となります。

    #90171

    bonbon
    参加者

    何度も投稿し申し訳ございませんが、ご指定のファイルを適用しても未だ症状が改善されておりません。
    今一度ご確認いただけないでしょうか。

    管理者に送られてくるメールは以下の内容です。

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    この問題を解決しようとする際、以下の情報を聞かれるかもしれません。
    WordPress バーション5.4.1
    現在のテーマ: Welcart Basic Child (バージョン 1.0.0)
    現在のプラグイン: Welcart e-Commerce (バージョン 1.9.30)
    PHP バージョン5.6.30

    エラー詳細
    ===============
    エラータイプ E_ERROR が /xxxxxx/wp-content/plugins/usc-e-shop/includes/update_check.php ファイルの 45 行目で発生しました。 エラーメッセージ: Cannot use object of type WP_Error as array

    • この返信は3 ヶ月、 2 週間前に  bonbon さんが編集しました。
    #90290

    ono
    参加者

    横から失礼します。私も全く同じ症状になります。
    修正版を入れても「サイトに重大なエラーがありました。 」となります。

    最新verのwelcartにUPしてからこのような症状になったので、多分こちらのプラグインが原因ではないかと思います。

    【エラーメッセージは下記です。】
    ————————
    Fatal error: Cannot use object of type WP_Error as array in /home/sites/truefood/web/site/wp-content/plugins/usc-e-shop/includes/update_check.php on line 45
    サイトに重大なエラーがありました。 詳細については、サイト管理者のメール受信ボックスを確認してください。
    ————————-

    対応方法が解らずお手上げ状態なのですが、古いバージョンを入手出来ないでしょうか?
    Wardpressの管理画面にログイン出来ずに困っておりまして。。

    お手数をおかけしますが、宜しくお願いいたします。

    ——————————————-
    WordPress のバージョン:最新
    Welcart のバージョン:最新
    PHP のバージョン:多分、7.2
    Welcart専用の拡張プラグインとバージョン:拡張は無い。
    ご利用のテーマ:自作子テーマ
    症状を確認したブラウザ:chrome edgeなど
    サーバー:4stars
    SSLの利用:利用している

    • この返信は2 ヶ月、 4 週間前に  ono さんが編集しました。
    #90294

    ono
    参加者

    度々失礼します、大野です。

    先の連絡でPHPのバージョンが「多分、7.2」とお伝えしていましたが、改めて確認したところ「5.6.30」でした。
    記載の誤り大変恐縮です。

    こちらが原因なのでしょうか?
    お手数をおかけしますが、教えていただけたらありがたいです。
    宜しくお願いいたします。

    #90295

    ono
    参加者

    度々失礼します、お忙しいところ大変恐縮です。
    使用サーバの「4stars」に問い合わせた所、phpは「5.6.30」以上のバージョンには出来ないようです。

    お手上げ状態でして(汗)、何か良い方法あれば教えていただけたらありがたいです。
    ※もしくは、今まで使えていた一つ前のバージョンのデータの入手方法があれば、教えていただけたらありがたいです。

    お手数をおかけしますが、宜しくお願いいたします。
    大野

    #90316

    yskysmr
    キーマスター

    ono 様

    Welcart は次期バージョンより、PHP 5.6 では利用できなくなります。
    Welcart の古いバージョンはプラグインページよりダウンロードしてください。

    ▼プラグインページ
    https://ja.wordpress.org/plugins/usc-e-shop/advanced/

    ただ、古いバージョンを使い続けるのではなく、サーバーの移行をお勧めいたします。

    #90352

    ono
    参加者

    yskysmrさま

    返信が遅くなり申し訳ありません。
    ご対応、本当にありがとう御座いました!

    お手数おかけしまして大変恐縮です。

9件の投稿を表示中 - 1 - 9件目 (全9件中)

このトピックに返信するにはログインが必要です。