PayPalの導入でエラーがでます。

2012 年 2 月 14 日

ホーム フォーラム 使い方全般 PayPalの導入でエラーがでます。

このトピックには4件の返信が含まれ、2人の参加者がいます。5 年、 9 ヶ月前 nyano さんが最後の更新を行いました。

5件の投稿を表示中 - 1 - 5件目 (全5件中)
  • 投稿者
    投稿
  • #51288

    nyano
    参加者

    動作に関するご質問の場合は必ずご記入ください。


    WordPress のバージョン:3.3.1

    Welcart のバージョン:1.1.1

    ご利用のテーマ:Welcart Default Theme 1.1

    症状を確認したブラウザ:chrome IE8

    サーバー(会社名、サービス名):ロリポップ ロリポプラン

    SSLの利用: 共用SSL

    WordPress のパーマリンク設定:デフォルト


    初めて導入を進めております。よろしくお願いいたします。

    PayPalの決済を行うと以下のエラーが表示されます。

    ご注文が完了しませんでした。

    (error 0)

    ログ(acting_transaction.log)を確認し、いろいろ検索してみたのですが、解決方法がわかりませんでした。

    以下のログとなっております。

    [2012-02-14 23:17:32] PayPal : SetExpressCheckout API call failed. Error Code:[10002] Error Severity Code:[Error] Short Error Message:Security error Detailed Error Message:Security header is not valid

    [2012-02-14 23:17:34] PayPal : GetExpressCheckoutDetails API call failed. Error Code:[10002] Error Severity Code:[Error] Short Error Message:Security error Detailed Error Message:Security header is not valid

    よろしくお願いいたします。

    #63839

    nanbu
    参加者

    こんにちは。

    恐らく設定ミスで認証が通っていないのだと思います。再度こちらをご覧になってじっくりとミスがないかご確認いただけますでしょうか。

    https://www.welcart.com/documents/manual-2/%E3%82%AF%E3%83%AC%E3%82%B8%E3%83%83%E3%83%88%E6%B1%BA%E6%B8%88%E8%A8%AD%E5%AE%9A#paypal

    なお、ロリポップは初期値PHPセーフモードだったと思いますが、通常モードでご利用いただいていますでしょうか。

    #63840

    nyano
    参加者

    ロリポップですべてのドメインに対してsafemodeをOFFに再度行って、

    APIユーザー名、APIパスワード、署名を再設定したのですが、同じでした。

    ロリポップはOpenSSL対応なので使えるという認識ですが、2006年からの契約と古いのでその辺でサーバの問題があるのでしょうか。

    #63841

    nanbu
    参加者

    OpenSSLはほとんどのサーバーで標準で入っているかと思います。心配なのはコンパネでsafemodeがOFFになっているにもかかわらず実際にはオフになっていないなんて言うことも実際にはあるようですので、phpinfo()を確認されてみてはいかがでしょうか。

    どうしてもうまく行かない場合は有償となりますが調査させていただきますので「Welcartレスキュー」にお問い合わせください。

    #63842

    nyano
    参加者

    phpinfo() でも OFFでした。

    新たに、ロリポップのお試しで契約をして、インストールしてみましたが結果は同じ結果でした。

    あきらめるか、別のサーバで検討するかするようにいたします。

    ありがとうございました。

5件の投稿を表示中 - 1 - 5件目 (全5件中)

このトピックに返信するにはログインが必要です。