[解決済み] SSL設定で躓いています

ホーム フォーラム 使い方全般 [解決済み] SSL設定で躓いています

このトピックには4件の返信が含まれ、2人の参加者がいます。7 年、 4 ヶ月前 onlyone さんが最後の更新を行いました。

5件の投稿を表示中 - 1 - 5件目 (全5件中)
  • 投稿者
    投稿
  • #50250

    onlyone
    参加者

    Welcart のバージョン:0.8.1

    症状を確認したブラウザ:Sleipnir、Chrome

    サーバー(会社名、サービス名):エックスサーバー

    SSLの利用:専用SSL

    WordPress のパーリンク設定:/%category%/%post_id%.html/

    補足情報:他社で購入したテーマ


    いつもお世話になっております。

    SSL設定を完了した後、WelcartのSSL設定も済ませて

    買い物カゴ内の動作確認したところ

    「Not Found」となってしまいました。

    別のスレッドを調べたところ

    パーマリンクを/%category%/%post_id%.html/に変えて

    上手くいった事例があったので試してみたら

    買い物カゴには進みましたが警告が出てしまいました。

    (LightBox2を有効にしていましたが、SSL設定前にLightBox2のスレッドを見て

     LightBox2は停止状態にしていました。)

    そこでfunctions.php におまじない(強化版)書き加えてアップしましたら

    再び「Not Found」となってしまいましたので、

    おまじないを加える前のfunctions.phpに戻しましたが

    「Not Found」から直らなくなりました。(買い物カゴに進まない)

    (間違えて上書きしてしまったと思い確認しましたが元のPHPのままでした)

    何故データを戻したのに元に戻らなのか、(SSLを外すと正常に機能します)

    また買い物カゴで「Not Found」になってしまう原因が何なのか

    正直判らないでいます。

    レスキューを考えましたが、PHP書き変える前の「Not Found」は

    別でもよく話題に上がっているので、

    レスキュー前に一応フォーラムに投稿しました。

    お手数をお掛け致しますが宜しくお願い致します。

    #61459

    onlyone
    参加者

    自己レスです。

    朝確認したら警告は出るもののカゴは動作しました。

    お騒がせしてすみません。

    ただ警告の問題が残されてしまいました。

    他の記事を今読み漁っていますが

    まだ解決の糸口すら判らないでいます。

    アドバイスをお願い致します。

    #61460

    nanbu
    参加者

    こんにちは。

    何か大きな変更設定をした場合は、セッションの問題がありますのでブラウザを立ち上げなおしましょう。

    おまじないを設置してもSSL警告が出るのは、他のプラグインやテーマテンプレートに原因があります。警告の出るページのソースを隅から隅まで確認してください。画像、CSS、JavaScript の読み込みでhttp:// となっているところが犯人です。

    #61461

    onlyone
    参加者

    ご回答ありがとうございます。

    犯人はテーマ内の画像ですね。

    再度おまじないを入れたら無事にSSL化出来ました。

    ありがとうございました。

    #61462

    onlyone
    参加者

    自己レスです。

    当スレッドにある「Not Found」になった原因は別にありました。

    その詳細は別のスレッドにて解決致しました。

    ▽カートが不安定?(時々Not Found)

    https://www.welcart.com/forum/topic.php?id=574

5件の投稿を表示中 - 1 - 5件目 (全5件中)

このトピックに返信するにはログインが必要です。