SSL の修正版について

2010 年 9 月 20 日

ホーム フォーラム 使い方全般 SSL の修正版について

このトピックには5件の返信が含まれ、2人の参加者がいます。7 年、 2 ヶ月前 grace さんが最後の更新を行いました。

6件の投稿を表示中 - 1 - 6件目 (全6件中)
  • 投稿者
    投稿
  • #49962

    nanbu
    参加者

    こんにちは。

    SSL の動作に関してたくさんの情報提供ありがとうございました。

    お陰さまで、改めてSSLを見直すことができました。

    SSLを実現するには次の点に気をつけなくてはいけないようです。

    ・SSLのタイプ(独自ドメイン専用SSL、サブドメイン型共用SSL、サブディレクトリ型共用SSL)

    ・パーマリンク利用の有無

    SSLの不具合での主な症状は、ページが見当たらない、セッションが渡らない(カートが空になってしまう)などでした。

    いくつかの環境で動作を確認し、現在Development Version で正常動作しています。

    ただ、今回の修正はテーマのテンプレートにまで影響を及ぼしています。以下はその修正内容です。

    welcart_default/sidebar.php 2箇所のアンカーのhref を変更しています。

    <a href="<?php echo USCES_MEMBER_URL; ?>"&page=lostmemberpassword title="****
    <a href="<?php echo USCES_MEMBER_URL; ?>"&page=newmember title="****
      ↓
    <a href="<?php echo USCES_LOSTMEMBERPASSWORD_URL; ?>" title="****
    <a href="<?php echo USCES_NEWMEMBER_URL; ?>" title="****

    welcart_default/header.php 「清算する」リンクのhref を変更しています。

    <a href="<?php echo USCES_CART_URL; ?>&customerinfo">****
      ↓
    <a href="<?php echo USCES_CUSTOMER_URL; ?>">****

    プラグインのtemplates ディレクトリ内のファイルを退避させている方は次の修正も必要になります。

    templates/member/login.php 内容は上記sidebar.php と同じです。

    <a href="<?php echo USCES_MEMBER_URL; ?>"&page=lostmemberpassword title="****
    <a href="<?php echo USCES_MEMBER_URL; ?>"&page=newmember title="****
      ↓
    <a href="<?php echo USCES_LOSTMEMBERPASSWORD_URL; ?>" title="****
    <a href="<?php echo USCES_NEWMEMBER_URL; ?>" title="****

    templates/member/lostpassword.php

    $html .= '<a href="' . USCES_MEMBER_URL . '&page=login" title="'****
      ↓
    $html .= '<a href="' . USCES_LOGIN_URL . '" title="'****

    この様な修正は避けたかったのですが、URLを動的に変更する必要が出てきたため避けられないこととなってしまいました。正式版でも同じ修正が必要となります。

    今回、以下の環境で正常動作を確認しました。

    ★さくらスタンダード

     サブドメイン型共用SSL、パーマリンク利用

    ★Xserver X10

     サブディレクトリ型共用SSL、パーマリンク利用

    ★NTT/Verio

     サブドメイン型共用SSL、独自ドメイン専用SSL、パーマリンク利用

    各サーバーで動作が異なりましたので苦労しましたが、何とか吸収できました。他のサーバーでどのような状況になるか、また皆さんのご協力をお願いいたします。

    ※注 依然サブディレクトリ型共用SSLの利用はお勧めしておりません。

    #60363

    grace
    参加者

    こんにちは。

    上記の Development Version をインストールして検証してみたのですが、

    SSL を通したページにアクセスすると “ページが見当たらない” になってしまいます。

    修正前の V0.7.1 では正常でした。

    V0.7.1 でのリンクURLは

    共用SSLのURL/?page_id=○&usces=…… といった感じでしたが、

    Development Version では

    共用SSLのURL/usces-member/?uscesid=…… という具合に、URL が変わっています。

    これで正常なのでしょうか?

    環境は

    サーバー:レンタルサーバーミニム(Apache)

    MySQL:5.0.45

    PHP:5.1.6

    パーマリンクは

    /%category%/%postname%.html

    に設定。

    ちなみに、現在は非推奨の “サブディレクトリ型共用SSL” を使用しております。

    #60364

    nanbu
    参加者

    こんにちは。

    テンプレートの修正はされましたか?

    テンプレートを修正しなくてはちゃんと表示されないリンクは次の通りです。

    ・メインナビ下の「ログイン」「ログアウト」「カート」「精算する」リンク。

    ・ログインフォームの下の「パスワードをお忘れですか?」と「新規ご入会はこちら」リンク。

    ・新パスワード取得ページの「ログイン」リンク。

    パラメーターのusces はuscesid に変更しました。これによる影響は特にありません。

    #60365

    grace
    参加者

    おつかれさまです。

    テンプレートの修正は問題ないと思います。

    パーマリンクは

    /%category%/%postname%.html

    に設定していると書きましたが、デフォルトのパーマリンクに設定すると正常に動作します。

    パーマリンクが /%category%/%postname%.html の時のリンクURLは

    共用SSLのURL/usces-member/?uscesid=……

    パーマリンクがデフォルトの時のリンクURLは

    共用SSLのURL/?page_id=○&uscesid=……

    になります。

    #60366

    nanbu
    参加者

    grace さん、申し訳ありません。

    Development Version のファイルがうまく更新されていませんでした。

    再度更新しましたので、お手数ですがもう一度アップグレードしてみていただけますでしょうか。

    よろしくお願いします。

    #60367

    grace
    参加者

    nanbuさん、こんばんは。

    再度アップグレードしたら正常に動作しました。

    どうもありがとうございました。

6件の投稿を表示中 - 1 - 6件目 (全6件中)

このトピックに返信するにはログインが必要です。