WCEX Multiple Shipping+Paypal決済(WPP)の不具合

2017 年 8 月 8 日

ホーム フォーラム 拡張プラグイン WCEX Multiple Shipping+Paypal決済(WPP)の不具合

このトピックには9件の返信が含まれ、2人の参加者がいます。2 ヶ月、 2 週間前 runta さんが最後の更新を行いました。

10件の投稿を表示中 - 1 - 10件目 (全10件中)
  • 投稿者
    投稿
  • #83648

    runta
    参加者

    以下の2つの条件で注文された時に以下の不具合が出てしまいます。
    (条件1のみ又は条件2のみの場合は不具合は出ません。)

    条件1:複数配送先プラグイン WCEX Multiple Shipping
    条件2:Paypal決済(WPP)

    不具合の内容は以下のとおりです。

    注文メール
    ・配送先が表示されない。
    ・商品名が表示されない。

    受注データ編集
    ・送り先が表示されない。
    ・商品名が表示されない。
    ・金額が間違っている。(総合計:8600円が1100円と表示されている。)

    よろしくお願い致します。

    #83657

    runta
    参加者

    環境は以下のとおりです。
    よろしくお願い致します。
    ——————————————-
    WordPress のバージョン:4.7.5
    Welcart のバージョン:1.8.8
    Welcart専用の拡張プラグイン:WCEX Multiple Shipping
    ご利用のテーマ:オリジナル
    症状を確認したブラウザ:Safari
    サーバー:エックスサーバー
    SSLの利用:常時SSL
    WordPress のパーマリンク設定:/%postname%.html
    ——————————————–

    #83662

    yskysmr
    キーマスター

    こんにちは。

    動作に関するご質問の場合は、ご利用の環境をご記入ください。
    ——————————————-
    WordPress のバージョン:(例 4.7.4)
    Welcart のバージョン:(例 1.9.2)
    Welcart専用の拡張プラグイン:(例 DLSeller、Mobileなど)
    ご利用のテーマ:(例 WelcartBasicの自作子テーマ)
    症状を確認したブラウザ:
    サーバー:(会社名、サービス名)
    SSLの利用:(例 常時SSL)
    WordPress のパーマリンク設定:(例 /archives/%post_id%/)
    ——————————————–

    • この返信は3 ヶ月、 2 週間前に  yskysmr さんが編集しました。
    #83693

    runta
    参加者

    環境は以下のとおりです。
    よろしくお願い致します。
    ——————————————-
    WordPress のバージョン:4.7.5
    Welcart のバージョン:1.8.8
    Welcart専用の拡張プラグイン:WCEX Multiple Shipping
    ご利用のテーマ:オリジナル
    症状を確認したブラウザ:Safari
    サーバー:エックスサーバー
    SSLの利用:常時SSL
    WordPress のパーマリンク設定:/%postname%.html
    ——————————————–

    #83710

    yskysmr
    キーマスター

    runta 様

    仰るとおりの症状を確認いたしました。修正までしばらくお待ちください。ご不便をおかけしまして申し訳ございません。

    #83772

    yskysmr
    キーマスター

    runta 様

    WCEX Multiple Shipping の v1.1.4 をリリースいたしました。会員ページよりダウンロードして、アップデートしてください。
    また、修正を適用するには Welcart の Development Version が必要です。Development Version はこちらからダウンロードできます。
    Welcart ドキュメンテーション
    Welcart を Development Version にアップデートしてお使いください。

    #83895

    runta
    参加者

    yskysmr 様
    お陰様で問題なく動作しました
    ただ、
    > Development Version が必要
    とのことで、これにつきまして、

    Development Version にアップグレードする方法


    にて
    > 本稼動されているショップでは無闇にインストールしない方が無難
    > 本リリースの自動アップグレードでも削除されます
    とのことで、この修正が本リリースでも上手く機能するように本リリースの方にも反映して頂けると助かります
    また、会員ログイン後の購入履歴にて
    Warning: Invalid argument supplied for foreach() in /home/*****/*****/*****/wp-content/plugins/wcex_multiple_shipping/wcex_multiple_shipping.php on line 3292
    と出ます(WordPressの WP_DEBUG が false でも)
    今の所、該当箇所を
    foreach( (array) $groupcart as $index => $cart_row ){
    として対処していますが、この辺も反映して頂けると助かります

    この度は、誠に有難う御座いました

    • この返信は2 ヶ月、 2 週間前に  yskysmr さんが編集しました。
    #83898

    yskysmr
    キーマスター

    runta 様

    この度はお手数をおかけいたしました。
    Development Version は、将来正式にリリースされる開発バージョンですので、今回の修正が消えることはありません。

    > 本リリースの自動アップグレードでも削除されます
    というのは、Welcart 本体のソースファイルをご自身で改変されている場合、Development Version に限らず、Welcart をアップデートする度に改変箇所は上書きされます、という意味になります。

    また、恐れ入りますが WCEX Multiple Shipping のバージョンを教えていただけますでしょうか。

    #83899

    runta
    参加者

    yskysmr 様
    バージョンは1.1.4です。

    すみませんが、上の投稿の/home/から始まる文字列を削除して頂くことは可能でしょうか。
    (こちらの情報が含まれておりますので)
    それか編集の方法があればやり方を教えて頂きたいです。
    よろしくお願い致します。

    #83907

    runta
    参加者

    yskysmr 様
    ご対応ありがとうございました。

10件の投稿を表示中 - 1 - 10件目 (全10件中)

このトピックに返信するにはログインが必要です。