解決済WCEX SKU Selectを入れただけでエラーになります

フォーラム 拡張プラグイン 【解決済】WCEX SKU Selectを入れただけでエラーになります

  • このトピックには2件の返信、2人の参加者があり、最後にSuzukimaiMにより1ヶ月前に更新されました。
3件の投稿を表示中 - 1 - 3件目 (全3件中)
  • 投稿者
    投稿
  • #97646
    SuzukimaiM
    参加者

    ——————————————-
    WordPress のバージョン:6.01(最新)
    Welcart のバージョン:2.6.10(最新)
    PHP のバージョン:8.0.21
    Welcart専用の拡張プラグインとバージョン:WCEX SKU Select 1.3.2(最新)
    ご利用の親テーマとバージョン :Welcart Basic 1.5(最新)
    ご利用の子テーマとバージョン :Welcart Basicをカスタマイズしたオリジナル
    症状を確認したブラウザ:Chrome、safari
    サーバー【重要】:KAGOYA
    ——————————————–

    お世話になっております。
    WCEX SKU Selectを購入して導入しましたが
    プラグインを有効にして商品の更新をしようとしたら、以下のエラーが表示されます。(実際はもっと長いです)

    Fatal error: Uncaught Error: Undefined constant “INPUT_REQUEST” …./wp-content/plugins/usc-e-shop/functions/utility.php

    他のプラグインを無効にしましたが変わらず、WCEX SKU Selectを無効にすると症状が出なくなります。
    環境の各バージョンの問題はありますでしょうか?

    #97651
    ikeda
    キーマスター

    SuzukimaiM 様
    こんにちは。
    Welcart は今のところ PHP8.0 には未対応となっておりますので、こちらが原因かと思われます。
    システム要件にございますとおり PHP7.0 から 7.4 にしていただき、再度ご確認をいただけたらと思います。
    PHP8.0 の対応を進めている最中ですので、何卒ご了承いただきたく存じます。

    #97655
    SuzukimaiM
    参加者

    ikeda様

    お世話になっております。
    PHPのバージョンを7.4に変更しましたら、商品登録やSKU Selectの作動を確認できました。
    ご意見ありがとうございました。

3件の投稿を表示中 - 1 - 3件目 (全3件中)
  • このトピックに返信するにはログインが必要です。