Welcart Shop クレジット決済設定 が表示されない

2017 年 2 月 8 日

ホーム フォーラム バグ報告 Welcart Shop クレジット決済設定 が表示されない

このトピックには4件の返信が含まれ、2人の参加者がいます。8 ヶ月前 fafa さんが最後の更新を行いました。

5件の投稿を表示中 - 1 - 5件目 (全5件中)
  • 投稿者
    投稿
  • #82078

    fafa
    参加者

    いつもお世話になっております。
    この度不具合が解決せず投稿させて頂きます。

    ——————————————-
    WordPress のバージョン:WordPress 4.7.2
    Welcart のバージョン:1.9.1
    ご利用のテーマ:Earth WelCart
    症状を確認したブラウザ:クローム サファリ エッジ IE
    サーバー(会社名、サービス名):kagoya専用サーバー
    SSLの利用: 有
    WordPress のパーマリンク設定:/%category%/%postname%/
    ——————————————–

    を使用しています。

    管理画面より、
    クレジット決済設定をクリックすると

    Welcart Shop クレジット決済設定

    というタイトルのみが表示され、詳細設定ができない状態です。

    一度使用中のプラグインを全部オフにし確認しても治りませんでした。

    jqのバージョンが関係しているのでしょうか。
    稼働中のサイトですが急に表示されなくなりました。
    (wp,welcartのバージョンUPは行っていたと思います)

    大至急何とかしなければいけません。
    恐れ入りますが、解決方法をご教示いただけないでしょうか?
    助けて下さい。
    よろしくお願いします。

    下記エラーログです

    load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,jquery-color,utils&ver=4.7.2:9 JQMIGRATE: Migrate is installed, version 1.4.1
    admin.php?page=usces_settlement:236 Uncaught TypeError: $.cookie is not a function
    at HTMLDocument.<anonymous> (admin.php?page=usces_settlement:236)
    at fire (jquery-1.11.3.js:3148)
    at Object.fireWith [as resolveWith] (jquery-1.11.3.js:3260)
    at Function.ready (jquery-1.11.3.js:3472)
    at HTMLDocument.completed (jquery-1.11.3.js:3503)
    load-scripts.php?c=1&load[]=jquery-ui-core,jquery-ui-widget,jquery-ui-tabs,jquery-ui-mouse,jquery-u…:356 Uncaught TypeError: Cannot read property ‘hasClass’ of undefined
    at HTMLDocument.<anonymous> (load-scripts.php?c=1&load[]=jquery-ui-core,jquery-ui-widget,jquery-ui-tabs,jquery-ui-mouse,jquery-u…:356)
    at HTMLDocument.dispatch (jquery-1.11.3.js:4670)
    at HTMLDocument.elemData.handle (jquery-1.11.3.js:4338)
    at Object.trigger (jquery-1.11.3.js:4579)
    at HTMLDocument.<anonymous> (jquery-1.11.3.js:5289)
    at Function.each (jquery-1.11.3.js:384)
    at jQuery.fn.init.each (jquery-1.11.3.js:136)
    at jQuery.fn.init.trigger (jquery-1.11.3.js:5288)
    at Object.<anonymous> (load-scripts.php?c=1&load[]=jquery-ui-core,jquery-ui-widget,jquery-ui-tabs,jquery-ui-mouse,jquery-u…:355)
    at fire (jquery-1.11.3.js:3148)
    (anonymous) @ load-scripts.php?c=1&load[]=jquery-ui-core,jquery-ui-widget,jquery-ui-tabs,jquery-ui-mouse,jquery-u…:356
    dispatch @ jquery-1.11.3.js:4670
    elemData.handle @ jquery-1.11.3.js:4338
    trigger @ jquery-1.11.3.js:4579
    (anonymous) @ jquery-1.11.3.js:5289
    each @ jquery-1.11.3.js:384
    each @ jquery-1.11.3.js:136
    trigger @ jquery-1.11.3.js:5288
    (anonymous) @ load-scripts.php?c=1&load[]=jquery-ui-core,jquery-ui-widget,jquery-ui-tabs,jquery-ui-mouse,jquery-u…:355
    fire @ jquery-1.11.3.js:3148
    fireWith @ jquery-1.11.3.js:3260
    done @ jquery-1.11.3.js:9314
    callback @ jquery-1.11.3.js:9718

    #82107

    yskysmr
    キーマスター

    こんにちは。

    まず、「今まで正常に稼働していたものが急に」というのは、必ず契機があったはずですが、お心当たりはございますでしょうか。
    また、JavaScript の検証をする際には、必ずブラウザのキャッシュを削除してください。(プラグインを停止しただけでは反映されない場合もあります)

    このエラーログはどこで表示されるものでしょうか。また、Welcart Shop>ホームの下の方の、「ご利用の環境」のところの情報を教えてください。

    #82120

    fafa
    参加者

    ご返信ありがとうございます。

    契機としては、wordpress welcartのバージョンアップだと思っています。
    バージョンアップを行ってから表示ができなくなりました。

    ログは、
    クロームのコンソール機能にて表示させたエラーです。

    サーバー Apache/2.4.6 (CentOS) OpenSSL/1.0.1e-fips PHP/7.0.9 mod_perl/2.0.9dev Perl/v5.16.3
    MySQL 5.6.32
    PHP 7.0.9 memory[global]:128M [locale]:256M [usage]:34M
    simplexml, curl, gd, json, mbstring, openssl

    環境はこのようになっています。

    以前はクレジットの設定ができていたのでサーバー環境は問題ないかと思っていました。
    よろしくお願いします。

    Attachments:
    You must be logged in to view attached files.
    #82159

    yskysmr
    キーマスター

    fafa 様

    Welcart は PHP7 には対応しておりません。何卒ご了承くださいますよう、お願いいたします。
    独自に JQuery を読み込んでいるところなどはありませんでしょうか。

    #82169

    fafa
    参加者

    ご返信ありがとうございます。

    もともと現環境で使えていたのに使えなくなった。
    そして、PHP5.6にしてもエラーが発生していました。

    JQの独自利用はありません。

    ですが、今回admin_settlementのエラーを確認し、
    修正することで解決しました。

    取り急ぎこちらで運用が出来そうなのでこのまま行こうかと思います。
    お騒がせして申し訳ございません。
    ありがとうございました。

5件の投稿を表示中 - 1 - 5件目 (全5件中)

このトピックに返信するにはログインが必要です。