返信先: アップデート後、購入時に決済エラーになる。

ホーム フォーラム インストール アップデート後、購入時に決済エラーになる。 返信先: アップデート後、購入時に決済エラーになる。

#78093

hidetatsu
参加者

Paypalのセキュリティ計画について、paypal、xserverの担当者とのやり取りをした内容の情報共有です。

・スケジュール
TLS 1.2および HTTP/1.1のアップグレード  2016年6月17日
SSL証明書のSHA-256へのアップグレード   2016年6月17日
HTTPSでのIPN認証             2016年9月30日
※先行して、sandbox使用時が対応されており、条件を満たさない場合はエラーとなる。

以下、paypal担当者より指摘されました確認事項となります。
・ご利用のウェブ環境がSHA-256アルゴリズムとVeriSignの2048ビットG5ルート証明書に対応していること
・PHPを利用されている場合は、CURLのLibraryを7.34.0以上のバージョンとなっていること
※curl -Vコマンドで確認可能

以下、xserver担当者の回答です。
・証明書は「VeriSign Class3 Public Primary Certification Authority – G5」が設置されている。(条件を満たしている)※別の証明書については未確認
・PHPバージョンを【5.6】または【7.0】に設定すれば、curlはバージョン【7.47.1】となる。※curlのバージョンのみを変更することはできない。

以上となります。