返信先: WP更新後(4.9)のPHPファイルが更新できない

ホーム フォーラム バグ報告 WP更新後(4.9)のPHPファイルが更新できない 返信先: WP更新後(4.9)のPHPファイルが更新できない

#90192

——————————————-
WordPress のバージョン:(5.4.2)
Welcart のバージョン:(1.9.30)
PHP のバージョン:(7.2.29)
Welcart専用の拡張プラグインとバージョン:(なし)
ご利用のテーマ:(WelcartBasic の自作子テーマ)
症状を確認したブラウザ:Mac版 Chrome 83.0.4103.97(Official Build) (64 ビット)
サーバー: エックスサーバー X10
SSLの利用:(常時SSL)
——————————————–
プラグインは、welcart以外を無効化しています。
テーマファイルのfunctions.phpにも何も記述していない状態です。
テーマファイルのファイルのパーミッションは666です。ほかのパーミッションにもいろいろ変更してみました。

このような状態で、WordPressのテーマ編集機能を使って、テーマファイルを編集した際に、

「致命的なエラーをチェックするためにサイトと通信できないため、PHP の変更は取り消されました。SFTP を使うなど、他の手段で PHP ファイルの変更をアップロードする必要があります。」

と表示されてファイルを上書きできない現象が発生しています。

SFTPなどでファイルを直接アップロードして作業することはできますが、ブラウザからの編集ができない状態です。

以下の様なURLの編集画面です。
https://サイトURL/wp-admin/theme-editor.php?file=index.php&theme=テーマ名

ログインユーザーのプロフィール
『シンタックスハイライト コード編集中のシンタックスハイライトを無効化』をオンにしても、変わりません。

Welcartを無効化すると、通常の上書きができます。
Welcartを有効化すると、編集が上書きできず、上記のエラーが表示されます。

Welcartが原因だと思いますが、何か他に調整できることはありますか。