「エラーコード:K20」について

ホーム フォーラム 使い方全般 「エラーコード:K20」について

このトピックには3件の返信が含まれ、2人の参加者がいます。1 週、 3 日前 yskysmr さんが最後の更新を行いました。

4件の投稿を表示中 - 1 - 4件目 (全4件中)
  • 投稿者
    投稿
  • #88832

    hombo
    参加者

    ——————————————-
    WordPress のバージョン:4.4.1
    Welcart のバージョン:1.6.2.1511192
    ご利用のテーマ:オリジナル
    症状を確認したブラウザ:chrome
    サーバー(会社名、サービス名):さくらサーバー
    SSLの利用:あり 
    ソニーペイメントサービス利用
    ——————————————–

    先日、クレジットカード利用でエラー表示になると連絡を受け、
    試してみたところ、以下のようなエラー表示がでました。

    ーーーーーーーーーーーーーー
    エラー
    ERROR
    ご注文が完了しませんでした。
    (error 0)
    エラーコード:K20
    「カード番号再入力」
    ーーーーーーーーーーーーーー

    最後にクレジットカード決済が正常に機能していたのは、半年ほど前で、
    それ以降、特にこちらで設定をいじっておりません。

    このエラーについて、何かご存知の方いらっしゃいましたらご教授いただけますと幸いです。
    どうぞよろしくおねがいいたします。

    #88833

    yskysmr
    キーマスター

    こんにちは。

    K20 のエラーは、ご利用のサイトがまだトークン決済の設定をされていない場合に発生します。WordPress 、Welcart 共にバージョンが低すぎるようです。他のプラグインの兼ね合いもあるかと存じますが、全てのプラグインを最新バージョンにアップデートしてください。
    また、トークン決済認証コードがおわかりでない場合は、マーチャントID を添えて、ソニーペイメントサービスに「トークン決済認証コード」をお問い合わせください。

    #88837

    hombo
    参加者

    早速、ご回答いただき誠にありがとうございます。

    WordPress 、Welcartのバージョンですが、おっしゃるとおり、HPの作り上、アップデートをしない方向で模索しているのですが、トークン決済の設定は、バージョンアップしないとできないのでしょうか?

    お手数ですが、ご回答いただけますと幸いです。
    どうぞよろしくおねがいいたします。

    #88838

    yskysmr
    キーマスター

    hombo 様

    ソニーペイメントサービスの決済モジュール(WelcartPay、e-SCOTT Smart)におきましては、Welcart v1.9.5 よりトークン決済に対応し、v1.9.11 より埋込み型を廃止し、トークン決済が必須になりました。ソニーペイメントサービスからも加盟店様宛に、トークン決済の設定をするよう再三メールで通知しているはずです。トークン決済の設定(トークン決済認証コードの入力)をされない場合は、クレジットカード決済が利用できません。

4件の投稿を表示中 - 1 - 4件目 (全4件中)

このトピックに返信するにはログインが必要です。