カスタムフィールドの内容が2重表示される&公開後商品詳細本文が表示されない

2014 年 9 月 23 日

ホーム フォーラム 使い方全般 カスタムフィールドの内容が2重表示される&公開後商品詳細本文が表示されない

このトピックには7件の返信が含まれ、3人の参加者がいます。3 年、 1 ヶ月前 mjuk さんが最後の更新を行いました。

8件の投稿を表示中 - 1 - 8件目 (全8件中)
  • 投稿者
    投稿
  • #72068

    mjuk
    参加者

    初めて、利用させて頂きます。
    商品情報編集ページのカスタムフィールドの商品スペックが「下書き」の状態でプレビューすると2重表示されます。(本文と、定価・在庫状態などが書かれている別ブロックに2か所に分かれて表示されます)この時は商品説明の本文もすべて表示されます。
    この時のプレビュー画像は、恐らくそのままのサイズ(750×750)で大きく表示されます。

    「下書き」を公開に変更して、サムネイルの画像をクリックすると、下書きの時に見れていた文章は全く表示されず、画像は下書きの時のプレビューで見るものより、かなり小さなサイズで「画像のみ」が表示されます。この商品一覧のサムネイルはタイトル・金額が表示され、問題ありません。

    一度公開してしまったものは、非公開に変えても、文章はなく、画像のみ表示され、
    一度も公開していないものは、画像も大きなサイズで表示され、スペックは2重表示されますが、本文もすべて表示されます。うまく説明ができているとよいのですが、何か対処法をご存じの方がおられましたら、教えて下さい。どうぞよろしくお願い致します。

    #72101

    yskysmr
    キーマスター

    こんにちは。

    ご利用の環境を教えてください。
    ——————————————-
    WordPress のバージョン:
    Welcart のバージョン:
    ご利用のテーマ:
    症状を確認したブラウザ:
    サーバー(会社名、サービス名):
    SSLの利用: 
    WordPress のパーマリンク設定:
    ——————————————–

    #72114

    mjuk
    参加者

    ご返信、ありがとうございます!!
    必要な情報が抜けていて申し訳ありません。

    WordPress のバージョン:WordPress 4.0
    Welcart のバージョン:バージョン 1.4.7
    ご利用のテーマ:petit garden
    症状を確認したブラウザ:Google Chrome
    サーバー(会社名、サービス名):ロリポップ(チカッパ)
    SSLの利用:独自SSLなし
    WordPress のパーマリンク設定:設定→パーマリンクを開くと、投稿名にチェックがあります。
    このことでしょうか。本当に初歩的ですみません。

    登録している商品はすべて、同じ結果になりますので、
    新規ページを作りなおしたところ、文章も表示されました。
    これまでも同じやり方でしたので、何がおかしかったのかわかりませんが、、、
    カスタムフィールドの文字、数値は、はやり2重に表示されます。

    さらに、かなり初歩的な質問で大変恐縮ですが、
    テーマ購入先の同じテーマのライブデモは、
    画像が小さめに表示されるのですが、現在制作中のものは、
    大きく表示されるのですが、それはテーマ作者の設定の問題でしょうか。
    見やすくてよいのですが、そもそも根本的な設定が間違っているのかと思いまして。
    初心者の質問で本当に申し訳ありません。
    お手数ですが、どうぞよろしくお願い致します。

    #72115

    yskysmr
    キーマスター

    テーマを Welcart Default Theme に設定しても、同じ結果になりますでしょうか。

    テーマに関しましては、弊社の無料テーマ・有料テーマ以外のご質問には、弊社ではお答えいたしかねます。何卒ご了承くださいませ。

    #72138

    mjuk
    参加者

    お返事、ありがとうございます!!
    大変失礼いたしました。

    試してみようと思います。
    ありがとうございました。

    #72157

    nanbu
    参加者

    こんにちは。

    Welcart Default テーマに切り替えて動作確認してみて下さい。
    少なくとも、原因がWelcart本体に有るのか、テーマにあるのかがわかると思います。
    また、併用しているプラグインがある場合は、それらも一つずつ停止して動作を確認すると良いかと思います。

    #72163

    mjuk
    参加者

    ご回答、ありがとうございます!!
    「商品説明が表示されない」件につきましては、初心者で、自分の考えられる範囲内ですが、
    商品詳細ページの「パーマリンク」を「商品コード」と同じ名前で書き換えた場合に
    写真のみになるようでしたので、パーマリンク設定をカスタム構造にし、別の名前になるように設定しましたら、表示されるようになりました。

    「カスタムフィールドの内容2重表示」は、皆様のアドバイス通りにWelcart Default テーマに切り替えてみたところ、問題ありませんでしたので、テーマにありそうです。
    困っている時に、アドバイス頂けるのはとても嬉しく、本当にありがたいです。
    どうもありがとうございました。

    #72164

    mjuk
    参加者

    追記

    先ほどの投稿では、テーマに問題があるような書き方になりましたが、
    テーマは大変気に入っており、とても使いやすいです。
    どなたが参考にされるか分かりませんので、文章の書き方に気を付ければよかったと
    思いまして、追記させて頂きました。申し訳ありません。

    このようなコミュニティーがあり、本当に感謝致します。
    ありがとうございました。

8件の投稿を表示中 - 1 - 8件目 (全8件中)

このトピックに返信するにはログインが必要です。