カートページのみに出るエラーについて

ホーム フォーラム その他 カートページのみに出るエラーについて

このトピックには4件の返信が含まれ、2人の参加者がいます。4 週間前 qtqt さんが最後の更新を行いました。

5件の投稿を表示中 - 1 - 5件目 (全5件中)
  • 投稿者
    投稿
  • #87855

    qtqt
    参加者

    いつも大変お世話になっております。
    カートページ下部に以下のエラーメッセージが出てしまうのですが
    こちらはエラーメッセージの通り、WordPress本体側の問題になりますでしょうか。
    カートページのみに出ていたため、念のためこちらで質問させていただきました。
    何かご存知の方がいらっしゃいましたら、御教授いただけますと幸いです。

    ———————
    Warning: count(): Parameter must be an array or an object that implements Countable in /home/****/www/wp-includes/post-template.php on line 310

    #87857

    yskysmr
    キーマスター

    こんにちは。

    ご利用の環境をご記入ください。
    ——————————————-
    WordPress のバージョン:(例 4.7.4)
    Welcart のバージョン:(例 1.9.2)
    PHP のバージョン:(例 5.6)
    Welcart専用の拡張プラグイン:(例 DLSeller、Mobileなど)
    ご利用のテーマ:(例 WelcartBasicの自作子テーマ)
    症状を確認したブラウザ:
    サーバー:(会社名、サービス名)
    SSLの利用:(例 常時SSL)
    ——————————————–

    #87860

    qtqt
    参加者

    早速のご連絡ありがとうございます。
    利用環境のご連絡をし忘れており、大変失礼いたしました。
    どうぞ、よろしくお願いいたします。

    ——————————————-
    WordPress のバージョン:5.2.2
    Welcart のバージョン:7.2
    PHP のバージョン:7.3
    Welcart専用の拡張プラグイン:WCEX Mobile(現在は無効化)
    ご利用のテーマ:Welcart Defaultテーマを元にした自作テーマ
    症状を確認したブラウザ:Google Chrome
    サーバー:さくらインターネットスタンダードプラン
    SSLの利用:なし(カートページのみ共有SSL)
    ——————————————–

    #87861

    yskysmr
    キーマスター

    qtqt 様

    Welcart の本日時点での最新バージョンは v1.9.19 になります。古いバージョンをご利用の場合はアップデートしてください。

    また、Welcart Default Theme を流用されたのであれば、古い記述が残っている可能性があります。カートページ(テーマディレクトリ/wc_templates/cart/wc_cart_page.php)に以下の記述があれば、この一文を削除してください。
    <?php the_content();?>

    #87862

    qtqt
    参加者

    ご返信ありがとうございます。
    Welcartバージョンを間違っておりました。大変失礼いたしました。
    正しくは、最新バージョンの1.9.19を利用させて頂いております。

    また、お知らせいただきました箇所の記述を削除したところ、無事エラー表示が消えました。
    お忙しい所お教えいただき、ありがとうございました。

5件の投稿を表示中 - 1 - 5件目 (全5件中)

このトピックに返信するにはログインが必要です。