[解決済み] サーバーエラー500(システム設定SSL回りいじった後)

2012 年 6 月 5 日

ホーム フォーラム 使い方全般 [解決済み] サーバーエラー500(システム設定SSL回りいじった後)

このトピックには2件の返信が含まれ、2人の参加者がいます。5 年、 6 ヶ月前 nanbu さんが最後の更新を行いました。

3件の投稿を表示中 - 1 - 3件目 (全3件中)
  • 投稿者
    投稿
  • #51578

    waka
    参加者

    動作に関するご質問の場合は必ずご記入ください。


    WordPress のバージョン:3.3.2

    Welcart のバージョン:1.1.6

    ご利用のテーマ:Welcart Default Theme 1.1

    症状を確認したブラウザ:Google Chrome

    サーバー(会社名、サービス名):エックスサーバー X10

    SSLの利用: 専用SSL

    WordPress のパーマリンク設定:デフォルト


    Welcartをインストールし、設定をしていたのですが、

    システム設定の

    SSLを設定する チェック

    WordPress のアドレス (SSL) https:〜に変更

    ブログのアドレス (SSL) https:〜 に変更

    このあたりをいじった後「設定を更新」したらサーバーエラーが出ました。

    エラーは、

    URLが

    http://www.ドメイン.jp/store/wp-admin/plugins.php?action=activate&plugin=usc-e-shop%2Fusc-e-shop.php&_wpnonce=ae9a385d4d

    というもので、

    ///////////////////////////////////////////////////////

    サーバー エラー

    http://www.ドメイン.jp/store/wp-admin/plugins.php?action=activate&plugin=usc-e-shop%2Fusc-e-shop.php&_wpnonce=ae9a385d4d を取得中にウェブサイトでエラーが発生しました。 ウェブサイトがメンテナンスのために停止しているか、正しく設定されていない可能性があります。

    ヒント:

    このウェブページを後で読み込んでください。

    HTTP エラー 500(Internal Server Error): サーバーによるリクエストの実行中に、予期しない状況が発生しました。

    ///////////////////////////////////////////////////////

    と出ました。

    そこで、WelcartのフォルダをFTPで削除したら、またWordPress管理画面にもログインできるし、サイトも表示されるようになりました。

    新たにまたプラグインの新規追加よりWelcartをインストールして有効化すると、上記と同じエラーが出ます。

    この場合、何をどうしたらいいでしょうか。

    最悪、WordPressのインストールからやり直しなのかなと思っていますが、その前に何か修正手段があるかなと質問させていただきました。

    よろしくお願いします。

    #64664

    waka
    参加者

    いじっていたら直ったので自己解決とします。

    php.ini で memory_limit のサイズをあげたら、

    通常のデータベースエラーメッセージが出て、それがfunction.phpのSSLおまじないだったので、

    それを削除しました。

    とりあえず問題なく作業できそうです。

    お騒がせしました。

    #64665

    nanbu
    参加者

    こんにちは。

    SSLのおまじないはデータベースを操作してはいません。どのようなエラーか見せていただけると良かったのですが。

    SSLのおまじないを入れておかないとSSL警告が出ます。

3件の投稿を表示中 - 1 - 3件目 (全3件中)

このトピックに返信するにはログインが必要です。