システム設定で都道府県が出てこなくなってしまいました

2015 年 6 月 19 日

ホーム フォーラム 使い方全般 システム設定で都道府県が出てこなくなってしまいました

このトピックには4件の返信が含まれ、3人の参加者がいます。10 ヶ月前 yskysmr さんが最後の更新を行いました。

5件の投稿を表示中 - 1 - 5件目 (全5件中)
  • 投稿者
    投稿
  • #74541

    monta
    参加者

    Welcartで現在開発をすすめさせていただいております。
    大変便利で開発者様には感謝の言葉しかございません。

    今回ご質問させていただきますのはシステム設定から
    配送地域先を選んで設定する際の都道府県の入力箇所なのですが、
    いくら入力してから設定を更新してもまったく反映されず空白に
    戻ってしまいます。(設定更新は完了しましたという文字はちゃんと出てきます)
    試しに他のワードプレスにウェルカートを導入し
    試したところそちらでは都道府県がしっかりと表示され、設定した県のみが
    残るように設定できました。

    ある程度開発を進めた段階での設定変更でしたので、
    開発途中に都道府県を設定する箇所になんらかの干渉をしてしまう
    ものをこちらで組み込んでしまったのかもしれませんが
    こちらとしては何が影響を及ぼしているのか見当がつきません。

    もし何かお分かりになることがございましたらご助言いただけますでしょうか。

    #74547

    yskysmr
    キーマスター

    こんにちは。

    動作に関するご質問の場合は、ご利用の環境を教えてください。
    ——————————————-
    WordPress のバージョン:
    Welcart のバージョン:
    ご利用のテーマ:
    症状を確認したブラウザ:
    サーバー(会社名、サービス名):
    SSLの利用: 
    WordPress のパーマリンク設定:
    ——————————————–

    「ある程度開発を進めた段階での設定変更」とのことですが、Welcart 本体の改変をされたのでしょうか。
    Welcart 以外のプラグインを停止して、動作を確認してみてください。

    #74550

    monta
    参加者

    早速の返信ありがとうございます。
    先に結果を申し上げますと解決いたしました!

    プラグインの停止などを試してみた段階では
    変化はなかったのですかfunction.phpをデフォルトのもので
    上書きしたところ正常に機能するようになりました。
    ただ元々のfunction.phpの追加した項目を一度全て削除した段階では
    変化が起きず、元々の部分に手を加えた記憶はないので
    どの箇所が原因だったのかまでは判明いたしませんでした。
    ですがこちらで余計な情報を書き加えてしまっていたことに間違いは
    ないと思いますのでおそらくそれが原因だったと思われます。

    お騒がせして申し訳ありませんでした。

    #81878

    globcomm
    参加者

    ——————————————-
    WordPress のバージョン:4.5.2
    Welcart のバージョン:1.8.4
    ご利用のテーマ:デフォルト
    症状を確認したブラウザ:Chrome
    サーバー(会社名、サービス名):さくらサーバ ビジネス
    SSLの利用:あり
    WordPress のパーマリンク設定:投稿名
    ——————————————–

    WELCARTを使って、地域の特産品を販売したいと考えております。
    そこで、
    カスタムフィールドを使って、
    都道府県と市区町村を入れる事はできるかと思うのですが、
    それをカテゴリとして表示して、選択させる方法がわかりません。

    是非、お知恵をお借りしたいと思います。

    ご教授を頂ければと思います。

    よろしくお願い致します。

    #81889

    yskysmr
    キーマスター

    globcomm 様

    元々のトピックの内容とは関連がないと思われます。新しいトピックを立ててください。

5件の投稿を表示中 - 1 - 5件目 (全5件中)

このトピックに返信するにはログインが必要です。