テキストが英語になり、カートページ後にトップへ戻る

2016 年 4 月 9 日

ホーム フォーラム 使い方全般 テキストが英語になり、カートページ後にトップへ戻る

このトピックには12件の返信が含まれ、4人の参加者がいます。9 ヶ月、 1 週前 yasumax さんが最後の更新を行いました。

13件の投稿を表示中 - 1 - 13件目 (全13件中)
  • 投稿者
    投稿
  • #78075

    overwrite
    参加者

    以下環境でインストールしたのですが
    英語の文言となってしまい、それが原因かわからないのですが
    カートページのNEXTヘ進めずトップへ戻ってしまう現象が発生しております。
    Wordpressの言語設定は日本語
    wp-configにもdefine (‘WPLANG’, ‘ja’);
    languegeも日本語の存在はあり、welcartの配送対象も国内としております。

    動作に関するご質問の場合は、下記をコピペしてご利用の環境をご記入ください。
    ——————————————-
    WordPress のバージョン:WordPress 4.4.2
    Welcart のバージョン:1.8
    ご利用のテーマ:Twenty Sixteenバージョン: 1.1
    症状を確認したブラウザ:FF,Chrome,Safari
    サーバー(会社名、サービス名):conoha kusanagi
    SSLの利用: なし
    WordPress のパーマリンク設定: 日付と投稿名
    ——————————————–

    Attachments:
    You must be logged in to view attached files.
    #78080

    overwrite
    参加者

    カートが英語になってしまうのは未解決ですが
    プラグインを利用しdebugしたところ、sessionへの書き込みに失敗していたので
    書き込み権限を変更することで、次の画面への遷移はできました。

    /var/lib/php/session
    drwxrwx—. 2 root apache

    drwxrwxrwx. 2 apache apache

    • この返信は1 年、 3 ヶ月前に  overwrite さんが編集しました。理由: 具体的な解決策を明示するため
    #78082

    nanbu
    参加者

    こんにちは

    wp-config の define (‘WPLANG’, ‘ja’) は削除して、一般設定のサイトの言語を確認してみて下さい。

    #78090

    overwrite
    参加者

    ご返信ありがとうございます。

    define (‘WPLANG’, ‘ja’) 削除し、
    サイトの言語を管理画面で更新しましたが
    状況変わらず・・・。

    他のプラグインが影響している等ございますでしょうか?

    Attachments:
    You must be logged in to view attached files.
    #78098

    overwrite
    参加者

    再度言語設定を変更して
    言語関係のモジュールの実行を調査したところ、
    usces-jaを読み込みを行っているのは確認いたしました。

    しかしながら英語になります。
    何か過去の事例等であればと思い調べてみたのですが、
    見当たらず。。。

    Attachments:
    You must be logged in to view attached files.
    #78103

    nanbu
    参加者

    カートページの遷移ができないのでしたら、セッションファイルのパーミッションの問題かもしれません。まずはこちらを解決してから言語の方を検証してみてはいかがでしょうか。どうしても解決できないようでしたら、レスキューナビから不具合調査(有償)をご依頼いただく事になります。よろしくお願いいたします。

    #78104

    overwrite
    参加者

    ご返信ありがとうございます、セッションの問題は
    /var/lib/php/session
    drwxrwx—. 2 root apache

    drwxrwxrwx. 2 apache apache
    自己解決できました。

    ただプラグインというかユーザ画面が英語になってしまいます。
    どうも全部のプラグインに影響しているようでして、こちらはWelcartとは別の問題かと思いますので、この内要に関しては本フォーラムの質問としてはふさわしくないかと思いますので、取り下げします。

    WP_Langは推奨されなくなったようで、別のアプローチを調査しております。

    #80682

    toron
    参加者

    ——————————————-
    WordPress のバージョン:WordPress 4.6.1
    Welcart のバージョン:1.2.1
    ご利用のテーマ:Welcart Basic Child Theme
    症状を確認したブラウザ:firefox 49.0.1,Chrome
    サーバー(会社名、サービス名):NTT Cloudn CentOS 6.0 (64-bit)
    テンプレート:kusanagi_cloudn
    SSLの利用: なし
    WordPress のパーマリンク設定:投稿名
    ——————————————–

    上記環境インストールで、Welcart関連の表示のみ英語となります。

    ※サンプルページやwordpressでの基本設定は日本語で表示、
     Welcartでのログイン、カート、ウィジェット等は英語表示

    ※テーマをWelcart BasicやWelcart Default Themeに変更も同じ英語表示

    先に質問されたoverwriteさんと同じと思われます。
    (私は、カートページのNEXTへ進めます。)

    ローカルPC環境 Windows 8.1、他上記と同環境では
    日本語表示されている為、クラウド側(kusanagiテンプレート)
    が疑わしいのですが、クラウド側パーミッション、php等の設定ポイント等
    何かアドバイスを頂けましたらよろしくお願い致します。

    • この返信は9 ヶ月、 1 週前に  toron さんが編集しました。
    #80686

    yasumax
    キーマスター

    toronさん>

    こんにちは。

    管理画面[Welcart Shop]>[システム設定]の[国・言語・通貨]タブ内の「フロントエンドの言語」の設定は何になっていますか?

    #80692

    toron
    参加者

    yasumaxさん
    ご連絡ありがとうございます

    フロントエンド言語 ja
    他、添付画像1枚目ご覧頂けますでしょうか
    日本語を設定しているつもりです。

    添付画像2枚目、少々わかりにくいかもしれませんが
    クラウドと同じサイトをローカルでも構築

    上がクラウド側のトップ画面
    下がローカル環境の同じ画面
    ログイン、おすすめ商品、営業日カレンダーが英語表示

    他、商品紹介で入力してテキストは日本語表示
    買い物カゴやログインページは英語表示になります。

    Attachments:
    You must be logged in to view attached files.
    #80696

    overwrite
    参加者

    kusanagiメニューの中にある翻訳キャッシュの設定をキャッシュしないにしてみたら
    私の方は治りました。

    翻訳アクセラレーターを無効に。

    KUSANAGI専用プラグイン

    そちらを見直してみてください。

    Attachments:
    You must be logged in to view attached files.
    #80698

    toron
    参加者

    overwriteさん
    ありがとうございます!

    KUSANAGI Settings 翻訳アクセラレータの
    1、高速化を有効にする 有効のチェック外し変更を保存
    で日本語表示になりました。

    解決しました、皆さんありがとうございました。

    #80708

    yasumax
    キーマスター

    こんにちは。

    toronさん>
    KUSANAGIを利用されているのを見落としておりました。
    解決されたようで安心いたしました。

    overwriteさん>
    フォロー・情報提供ありがとうございます。

13件の投稿を表示中 - 1 - 13件目 (全13件中)

このトピックに返信するにはログインが必要です。