[解決済み] バージョンアップ:0.9.3

ホーム フォーラム インストール [解決済み] バージョンアップ:0.9.3

このトピックには2件の返信が含まれ、2人の参加者がいます。7 年、 7 ヶ月前 debau さんが最後の更新を行いました。

3件の投稿を表示中 - 1 - 3件目 (全3件中)
  • 投稿者
    投稿
  • #50273

    debau
    参加者

    お世話になっております。

    先日WelcartのアップグレードをWPより行いました。

    先ほど気づいたのですが、/wp-admin/index.phpを表示できなくなっておりました。

    代わりに、

    Fatal error: Call to undefined function usces_get_wcex() in /home/users/…/wp-content/plugins/usc-e-shop/classes/usceshop.class.php on line 1489

    と表示されました。(下記…の部分は省略しました↑)

    そのラインの部分は、$wcex = usces_get_wcex();

    とありました。

    ログインできないと困りますので、昨年の12月の別バージョン

    usceshop.class.php(←すいません、このファイルのバージョンはわかりません)のファイルをアップしたところログインできました。

    ただその代わりに、各ページ(フッター部分)に

    「Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, ‘usc_e_shop::shop_foot’ was given in /home/users/1/lolipop.jp-…/web/…/wp-includes/plugin.php on line 395」

    と表示されるようになりました。

    ( 395は、call_user_func_array($the_, array_slice($args, 0, (int) $the_)); とありました)

    アップデート後にファイルusceshop.class.phpとplugin.phpは何も編集や変更をいたしておりません。(もしくは他のファイルと関係しているのでしょうか)

    この状態を改善するには何をすればよろしいでしょうか…

    私の方ではプログラミングを解析することが出来ませんので、何か解決案をいただけましたら幸いです。

    よろしくお願いいたします。

    不具合の場合は必ずご記入ください。


    Welcart のバージョン:0.9.3

    WP:WordPress 3.0.5

    症状を確認したブラウザ:Firefox3.6.13、safari 4.13

    サーバー(会社名、サービス名):ロリポップ

    SSLの利用: 無し | 専用SSL | 共用SSL

    WordPress のパーリンク設定:


    #61535

    nanbu
    参加者

    こんにちは。

    アップグレードはどの様に行っていますか?

    自動アップグレードですか?

    一部のファイルだけを違うバージョンにするといったことは、何が起こるか分かりませんのでしない方が良いかと思います。

    #61536

    debau
    参加者

    nanbu様

    お騒がせいたしました。

    そしてアドバイスありがとうございます。

    早速、各ファイルの日時をにらめっこしながら、オリジナルのファイルを一つ一つ入れ戻し、入れ替えてしまったと思われる該当ファイルを発見いたしました。今回は、自分がfunctions/function.phpの書き換えをしたことが原因だった様です。ファイルを正しいものに戻した所、機能も元にもどった様です。エラーも出なくなりました。

    普段アップグレードはWPから自動で行っていますが、ファイルによっては、必要に応じて手動でその後入れ替えておりました。(ごめんなさい。荒々しいやり方ですよね…)

    今後は気をつけながら作業いたしたいと思います。

3件の投稿を表示中 - 1 - 3件目 (全3件中)

このトピックに返信するにはログインが必要です。