パーマリンクを変更すると商品ページが正しく表示されない

2013 年 2 月 28 日

ホーム フォーラム 使い方全般 パーマリンクを変更すると商品ページが正しく表示されない

このトピックには2件の返信が含まれ、2人の参加者がいます。4 年、 9 ヶ月前 staff_ueyk さんが最後の更新を行いました。

3件の投稿を表示中 - 1 - 3件目 (全3件中)
  • 投稿者
    投稿
  • #52314

    staff_ueyk
    参加者

    WordPress のバージョン:3.5.1

    Welcart のバージョン:1.2.3

    ご利用のテーマ:デフォルト

    症状を確認したブラウザ:FireFox19.0

    サーバー(会社名、サービス名):Xserver

    SSLの利用: 共用SSL

    WordPress のパーマリンク設定:/%postname%/


    いつもお世話になりありがとうございます

    1点ご確認したいことがございます

    WordPress のパーマリンク設定を/%postname%/

    とした場合、商品ページにアクセスすると商品画像しか表示されません

    (ヘッダ、サイドバー、フッター等は表示されます)

    パーマリンクをデフォルトにすると、商品画像と紹介文、カートに入れるボタンが正しく表示されます

    例えばpostIDが164の商品で商品コードをitem001にしていると次のようになります

    https://○○○.ssl-xserver.jp/item001 商品画像のみ表示

    https://○○○.ssl-xserver.jp/?p=164 正しく表示

    という感じです

    そこで商品のスラッグにitem-を頭に付け次のようにアクセスすると

    https://○○○.ssl-xserver.jp/item-item001

    正しく表示されます

    これはそのような仕様と理解すればよろしいでしょうか。

    それとも、スラッグを変更しなくても正しく表示させる方法があるのでしょうか。

    お手数をおかけしますが、ご教授の程宜しくお願いいたします。

    #66244

    nanbu
    参加者

    こんにちは。

    こちらでは同様の環境にして正常に動作しています。

    ページの確認は、更新をしてから確認されていますか?

    #66245

    staff_ueyk
    参加者

    ご返信ありがとうございます

    下記のように修整するとうまく表示されるようになりました

    商品コード item001

    商品名 アイテム001

    となっている商品で、商品詳細ページタイトルを

    「item001」→アイテム001

    にするとパーマリンクが

    https://○○○.ssl-xserver.jp/アイテム001

    となり正しく表示されました

    どうやら商品詳細ページタイトルを商品コードと同一にすると表示がおかしくなるようです

    商品詳細ページタイトルを商品名と同一とすることで問題なく表示

    されておりますので、この仕様で進めていきたいと思います

    ありがとうございました

3件の投稿を表示中 - 1 - 3件目 (全3件中)

このトピックに返信するにはログインが必要です。