ペイジェントのクレジット決済画面に遷移せずに

2015 年 12 月 16 日

ホーム フォーラム 使い方全般 ペイジェントのクレジット決済画面に遷移せずに

このトピックには4件の返信が含まれ、3人の参加者がいます。1 年、 5 ヶ月前 nanbu さんが最後の更新を行いました。

5件の投稿を表示中 - 1 - 5件目 (全5件中)
  • 投稿者
    投稿
  • #76677

    Ryo649
    Participant

    ——————————————-
    WordPress のバージョン:WordPress 4.3.1
    Welcart のバージョン:Version 1.6.1
    ご利用のテーマ: Blanc テーマ
    症状を確認したブラウザ:Chrome, Safari, FireFox
    サーバー(会社名、サービス名):さくら VPS 2G
    SSLの利用:あり
    WordPress のパーマリンク設定:デフォルト
    ——————————————–
    お世話になっております。
    ペイジェントの本番環境でクレジットカード決済を運用予定です。

    クレジット決済設定(ペイジェントの)をすべで設定しました。
    購入のテストを行って注文時にペイジェントの決済ページに遷移ぜずに
    エラーメッセージが出ました。
    ーーーーーーーーーーーーーーー
    エラー ERROR
    ご注文が完了しませんでした。
    (error 0)
    ーーーーーーーーーーーーーーー

    一方、ログファイルも確認しました。(acting_transaction.log )
    ーーーーーーーーーーーーーーー
    [2015-12-16 15:33:26] paygent_card data error : Array
    (
    )
    ーーーーーーーーーーーーーーー

    試験環境の方だと問題なく決済画面に遷移してクレジットカード決済が出来ました。
    コマンドでペイジェントの本番環境にPOSTリクエストをしてレスポンスがあったので
    ペイジェントの設定問題ではないと思いましたが

    レスポンスは以下の感じです
    ーーーーーーーーーーーーーーー
    result=0
    trading_id=014…省略
    url=https://link.paygent.co.jp/v/top?type=&tid=…..省略
    limit_date=20151221235959
    trade_generation_date=2015….省略
    ーーーーーーーーーーーーーーーーーー

    このような現象では何かの原因があるでしょうか?
    誠に恐縮ですがご教示をお願いいたします。

    日本語は下手の所、意味不明がありましたら
    ご指摘ほど宜しくお願い致します。

    #76680

    yskysmr
    キーマスター

    こんにちは。

    ペイジェントは確か、接続申込書が試験環境用と本番環境用、別になっていたかと思いますが、本番環境用も間違いなく申込みされましたでしょうか。

    #76682

    Ryo649
    Participant

    ご返信ありがとうございます。

    ペイジェントの本番環境と試験環境、両方の申し込みは完了でした。
    本番環境の利用もできている状態です。(ペイジェントに確認済み)

    今調べる所、わかったこと:
    Weclartを通じて
    本番環境からのレスポンスは【HTTP/1.1 400 Bad Request】
    試験環境からのレスポンスは【HTTP/1.1 200 OK】

    • この返信は1 年、 5 ヶ月前に  Ryo649 さんが編集しました。
    #76693

    Ryo649
    Participant

    こんにちは、

    この件について今調べて少し気になる所はPOSTの時に
    Header生成の所(usceshop.class.php 7013 line)です。
    ————————————————–
    $header .= “Host: “.$_SERVER[‘HTTP_HOST’].”\r\n”;
    ————————————————–
    この部分について$_SERVER[‘HTTP_HOST’]だと
    ペイジェントリクエスト先のURLにPOSTにならないです。

    代わりに$interface[‘host’]やペイジェントのurlに書き換えて
    実行するとペイジェント本番環境からのレスポンスがありました。

    $_SERVER[‘HTTP_HOST’]の書き方は正しいでしょうか?
    よくわかりませんのでご指摘ほど宜しくお願い致します。

    #76694

    nanbu
    Participant

    こんにちは

    ペイジェントの決済は、たくさんの方にご利用いただいており、現在決済ができないといったご報告は戴いておりません。なぜそちらの環境で決済が完了しないかは、調査をしてみなくては判りませんので、恐れ入りますがレスキューより不具合調査をご依頼いただきたいと思います。Welcartにバグが有りました場合はご返金させていただきます。

5件の投稿を表示中 - 1 - 5件目 (全5件中)

このトピックに返信するにはログインが必要です。