ペイジェント・カード決済でP063のエラー

フォーラム 使い方全般 ペイジェント・カード決済でP063のエラー

  • このトピックには3件の返信、2人の参加者があり、最後にikedaにより5ヶ月、 1週前に更新されました。
4件の投稿を表示中 - 1 - 4件目 (全4件中)
  • 投稿者
    投稿
  • #97208
    kudou
    参加者

    ——————————————-
    WordPress のバージョン:6.0
    Welcart のバージョン:2.6.9
    PHP のバージョン:7.4.29
    ご利用の親テーマとバージョン :welcart basic1.5
    ご利用の子テーマとバージョン :上記の子テーマ
    症状を確認したブラウザ:chrome
    サーバー【重要】:さくらのレンタルサーバ スタンダード
    決済代行会社:ペイジェント
    ——————————————–

    お客様のショップ制作中で、ペイジェントの試験環境の設定を行って決済テストをしました。
    ペイジェントには3Dセキュア1.0が申込済なので、「3Dセキュア結果受付ハッシュ鍵」に管理画面記載のものを入力してあります。

    しかし、ペイジェントに配布されているテスト用のカード情報を入れて決済テストしようとすると、エラーログに以下が表示されて、決済完了に至りません。

    ————————————————–
    登録日 = 2022-06-17 10:50:45
    リンクキー = 8601167935
    処理結果 = P063
    result = 1
    result_status = 1
    response_code = P063
    response_detail = 3Dセキュア2.0の利用が許可されていません。
    result_message = P063: 3Dセキュア2.0の利用が許可されていません。
    ————————————————–

    試しに、3Dセキュアを「未契約/利用しない」に設定して決済を試すと、決済は正常に行うことできました。

    ペイジェントに申し込んでいるのは1.0なのですが、3Dセキュアを稼働して決済するためにはどうしたらよいでしょうか。
    ペイジェントにも聞いてみたのですが、それはWelcart側の問題と言われたので、こちらで質問いたしました。よろしくお願いいたします。

    #97216
    ikeda
    キーマスター

    kudou 様
    こんにちは。
    上記エラーは、ペイジェント社へ3Dセキュア 2.0 を
    申込頂いてないため発生したエラーとなっております。
    加盟店様経由で、ペイジェント社へWelcartを使う旨、及び
    3Dセキュアをお申込する旨をお伝えください。
    どうぞよろしくお願いいたします。

    #97217
    kudou
    参加者

    回答ありがとうございます。
    確かに、エラー内容としては、

    >ペイジェント社へ3Dセキュア 2.0 を申込頂いてないため

    だとは思うのですが、
    ペイジェントでは、まだ3Dセキュア1.0の申込が出来ており、1.0は10月で終了だそうです。
    2.0は有料オプションになるため、有料になってもお客様が契約なさるのか、確認できていません。

    現時点で、無料での3Dセキュア1.0では、Welcartの3Dセキュアは使えないということなのでしょうか。

    #97221
    ikeda
    キーマスター

    kudou 様
    こんにちは。
    Welcart は 3Dセキュア2.0 の仕様になっています。
    新規の 3Dセキュア1.0 のみのお申し込みには対応しておりません。

4件の投稿を表示中 - 1 - 4件目 (全4件中)
  • このトピックに返信するにはログインが必要です。