ルミーズのコンビニ決済でエラーがでます

2014 年 6 月 2 日

ホーム フォーラム 使い方全般 ルミーズのコンビニ決済でエラーがでます

このトピックには12件の返信が含まれ、2人の参加者がいます。3 年、 4 ヶ月前 yskysmr さんが最後の更新を行いました。

13件の投稿を表示中 - 1 - 13件目 (全13件中)
  • 投稿者
    投稿
  • #70632

    maruo
    参加者

    初めて投稿させていただきます。
    表題の件ですが、ルミーズのコンビニ決済を設定し、カートからこの決済方法を選択した場合、カートの確認画面で以下のエラーが出てきます。これは何を意味しているのでしょうか?また、出ないようにするにはどうするのでしょうか??
    ご伝授お願い致します。

    ▼エラー内容
    Warning: mb_ereg() [function.mb-ereg]: mbregex compile err: premature end of char-class in <サイトのパス>/wp-content/plugins/usc-e-shop/includes/purchase_button.php on line 286

    Warning: mb_ereg() [function.mb-ereg]: mbregex compile err: premature end of char-class in <サイトのパス>/wp-content/plugins/usc-e-shop/includes/purchase_button.php on line 292

    ※<サイトのパス>はサイトのディレクトリーパス。

    その他情報です。
    ——————————————-
    WordPress のバージョン:3.9.1
    Welcart のバージョン:1.4.1.1406021
    ご利用のテーマ:Pinboard
    症状を確認したブラウザ:Chorme
    サーバー(会社名、サービス名):ロリポップ
    SSLの利用:利用
    WordPress のパーマリンク設定:カスタム「/%post_id%.html」
    ——————————————–

    ちなみにですが、カード決済時には、このようなエラーはでませんでした。

    以上

    #70638

    yskysmr
    キーマスター

    こんにちは。

    ご報告ありがとうございました。仰るとおりの症状を確認いたしました。
    Development Version にて修正が完了しておりますので、大変お手数ですが、Development Version にアップデートしてお使いいただけますでしょうか。

    よろしくお願いいたします。

    #70647

    maruo
    参加者

    ご返答ありがとうございました。
    早速「Development Version」にしたのですが、下記エラーにてWP全体がエラーをはく状態になりました。ヴァージョンは最新のやつですが、どうすればいいでしょうか??

    ▼エラー内容
    Warning: require_once(<パス>/wp-content/plugins/usc-e-shop/widgets/usces_search.php) [function.require-once]: failed to open stream: No such file or directory in <パス>/wp-content/plugins/usc-e-shop/includes/default_filters.php on line 83

    Fatal error: require_once() [function.require]: Failed opening required ‘<パス>/wp-content/plugins/usc-e-shop/widgets/usces_search.php’ (include_path=’.:/usr/local/php5.3/php’) in <パス>/wp-content/plugins/usc-e-shop/includes/default_filters.php on line 83

    #70650

    yskysmr
    キーマスター

    お手数ですが、Welcart Shop>ホームの下の方、「ご利用の環境」の内容を、教えていただけますでしょうか。

    また、Welcart のインストール(アップデート)は、どのようにされましたでしょうか。FTP からコピーされたのでしょうか。

    • この返信は3 年、 4 ヶ月前に  yskysmr さんが編集しました。
    #70654

    maruo
    参加者

    ご返答ありがとうございます。
    まず、アップデート方法ですが以下の手順です。
    1.デベロッパーからファイルをダウンロード
    2.ローカルにてZIPファイルを解凍
    3.解凍したフォルダごとFTPにて、WPのpluginにある「usc-e-shop」をまるごと上書きしました。

    環境の部分はこちらです。

    ▼ご利用の環境
    【サーバー】
    Apache

    【MySQL】
    5.6.11

    【PHP】
    5.3.15 memoly[global]:128M [locale]:256M [usage]:40M
    simplexml, curl, gd, json, mbstring, mysql, openssl

    ご返答お待ちしております。

    以上

    #70655

    yskysmr
    キーマスター

    おそらくですが、Welcart が正常にインストールできていないために出るエラーメッセージだと思われます。動作環境は問題ありません。

    Welcart のアップデートは、zip の場合、プラグイン>新規追加>アップロードを選択し、「ファイルを選択」で zip ファイルを指定してください。

    現在 Welcart 1.4.2 が最新バージョンとなります。Development Version の内容は既に含まれておりますので、プラグインからの自動アップデートをしていただいても構いません。

    #70656

    maruo
    参加者

    ご返答ありがとうございます。

    上記手順ですと、ファイルの容量制限(サーバーの)に引っかかるためヴァージョンアップできませんでしたが、プラグイン更新にてヴァージョンアップできました。現在「バージョン 1.4.2」になっております。

    しかし、表題の「ルミーズのコンビニ決済でエラーがでます」のバグは解決していません。何か間違いましたでしょうか??

    #70661

    yskysmr
    キーマスター

    バージョンアップの際に、プラグインを停止→有効化していただけましたでしょうか。
    また、ブラウザのキャッシュをクリアしていただけませんでしょうか。何かキャッシュ系のプラグインをご利用ではないでしょうか。

    #70662

    yskysmr
    キーマスター

    失礼いたしました。現在の Development Version を使っていただけますでしょうか。v1.4.2 には含まれておりませんでした。大変申し訳ありません。
    アップデートの際には、FTP からではなく、先ほどの手順でインストールしていただきますよう、お願いいたします。

    #70663

    maruo
    参加者

    ご返答ありがとうございます。

    デベロッパーのダウンロードがわからないのですが
    http://wordpress.org/plugins/usc-e-shop/download/
    ↑ここから赤いボタンを押して、ダウンロードでよろしいですか?

    こちらのヴァージョンを以下からインストールしても、バグが改善されません。

    1.FTPにて、WPのpluginにある「usc-e-shop」ごと削除
    2.管理画面から、プラグイン→新規追加→ダウンロードしたZIPファイルを選択
    3.プラグインを有効
    4.WPの「WP Super Cache」を停止
    5.ブラウザのキャッシュクリアー

    ご回答お願い致します。

    #70664

    yskysmr
    キーマスター

    Development Version は上記リンク先の一番下にあります。クリックでダウンロードを開始します。

    また、キャッシュ系のプラグインのご利用はお勧めいたしておりません。個人情報の漏洩に繋がる恐れがあります。

    キャッシュプラグインにご注意!

    #70665

    maruo
    参加者

    デベロッパーヴァージョンにて、バグの問題が解決しました!!
    長々とご対応いただき、ありがとうございました。

    それとキャッシュの件のご指摘もありがとうございます。
    こちらは利用しない方向で行きたいと思います。

    要望なのですが、このバグ対策がされたヴァージョンがアップされる時、更新ジャーナルに記載をお願い致します。でないといつまでも更新できなくなってしまいますので、、、

    以上

    #70669

    yskysmr
    キーマスター

    要望なのですが、このバグ対策がされたヴァージョンがアップされる時、更新ジャーナルに記載をお願い致します。でないといつまでも更新できなくなってしまいますので、、、

    毎回そのようにさせていただいております。

13件の投稿を表示中 - 1 - 13件目 (全13件中)

このトピックに返信するにはログインが必要です。