ログイン画面、新規登録画面が表示されません

ホーム フォーラム 使い方全般 ログイン画面、新規登録画面が表示されません

タグ: 

このトピックには3件の返信が含まれ、2人の参加者がいます。1 週、 2 日前 acid さんが最後の更新を行いました。

4件の投稿を表示中 - 1 - 4件目 (全4件中)
  • 投稿者
    投稿
  • #86729

    acid
    参加者

    突然、ログイン画面と新規登録画面が表示されなくなりました。
    Welcartで言うメンバーページの部分が動いてないようです。

    固定ぺージのメンバー、カートは触っていませんし、健在です。

    header.phpとfooter.phpの内容は読み込まれ、
    中身だけソースもない全くの無です。

    主なカスタマイズは、
    完全会員制にするため、ヘッダやフッタ、主だったページに
    if(usces_is_login())
    を仕込んで表示非表示をさせている事です。

    最後に確認してから行った事は、
    ・店舗担当者に管理画面から商品登録や基本設定を入力してもらった。
    のみで、この間php,js,cssなどの更新は行っていません。

    検索しても同様のケースは確認できなかったのですが、
    どなたかこの状態に心当たりはありますでしょうか。。

    ちなみにカートのほうは動いているようです。
    ——————————————-
    WordPress のバージョン:4.9.8
    Welcart のバージョン:Version 1.9.13.1809031
    Welcart専用の拡張プラグイン:なし
    ご利用のテーマ:WelcartBasicの自作子テーマ
    症状を確認したブラウザ:Chrome, IE他ほぼすべて
    サーバー:Dream Host
    SSLの利用:常時SSL
    WordPress のパーマリンク設定:基本(/?p=123)
    ——————————————–

    #86737

    yasumax
    キーマスター

    こんにちは。

    固定ぺージのメンバー、カートは触っていませんし、健在です。

    とのことですが、スラッグと公開状態はどうなっていますか?
    メンバーの場合スラッグが「usces-member」でなければメンバー関連のページは動作しませんので、他のスラッグ名になっているということはないですか?
    また、公開状態が「公開」以外になっていると正常には動作しないかもしれません。
    そちらもあわせて確認してください。

    また、会員制のサイトとのことですがメンバーページに何かしらの制限をかけてしまってはいませんか?
    一度カスタマイズを外した状態もしくは、テーマはWelcartBasic(親テーマ)に変更してみてもメンバーページは表示されませんか?

    #86759

    acid
    参加者

    ご返信ありがとうございます。

    >>メンバーの場合スラッグが「usces-member」でなければメンバー関連のページは動作しませんので、他のスラッグ名になっているということはないですか?

    →この場合URLの部分のことでしょうか。
    パーマリンク設定は最初からデフォルトのままの「/ルート/?p=123」となっています。
    カスタム投稿タイプなどfunction.phpまわりに追記するようなものは今回利用しておらず、スラッグと呼べるものを変更した形跡はありません。。

    >>また、公開状態が「公開」以外になっていると正常には動作しないかもしれません。
    →公開状態は公開ですね。
    一応一度非公開にして戻してみましたが変わりません。

    >>また、会員制のサイトとのことですがメンバーページに何かしらの制限をかけてしまってはいませんか?
    →表示制限をかけているのは
    header.php
    footer.php
    front-page.php
    各single
    などで、現状大枠をざっくりif文で囲むシンプルなものです。
    そういったソース内レベルではなく、
    header.phpで吐かれたソースのすぐ次にfooter.phpのソースがきており、
    メンバー部分が丸々機能していない形にみえるのです。

    >>一度カスタマイズを外した状態もしくは、テーマはWelcartBasic(親テーマ)に変更してみてもメンバーページは表示されませんか?
    →これにはかなり期待したのですが、同じでした。
    プラグインのコア部分に不具合が生じているのでしょうか。。
    テンプレートのバックアップをとってWelcartを入れなおしたほうが早いですかね

    #86760

    acid
    参加者

    解決しました。

    なんのことはなく、、
    店舗担当者のほうで、
    基本設定のポイントを利用しない旨の話をしていたのですが、
    それに伴って会員システムのほうのチェックも「利用しない」にしてしまっていたようです。。

    大変失礼いたしました。

4件の投稿を表示中 - 1 - 4件目 (全4件中)

このトピックに返信するにはログインが必要です。