会員ログイン時に「Security check4」がでる

フォーラム バグ報告 会員ログイン時に「Security check4」がでる

  • このトピックには3件の返信、2人の参加者があり、最後にsagawaにより1ヶ月前に更新されました。
4件の投稿を表示中 - 1 - 4件目 (全4件中)
  • 投稿者
    投稿
  • #94706
    sms
    参加者

    昨日、Welcart e-Commerceのバージョンを
    1.9.26から2.2.8にしました。

    方法は
    https://www.welcart.com/documents/archives/3708
    こちらのアップグレードの方法の1~7までそのとおり行いましたが、

    不具合が2箇所出ております。

    1つは、以前、納品書のカスタマイズを行い、
    希望配達日と時間を表示させるようにしましたが、
    そちらが表示されない点。

    2つ目は、表題の通り、
    カートから注文手続きに進み、「会員の方はこちら▼」の画面からログインしようとすると
    Security check4と書かれたページに遷移し進むことができない点。
    (会員ログインでなく新規の購入でしたら問題無い)

    という状況です。
    この場合どのように対処したらよろしいでしょうか?

    https://www.welcart.com/archives/techinfo/techinfo-20200305
    こちらの記事を拝見しましたが
    私が見た所、既にこちらの設置タグは記述済みとなっておりましたので
    原因がわかりません。

    ——————————————-
    WordPress のバージョン:( 5.5.5)
    Welcart のバージョン:(2.2.8)
    PHP のバージョン:(7.0.1)
    Welcart専用の拡張プラグインとバージョン:WCEX Amazon Pay 1.7.5、WCEX Coupon 1.0.8、WCEX Multi Price 1.2.0、
    ご利用のテーマ:(自作テーマ? 確認中)
    症状を確認したブラウザ:Google Chrome Safari FireFox
    サーバー【重要】:アルファメール
    ——————————————–

    #94714
    sagawa
    キーマスター

    こんにちは。

    1. カスタマイズにつきまして、こちらはご自身でされたカスタマイズでしょうか?
    また、そのカスタマイズの記述は残っていますでしょうか?

    2. Welcart v2.2.0からブルートフォース攻撃対策機能が追加されています。
    これが有効になっており、かつ指定回数以上ログイン情報を間違えた場合に「Security check4」が表示されます。
    こちらは有効になっていますでしょうか?
    ブルートフォース攻撃対策機能については、下記のマニュアルページの「ブルートフォース攻撃対策機能」欄をご確認いただければと思います。
    https://bit.ly/3irxmHD

    #94741
    sms
    参加者

    お世話になっております。
    回答頂き誠にありがとうございます。

    こちらの件ですが、
    アップグレードに影響を受けるファイルにカスタマイズを行っていたことが分かり、
    元通り、納品書に希望配達日と時間を表示させることができました。
    恐らく今後アップグレードすると同じように
    希望配達日と時間が表示されなくなると思うのですが、
    https://half-half.info/?p=253
    その場合、こちらの記事の1を参考に作業する認識でOKでしょうか?

    > 1. カスタマイズにつきまして、こちらはご自身でされたカスタマイズでしょうか?
    > また、そのカスタマイズの記述は残っていますでしょうか?

    無効になっておりました。
    また、右側追従メニューに「会員登録・ログイン」というボタンがあり、
    そちらをクリックして、ログインした後だと、
    注文時に「Security check4」は表示されず、
    「上記内容で注文するボタン」をクリックできる注文内容確認画面に進むことが出来るようになっております。

    つまり、

    事前にログインしてから注文手続きに進んだ場合 => 「Security check4」は表示されない
    未ログイン状態でカートから注文手続きに進んだ場合 => 「Security check4」は表示される

    といった状態でございます。

    > 2. Welcart v2.2.0からブルートフォース攻撃対策機能が追加されています。
    > これが有効になっており、かつ指定回数以上ログイン情報を間違えた場合に「Security check4」が表示されます。
    > こちらは有効になっていますでしょうか?

    #94750
    sagawa
    キーマスター

    こんにちは。

    申し訳ありませんが、社外の記事に対して見解を出す事はできません。(問題ないと断言はできませんので、ご了承下さい。)
    今回のようにアップデートされますとファイルが上書きされますので、こちらを回避するという意味では、フックを使ってカスタマイズを実装していただき、かつカスタマイズは子テーマに設置していただくければと思います。

    「Security check4」につきまして、一旦Welcart Basicテーマに切り替えてご確認いただけないでしょうか?
    Welcart Basicテーマは下記のページから無料で取得することができます。
    https://www.welcart.com/archives/4286.html

    また、環境が少し古いため、下記のシステム要件をご確認いただき、推奨環境下で再度ご確認いただければと思います。
    https://www.welcart.com/wc-condition/

4件の投稿を表示中 - 1 - 4件目 (全4件中)
  • このトピックに返信するにはログインが必要です。