[解決済み] 共用SSL(エックスサーバー)での動作について

2012 年 2 月 19 日

ホーム フォーラム 使い方全般 [解決済み] 共用SSL(エックスサーバー)での動作について

このトピックには11件の返信が含まれ、4人の参加者がいます。5 年、 9 ヶ月前 nanbu さんが最後の更新を行いました。

12件の投稿を表示中 - 1 - 12件目 (全12件中)
  • 投稿者
    投稿
  • #51324

    ikuemi
    参加者

    動作に関するご質問の場合は必ずご記入ください。


    WordPress のバージョン:3.3.1

    Welcart のバージョン:1.1.1

    ご利用のテーマ:Welcart Default Theme 1.1

    症状を確認したブラウザ:IE、Firefox

    サーバー(会社名、サービス名):エックスサーバー

    SSLの利用: 共用SSL

    WordPress のパーマリンク設定:デフォルト、カスタム(/%post_id%/)


    ここ数日色々調べて試したのですがどうにもわかりません。

    エックスサーバーでの共用SSLを利用し、最初は正常に動作しているように思えました。

    しかし、テストでSSLページと非SSLページの行き来を何度か繰り返しているうちに、SSLページ(カートなど)へのリンクをクリックすると全てサイトのトップページ(非SSL)へ戻ってしまうようになってしまいました。

    独自ドメインでの利用です。

    テーマやプラグインとの干渉も疑い、新たに空のWordPressサイトをインストールしてWelcart Default Themeで試しているのですが改善されません。

    パーマリンク設定も変えたりしましたが変化はありませんでした。

    もちろんクッキーや一時ファイルの削除もしていますし、別のパソコンからも確認しています。

    かなり前の記事ですが、こちらにはエックスサーバーの共用SSLで動作確認を取ったとありました。

    https://www.welcart.com/community/archives/929

    最近でも動作が確認出来ている方はいらっしゃいますか?

    ちなみにこちらのトピックに書いてあることも試しましたが、変化はありませんでした。

    https://www.welcart.com/forum/topic.php?id=560

    ただトピック内のサーバーが環境変数を隠しているかどうかの確認を行ってみるとHTTPSとPOSTには結果が返ってきませんでした。

    #63870

    Konoha
    参加者

    初めて投稿させていただきます。

    私もXServerにてここ1週間くらいikuemi様とまったく同様の問題で悩んでおります。

    原因追求をしようと奮闘していましたが、良く分かりませんでしたので、

    取り急ぎ確認した症状のみご連絡させていただきます。

    ■WordPress3.3.1を新規インストール⇒Welcart1.1.1をインストール(その他プラグインは一切入れていない状態)。パーマリンク設定がデフォルトでもSLLページに遷移しない事がほとんどです。でもパーマリンク設定がデフォルト(3種類)のいづれかででSSLが通るときもあるのでよくわかりません。

    ■パーマリンク設定をカスタムにして/%category%/%post_id%などにすると遷移しないことが多かったです。/%post_id%.htmlなどにすると遷移する場合が稀にありました。

    ■上記新規インストールにて偶然にもSSLページ遷移した場合。またWordPressを上書き更新(自動アップデート)するとSSLページに遷移しなくなってしまいました。(Wordpressアップデートを想定したテストです)

    余談ですが、現在のXserverはサーバー側が用意したphp.iniを使用するかしないかをON、OFFにて管理画面で行うようになっています。ONにした場合には、サーバー側で用意されたphp.iniが優先される仕組みのようです。

    デフォルトのsession.save_pathの問題かなとも思いましたが、ちゃんと動いているようでした。

    .htaccessの設定も特に問題があるような箇所は見受けられません。

    ※.htaccess


    suPHP_ConfigPath /home/***/***.jp/xserver_php/ *php.ini設定パス

    AddHandler x-httpd-php5.3 .php .phps

    # BEGIN WordPress

    <IfModule mod_rewrite.c>

    RewriteEngine On

    RewriteBase /

    RewriteRule ^index.php$ – [L]

    RewriteCond %{REQUEST_FILENAME} !-f

    RewriteCond %{REQUEST_FILENAME} !-d

    RewriteRule . /index.php [L]

    </IfModule>

    # END WordPress


    ※Xserver側デフォルトphp.ini(session部分のみ)


    [Session]

    session.save_handler = files

    session.save_path = /var/lib/php/session

    session.use_cookies = 1

    session.use_only_cookies = 1

    session.name = PHPSESSID

    session.auto_start = 0

    session.cookie_lifetime = 0

    session.cookie_path = /

    session.cookie_domain =

    session.serialize_handler = php

    session.gc_probability = 1

    session.gc_divisor = 1000

    session.gc_maxlifetime = 1440

    session.bug_compat_42 = 0

    session.bug_compat_warn = 1

    session.referer_check =

    session.entropy_length = 0

    session.entropy_file =

    session.cache_limiter = nocache

    session.cache_expire = 180

    session.use_trans_sid = 0

    session.hash_function = 1

    session.hash_bits_per_character = 5


    的外れでしたらすみません。

    #63871

    nanbu
    参加者

    ikuemi さん、Konoha さん、こんにちは。

    よろしければ、ご利用の環境を調査せていただきたいのですが可能でしょうか。調査費は結構です。もし可能でしたら下記宛にWordPressの管理者権限アカウントとFTP情報をお送りいただけたらと思います。(パスワードは別メールでお送りくださった方が良いかと思います。)

    nanbuアットusconsort.com(アットは@)

    #63872

    Konoha
    参加者

    nanbu様

    お早いご返答ありがとうございます。

    先ほどメールにてお送りさせていただきました。

    メールにも記載させていただきました通り、こちらすべてクリーンな状態にてインストール&設定しております。

    また、SSLページは最初の1回のみ、その後トップページなどに移動してからまたカートページなどに移行しようとすると、遷移できない状況を確認しております。

    ご確認の程よろしくお願いいたします。

    #63873

    nanbu
    参加者

    Konoha さん

    ご協力ありがとうございました。

    お陰様で、Xserverでcookieの処理に問題があるのを発見できました。

    修正をいたしまして、Development Versionを更新いたしました。

    感謝いたします。

    #63874

    Konoha
    参加者

    nanbu様

    早急なご対応ありがとうございます。

    Development Version、確認いたしました。

    現在SSLページへの遷移は問題なく行われております。

    また、重ねて恐縮ですが、同じ商品を複数回カートに入れた場合、カートの数量が追加されないようです。

    こちらも調査いただけますと幸いです。

    #63875

    ikuemi
    参加者

    nanbu様 Konoha様

    トピックの確認が遅くなってしまい申し訳ありません。

    早速Development Versionを導入してみたところ、SSLの件は正常な動作確認が出来ました。

    nanbu様の迅速なご対応と、Konoha様のご協力に感謝です。

    ありがとうございました。

    また、Konoha様のご指摘のカートの数量の問題はこちらでも確認出来ました。

    nanbu様のご確認が取れるまで今しばらくトピックステータスをこのままにしておきます。

    #63876

    nanbu
    参加者

    Welcart1.1から、カート投入の際の数量は加算ではなく上書きに仕様が変更されました。もし上書きがご都合悪い場合はフックの設置等考えますのでお申し出ください。よろしくお願いいたします。

    #63877

    NI
    参加者

    全く同じ事象がロリポップでも出ていました。

    複数のショップがロリポップに入っていますが、出ているのは一店だけ。

    サーバの設定でしょうか

    クッキーを削除すると元に戻ります

    #63878

    nanbu
    参加者

    NIさん、Development Versionはお試しいただいていますでしょうか。

    #63879

    Konoha
    参加者

    nanbu様

    ご連絡ありがとうございます。

    仕様とのこと、大変失礼いたしました。

    一般的に、加算されるECサイトが多いですのでフックをご用意いただけると大変嬉しいです。

    何卒よろしくお願いいたします。

    #63880

    nanbu
    参加者

    Konoha さん

    フック設置の件、了解いたしました。

12件の投稿を表示中 - 1 - 12件目 (全12件中)

このトピックに返信するにはログインが必要です。