受注データの見積書・納品書・請求書・領収書が印刷できません。

ホーム フォーラム その他 受注データの見積書・納品書・請求書・領収書が印刷できません。

このトピックには11件の返信が含まれ、2人の参加者がいます。1 週、 3 日前 j-info さんが最後の更新を行いました。

12件の投稿を表示中 - 1 - 12件目 (全12件中)
  • 投稿者
    投稿
  • #86411

    j-info
    参加者

    ——————————————-
    WordPress のバージョン:(例 4.6.12)
    Welcart のバージョン:(例 1.9.0.1610051)
    ご利用のテーマ:オリジナル
    症状を確認したブラウザ:chrome
    サーバー:さくらレンタルサーバー
    SSLの利用:常時SSL
    WordPress のパーマリンク設定:
    ——————————————–

    いつ頃からという明確な時期はわかりませんが、
    お客様の受注データから、見積書・納品書・請求書・領収書をクリックして、
    出てくるポップアップ画面が「このページは動作していません」http error 500が表示され印刷することができません。

    「ご利用環境」のphp情報も合わせてきさいさせていただきます。
    解決方法を教えてください。

    7.1.20 memory[global]:128M [locale]:268435456 [usage]:13M
    simplexml, curl, gd, json, mbstring, openssl

    #86413

    j-info
    参加者

    追記させていただきます。
    こちらのサイトは最近SSL化設定をしたのですが、この件と関係ありますでしょうか?

    #86417

    yskysmr
    キーマスター

    こんにちは。

    システム要件をご確認ください。
    システム要件

    また、常時SSL化につきましては、以下のリンク先をご参照ください。
    常時SSL化の設定方法

    #86419

    j-info
    参加者

    ご返信いただき、ありがとうございます。
    こちらはwordpressのバージョンが古いために、welcartが正常に機能していないという事でしょうか?

    WordPress のバージョン:4.6.12
    Welcart のバージョン:1.9.0.1610051

    SSL化につきましては、さくらの常時SSL化プラグインを使って対応しております。

    #86423

    yskysmr
    キーマスター

    j-info 様

    Welcart の PHP の推奨バージョンは 5.6 もしくは 7.0 となっています。
    また、WordPress、Welcart 共に最新バージョンにアップデートした上でご利用ください。

    #86435

    j-info
    参加者

    ご返答いただき、ありがとうございました。
    サーバーの管理会社に問い合わせた所、PHPのバージョンは7.1.20でした。

    この場合は、7.0までバージョンを落として対応するということでよろしいでしょうか?
    5.6は2018年12月にサポート終了になるということで、推奨されませんでした。

    #86437

    yskysmr
    キーマスター

    j-info 様

    PDF の出力ができないのが、PHP のバージョンが問題かは分かりません。ですが、動作環境を合わせていただけませんと、どこに影響が出るかわかりません。
    また、常時SSL 化の際に、Welcart の設定を正しく済まされたかご確認ください。

    #86439

    j-info
    参加者

    追記させていただきます。さくらサーバーのphpのバージョンは5.6、7.1、7.2からの選択になってしまうようで、7.0は選択できないとの連絡を受けました。

    Attachments:
    You must be logged in to view attached files.
    #86446

    yskysmr
    キーマスター

    j-info 様

    では、5.6 にダウングレードしていただけますでしょうか。

    #86452

    j-info
    参加者

    ご返信いただきありがとうございます。
    5.6まで落としてもらいましたが、結果は変わらずポップアップ画面上で「このページは動作していません」http error 500が表示されます。
    また、常時SSL化設定に則って対応しましたが、これでも改善はされませんでした。

    Attachments:
    You must be logged in to view attached files.
    #86456

    yskysmr
    キーマスター

    j-info 様

    WordPress、Welcart は最新バージョンにアップデートしていただけましたでしょうか。

    #86457

    j-info
    参加者

    ご返信いただき、ありがとうございます。
    wordpress、Welcartを最新のバージョンにアップデート後、印刷のポップアップが正常に表示されるようになりました。
    お手数をお掛けしました。ありがとうございます。

12件の投稿を表示中 - 1 - 12件目 (全12件中)

このトピックに返信するにはログインが必要です。