[解決済み] 商品のインポートエクスポートができない

2012 年 3 月 17 日

ホーム フォーラム その他 [解決済み] 商品のインポートエクスポートができない

このトピックには8件の返信が含まれ、2人の参加者がいます。5 年、 6 ヶ月前 nanbu さんが最後の更新を行いました。

9件の投稿を表示中 - 1 - 9件目 (全9件中)
  • 投稿者
    投稿
  • #51410

    masuda-clair
    参加者

    動作に関するご質問の場合は必ずご記入ください。


    WordPress のバージョン:3.1.4

    Welcart のバージョン:1.1.3.1203171

    ご利用のテーマ:Welcart Default Theme 1.1

    症状を確認したブラウザ:IE9

    サーバー(会社名、サービス名):MEGAFactory

    SSLの利用: 無し

    WordPress のパーマリンク設定:post ID


    商品の更新を行おうとして、「商品データ出力」のボタンを押すのですが

    ダイアログが出ず、出力ができなくなってしまいました。

    よく見ると、商品一覧の下のほうに、ダイアログで出るはずの

    内容が表示されているので、プラグインの問題と思い、

    Welcart multipriceのプラグイン以外をすべて停止してみましたが

    状況変わらず。

    それ以外に気が付いたのは

    [memory peak usage]

    に、使用中のメモリ容量が出るはずなのが、何も出ず

    ホームの内容で、一番下に出る

    PHPの状況の場所も

    [usage]:

    と出るだけで、数字は出ていないのに気が付きました。

    その後、MultiPriceのプラグインも停止してみましたが

    状況が変わりません。

    状況として、どのようなことが考えられるでしょうか?

    プラグインの停止も、停止させるだけでなく、削除したほうがいいのでしょうか?

    #64162

    nanbu
    参加者

    こんにちは。

    ダイアログが出ないのはJavaScriptのエラーが多いのですが、他のプラグインを停止して、テーマもWelcartDefaultテーマに切り替えてテストしてみてください。

    ただ、「Welcartホーム」でご利用環境が出ないのはまた違った異常な状況になっていると考えられます。メモリーが足りないのではないでしょうか。サーバー会社にメモリー・リミットの確認変更方法を問い合わせてみてください。

    32M~64Mは欲しいところです。

    #64163

    masuda-clair
    参加者

    ありがとうございます。

    プラグインはWelCartとマルチプライス以外はすべて「停止」させました

    テーマも、カスタマイズしていますが、デフォルトです。

    メモリは128MB確保されています。

    [attachment=6408,85] [attachment=6408,86]

    #64164

    nanbu
    参加者

    PHPのバージョンが低いようです。

    最新のWordPressとWelcartを利用するには、PHPはバージョン 5.2.4 以上が必要となります。まずはその辺をクリアする必要があるかと思います。

    #64165

    masuda-clair
    参加者

    回答ありがとうございます。

    ただ、レンタルサーバーの制限上MySQLはおろかPHPのバージョンアップも

    サポート外なので、できれば避けたいのですが。

    (PHPに関しては非公式にアップデートの情報はもらっています)

    わがままな希望なのですが、PHPのバージョンを触らずに対応は無理でしょうか?

    #64166

    nanbu
    参加者

    PHPが5.1の場合Welcartは1.0にダウングレードしなくてはいけません。

    ただ、Welcartを1.1にアップグレードした場合はデータベースが更新されてしまっていますので、1.0に戻すにはデータベースを元に戻さなくては行けなく、バックアップを取っていない場合は、もはやダウングレードはできないということになります。無理矢理ダウングレードした場合は、再度商品登録および支払方法の設定などをしなくては行けなくなります。

    残念ながらプログラムで対処することはできません。

    #64167

    masuda-clair
    参加者

    ありがとうございます。

    社内でいろいろ検討した結果、

    現状で、PHPだけをバージョンアップをするのは

    あまりにもリスキーだし、

    今後、PHPやMySqlのバージョンを上げたいときの

    ことを考えて、サーバーの変更で、対応する予定になりました。

    ありがとうございました。

    #64168

    masuda-clair
    参加者

    解決済みでしたが、サーバーを変えて、問題なく動作することが

    確認できましたので、改めて報告いたします。

    [attachment=6921,103]

    #64169

    nanbu
    参加者

    ご報告ありがとうございます。

    うまく行って良かったです。

9件の投稿を表示中 - 1 - 9件目 (全9件中)

このトピックに返信するにはログインが必要です。