[未解決] 商品マスターの2ページ目が開かない

ホーム フォーラム 使い方全般 [未解決] 商品マスターの2ページ目が開かない

このトピックには10件の返信が含まれ、4人の参加者がいます。5 年、 2 ヶ月前 mamekichi さんが最後の更新を行いました。

11件の投稿を表示中 - 1 - 11件目 (全11件中)
  • 投稿者
    投稿
  • #52915

    lesson_book
    参加者

    動作に関するご質問の場合は必ずご記入ください。


    WordPress のバージョン:3.5.2–ja

    Welcart のバージョン:Version 1.3.3.1306254

    ご利用のテーマ:オリジナル

    症状を確認したブラウザ:Safari 5.1.7(7534.57.2) Firefox21.0 IE10(Crome以外のブラウザ)

    サーバー(会社名、サービス名):XREA.com

    SSLの利用: 無し

    WordPress のパーマリンク設定:投稿名


    お世話になります。

    Welcartのプラグインを数件、大変重宝して運用させていただいています。

    私の検索不足かも知れませんが、Crome以外のブラウザで

    商品マスターの2ページ目に下記のエラーメッセージが

    ページ上部に書かれて、商品のサムネイルも表示されず商品の登録状態を変更できなくて困っています。

    お手数ですが、改善策をご教授ください。

    WordPress データベースエラー: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ” at line 7 for query SELECT post.ID, mc.meta_value AS item_code, mn.meta_value AS item_name FROM ia_posts AS post LEFT JOIN ia_postmeta AS mc ON post.ID = mc.post_id AND ‘_itemCode’ = mc.meta_key LEFT JOIN ia_postmeta AS mn ON post.ID = mn.post_id AND ‘_itemName’ = mn.meta_key LEFT JOIN ia_postmeta AS meta ON post.ID = meta.post_id AND ‘_isku_’ = meta.meta_key LEFT JOIN ia_term_relationships AS tr ON post.ID = tr.object_id LEFT JOIN ia_term_taxonomy AS tt ON tt.term_taxonomy_id = tr.term_taxonomy_id WHERE post.post_mime_type = ‘item’ AND post.post_type = ‘post’ AND post.post_status <> ‘trash’ GROUP BY post.ID ORDER BY made by do_action(‘welcart-shop_page_usces_itemedit’), call_user_func_array, usc_e_shop->item_master_page, require_once(‘/plugins/usc-e-shop/includes/usces_item_master_list.php’), dataList->MakeTable, dataList->GetRows

    [attachment=11043,266]

    #67252

    nanbu
    参加者

    こんにちは。

    サーバーのセッションが正常じゃないとこの様なエラーになります。

    サーバーの設定をご確認ください。

    #67253

    lesson_book
    参加者

    ご回答ありがとうございます。

    『サーバーのセッションが正常じゃない』とのご回答ですが、私は正直サーバーについての知識がほぼない人間です。

    具体的にどの辺りの『サーバーの設定』を確認すればよいか、アドバイスをいただけないでしょうか?

    #67254

    yskysmr
    キーマスター

    XREA.com をお使いとのことですが、こちらはセーフモードではなかったでしょうか。Welcart はセーフモードには対応しておりませんので、正常に動作しないかと思います。

    #67255

    lesson_book
    参加者

    ご回答ありがとうございます。

    wp-adminのディレクトリ内に下記のファイルを設置して対応していて

    今までは大丈夫だったのですが、何かバージョンアップによって仕様の変更をされたのでしょうか?

    XREA.comでは、もうWelcartは使用できないのでしょうか?

    .htaccess

    <files async-upload.php>

    AddHandler application/x-httpd-phpcgi .php

    </files>

    <files admin.php>

    AddHandler application/x-httpd-phpcgi .php

    </files>

    <files update.php>

    AddHandler application/x-httpd-phpcgi .php

    </files>

    <files upgrade.php>

    AddHandler application/x-httpd-phpcgi .php

    </files>

    <files plugin-install.php>

    AddHandler application/x-httpd-phpcgi .php

    </files>

    <files update-core.php>

    AddHandler application/x-httpd-phpcgi .php

    </files>

    <files plugins.php>

    AddHandler application/x-httpd-phpcgi .php

    </files>

    <files themes.php>

    AddHandler application/x-httpd-phpcgi .php

    </files>

    #67256

    nanbu
    参加者

    セーフモードでご利用いただいている方もいらっしゃるようですが、弊社ではセーフモードでの検証は行っておりませんので、その際の不具合につきましてもアドバイスし兼ねる所でございます。どうぞよろしくお願いいたします。

    #67257

    mamekichi
    参加者

    現在coreserverを使っています。xrea+も使っていました。

    不具合の原因はわかりませんが、lesson_bookさんの書かれた.htaccessは原因ではないと思います。

    そっくりコピーしてSafariやFirefoxで試しましたがエラーは表示されませんでした。

    #67258

    lesson_book
    参加者

    mamekichi様

    コメントありがとうございます。

    サーバーが原因ではないとなるといよいよ解決の糸口がなくなってきました。

    困まりました。。。

    #67259

    mamekichi
    参加者

    .htaccessに原因がないと推測されるだけです。

    何らかの原因でデータベースが壊れているのかもしれません。

    やれることは少ないのですが、コントロールパネルから保存と復元をやってみてはいかがですか? 

    それでもだめなら、データベースを消去して作り直すということもあるかと思います。

    #67260

    lesson_book
    参加者

    mamekichi様

    ご返信ありがとうございます。

    またこちらの返信が遅くなり申し訳ありません。

    mamekichi様のアドバイスの『コントロールパネルから保存と復元』と『データベースを消去して作り直す』もトライしてみましたが、改善はされませんでした。

    セーフモードも関係なく、データベースを復元したり、再構築しても改善されないとなるとあと出来る事はなんなのでしょうか?

    #67261

    mamekichi
    参加者

    データベースは関係なかったですね。余計な手間を取らせてすみません。

    nanbuさんのヒントに従って、session.save_pathを記述したphp.iniの名前を変えて無効にしてみたら、全く同じエラーが出ました。1ページ目は正常ですが、2ページ目を開こうとするとエラーが出ます。

    session用のディレクトリを適当な場所に作り、php.iniをwp-adminに置いてsession.save_pathにパスを指定してみてください。

11件の投稿を表示中 - 1 - 11件目 (全11件中)

このトピックに返信するにはログインが必要です。