解決済商品一括登録を行うと画像と関連商品が更新されない。

フォーラム 使い方全般 【解決済】商品一括登録を行うと画像と関連商品が更新されない。

  • このトピックには5件の返信、2人の参加者があり、最後にst_tantouにより4ヶ月、 2週前に更新されました。
6件の投稿を表示中 - 1 - 6件目 (全6件中)
  • 投稿者
    投稿
  • #92800
    st_tantou
    参加者

    【初回の商品追加】
    商品データをcsvで

    ①画像を商品コードの後ろにハイフンと番号で名前をつけてメディアにアップロードを行う
     例:lkdt1010-001.jpg、lkdt1010-002.jpg、lkdt1010-003.jpg、lkdt1010-004.jpg、lkdt1010-005.jpg
    ②商品一括登録でデータを追加

    の流れで商品登録をしていますが、画像が表示されません。
    管理画面「商品情報編集」を開くと管理画面には画像は表示されていますが、表側には反映がされません。

    そのため、仕方がないので、現在は一つ一つ「更新」ボタンを押して表示させています。
    原因と解消方法が分かりましたら教えていただきたいです。

    画像は最初に「更新」ボタンを押せば、以降は問題なく表示されます。

    【2回以降の商品データ更新】
    商品データを更新しアップロードしなおすと、関連商品が非表示になってしまいます。

    こちらも画像と同様で、管理画面「商品情報編集」にはタグに「商品コード」が入っていますが、
    表示されておらず、「更新」ボタンを押すことで表示させることができます。

    データ更新のたびに消えてしまうため、毎回「更新」ボタンを押すのは難しいです。
    同じ原因なのか、別なのかわかりませんが、ご教授お願いします。

    ——————————————-
    WordPress のバージョン:(例 5.6)
    Welcart のバージョン:バージョン 2.1.4
    PHP のバージョン:PHP7.4.13
    Welcart専用の拡張プラグインとバージョン:Image Uploader for Welcartバージョン 1.4.6
    ご利用のテーマ:TCDテーマオプションICONIC
    症状を確認したブラウザ:Chrome
    サーバー【重要】:(会社名、サービス名)
    ——————————————–

    #92824
    st_tantou
    参加者

    情報に洩れがありすみません。
    追加いたしました。
    ——————————————-
    WordPress のバージョン:WordPress 5.7
    Welcart のバージョン:バージョン 2.1.4
    PHP のバージョン:PHP7.4.13
    Welcart専用の拡張プラグインとバージョン:Image Uploader for Welcartバージョン 1.4.6
    ご利用のテーマ:TCDテーマオプションICONIC
    症状を確認したブラウザ:Chrome
    サーバー【重要】:xserver
    ——————————————–
    よろしくお願いいたします。

    #92826
    sagawa
    キーマスター

    こんにちは。

    何点か確認をさせて下さい。
    ①jpgファイル名で「-」を使用しておりますので、Welcartのシステム設定の「商品サブ画像適用ルール」は新しいルールを適用しない」でお使いという認識で間違いないでしょうか?

    ②画像が表示されない(表側には反映されない)とありますが、上記のファイル名から判断するにサブ画像が表示されないという認識でよろしいでしょうか?

    ③「商品データを更新しアップロード…」とありますが、商品データを更新した後に何をアップロードしなおしたのでしょうか?

    #92827
    st_tantou
    参加者

    ご返信ありがとうございます。
    ①「新しいルールを適用しない」にチェックを入れてあります。

    ②メイン画像の「lkdt1010.jpg」という名前では画像を登録していませんでした。
    ですので、サブ画像が表示されないということになるかと思います。

    ③「全項目」のデータになります。
    在庫状況やテキストの変更、商品の追加時など、都度、情報を更新しているため、毎回全商品のデータを更新しています。

    #92845
    sagawa
    キーマスター

    st_tantou様

    ご回答ありがとうございます。
    私の環境(テーマ:Welcart Basic、Image Uploader for Welcartプラグイン未使用)では再現できませんでした。
    サードパーティーのテーマ(ICONIC)とプラグイン(Image Uploader for Welcart)を併用されているため、一度テーマをWelcart Basicに切り替えていただき、ご確認いただけますでしょうか?
    それでも変わらないようでしたらImage Uploader for Welcartプラグインを無効化にした状態で再度ご確認いただけますでしょうか?

    #92895
    st_tantou
    参加者

    本日、下記を試してみました。
    ・「Welcart Basic」に切り替え
    ・「Image Uploader for Welcar」を無効化

    これで、データ更新を行ったところ、問題なく表示されました。

    「Welcart Basic」への切り替えだけでは、直らなかったので、
    「Image Uploader for Welcar」が影響していたようです。

    とても困っていたので、修正でき、とても助かりました。
    ご対応いただき、ありがとうございました。

6件の投稿を表示中 - 1 - 6件目 (全6件中)
  • このトピックに返信するにはログインが必要です。