基本設定が更新できない 【解決済】

ホーム フォーラム その他 基本設定が更新できない 【解決済】

タグ: 

このトピックには5件の返信が含まれ、3人の参加者がいます。3 週間、 3 日前 yuchelle さんが最後の更新を行いました。

6件の投稿を表示中 - 1 - 6件目 (全6件中)
  • 投稿者
    投稿
  • #87363

    yuchelle
    参加者

    いつも有用な情報をご掲載頂きありがとうございます。

    フォーラムの方でも幾つか投稿されていましたが、運用中のサイトで同様の症状が出ました。
    共通オプションの追加・削除は出来ますが、上部の「営業設定」「ショップ設定」の内容変更が出来ず困っておりました。

    ・上部の更新ボタンを押すと「辿ったリンクは期限が切れています」とエラーが出る
    ・最下部の更新ボタンを押すと変更点が元に戻る

    などの症状に悩まされていました。

    WAFやphp.iniの設定変更など試しましたが効果なく、ダメ元で共通オプションを削除したところ正常動作するようになりました。

    販売中商品を一定期間で追加していく関係上、共通オプションがいつのまにか200件超となっていたので、既に使用していないオプションを30件ほど削除したところ正常動作するようになりました。

    既に解決済の内容ですが、お困りの方がいらっしゃるかと思い共有させて頂きます。

    • このトピックは yuchelleが8 ヶ月、 2 週間前に変更しました。
    #88638

    soholand
    参加者

    基本設定で消費税を変更しようとしても 

    辿ったリンクは期限が切れています
     
    と表示されて変更ができません

    =====
    サーバー側から当該「php.ini」ファイルを探し、その「php.ini」について、次の3箇所をこの通りに書き換えます。-1にすることでこれらの上限を無しにできます。

    max_execution_time = -1
    memory_limit = -1
    post_max_size = -1
    =====

    と書いてあるとことがあったので やってみましたがダメでした。
    ——————————————-
    WordPress のバージョン: 5.2.3–
    Welcart のバージョン:バージョン 1.9.22
    PHP のバージョン: PHP7.0.33

    Welcart専用の拡張プラグインとバージョン:
    WCEX Multi Price 1.1.5
    WCEX Widget Cart 1.1.6
    WCEX Reports 1.1.0
    WCEX Order List Widget 1.0.3

    ご利用のテーマ:Welcart Vollバージョン: 1.0.1 御社にて一部カスタマイズ
    症状を確認したブラウザ: crome
    サーバー:wpx
    SSLの利用: 常時SSL
    ——————————————–

    #88639

    yuchelle
    参加者

    私の場合は同様に「php.ini」では全く効果がありませんでしたが、管理画面内Welcart Shop→基本設定内にある共通オプションを数十件単位で削除することにより正常動作するようになりました。

    余談ですが、先日こちらへ投稿したことをすっかり忘れており、同様の症状に陥った際にGoogle検索で自分の投稿にたどり着き再度解決しました。

    共通オプションが数百件単位で登録されている方はあまりいないと思われ、また、想定外の量のためこのような症状が発生したようですが、共通オプションを数百件も入れていないようですと他に原因があるようですね。

    前回は動作環境を記載していなかったので、念のため下記に記載しておきます。

    ——————————————-
    WordPress のバージョン:5.1.2
    Welcart のバージョン:1.9.20
    PHP のバージョン:5.6.40
    Welcart専用の拡張プラグインとバージョン:
    WCEX DL Seller: 3.0.8
    WCEX Multi Price: 1.1.4
    WCEX Yamato Number: 1.0.0
    ご利用のテーマ:welthemes minimum 1.8 カスタマイズ
    症状を確認したブラウザ:Chrome
    サーバー:Xserver
    SSLの利用:常時SSL
    ——————————————–

    お役に立てますと幸いです。

    #88687

    soholand
    参加者

    解決できません

    基本設定で消費税を変更しようとしても 

    辿ったリンクは期限が切れています
     
    と表示されて変更ができません

    =====
    サーバー側から当該「php.ini」ファイルを探し、その「php.ini」について、次の3箇所をこの通りに書き換えます。-1にすることでこれらの上限を無しにできます。

    max_execution_time = -1
    memory_limit = -1
    post_max_size = -1
    =====

    と書いてあるとことがあったので やってみましたがダメでした。
    ——————————————-
    WordPress のバージョン: 5.2.3–
    Welcart のバージョン:バージョン 1.9.22
    PHP のバージョン: PHP7.0.33

    Welcart専用の拡張プラグインとバージョン:
    WCEX Multi Price 1.1.5
    WCEX Widget Cart 1.1.6
    WCEX Reports 1.1.0
    WCEX Order List Widget 1.0.3

    ご利用のテーマ:Welcart Vollバージョン: 1.0.1 御社にて一部カスタマイズ
    症状を確認したブラウザ: crome
    サーバー:wpx
    SSLの利用: 常時SSL
    ——————————————–
    マルチプライスの削除も行いましたが 解決できません

    消費税8%のままで 大変困っております。
    ——————————————–

    解決できません
    更新できません
    よろしくお願いします
    解決できません

    #88706

    nglife
    参加者

    こんにちは。

    「php.ini」を編集可能なのであれば「max_input_vars」の値を増やしてみると改善されるかもしれません。大体「1000」あたりが設定されているかと思いますが必要に応じて「1500~2000」程度に設定するのが良いかなと思います。
    ※闇雲に増やすのもセキュリティ上問題ありますのでほどほどに

    >共通オプションがいつのまにか200件超
    ということですと、画面内HTML上の「<input>」の数が膨大になっているはずです。先ほどの「max_input_vars」は一度に送信できる「<input>」の数と捉えていただければOKです。この許容値を超えてしまうと仰るような現象が起こる可能性は高いと思います。

    見当違いでしたらすみませんがご参考までに。
    ※よくよく見たらyuchelleさんは解決済み?でしたね。soholandさんはどういう状態か分かりませんが参考になればと思います

    • この返信は3 週間、 4 日前に  nglife さんが編集しました。
    #88708

    yuchelle
    参加者

    nglifeさん、こんにちは。

    貴重な情報をありがとうございます。
    すでに解決済みですが、「max_input_vars」に関して確認したところ、私の管理するサイトでは値が1000となっていました。

    基本設定ページのinput数を確認すると934個あり、この状態での共通オプションは170ぐらいです。

    前述の通りinput数は1000以下ですが、再度こちらの数が超えた場合は「max_input_vars」の値を1500程度まで上げれば対応できそうです。

    どうもありがとうございました。

    soholandさん、nglifeさんの投稿のとおり、php.iniが編集可能であればmax_input_varsの値を上げるか、php.ini編集不可の場合は共通オプションの削除を試されてみてはいかがでしょうか?

6件の投稿を表示中 - 1 - 6件目 (全6件中)

このトピックに返信するにはログインが必要です。