支払い方法の追加でエラー

2015 年 1 月 9 日

ホーム フォーラム インストール 支払い方法の追加でエラー

このトピックには3件の返信が含まれ、2人の参加者がいます。2 年、 8 ヶ月前 nanbu さんが最後の更新を行いました。

4件の投稿を表示中 - 1 - 4件目 (全4件中)
  • 投稿者
    投稿
  • #73227

    katayama
    参加者

    ——————————————-
    WordPress のバージョン:4.1
    Welcart のバージョン:1.4
    ご利用のテーマ:デフォルト
    症状を確認したブラウザ:safari と chrome
    サーバー(会社名、サービス名):CPI
    SSLの利用: なし
    WordPress のパーマリンク設定:未設定
    ——————————————–

    初めて投稿いたします。
    welcartを上記の環境にインストールしたところ、他のところは問題なく動作するのですが
    基本設定の「支払い方法の追加」で、エラーが発生いたします。

    php5.5 でインストールしたところ下記のエラーが表示されました
    —————————-
    Warning: Illegal string offset ‘name’ in /usr/home/aa●●●●/html/test01/wp-content/plugins/usc-e-shop/functions/system_post.php on line 15

    Warning: Illegal string offset ‘sort’ in /usr/home/aa●●●●/html/test01/wp-content/plugins/usc-e-shop/functions/system_post.php on line 19

    Warning: Invalid argument supplied for foreach() in /usr/home/aa●●●●/html/test01/wp-content/plugins/usc-e-shop/functions/system_post.php on line 30

    Fatal error: [] operator not supported for strings in /usr/home/aaa●●●●/html/test01/wp-content/plugins/usc-e-shop/functions/system_post.php on line 37
    —————————-

    phpのバージョンを2.8に変更したところ下記のエラーが表示されました
    —————————-
    Fatal error: [] operator not supported for strings in /usr/home/aaa●●●●/html/test01/wp-content/plugins/usc-e-shop/functions/system_post.php on line 37
    —————————-

    welcart1.4以上は php4以降ということでしたので、phpのバージョンを5に戻し
    「Illegal string offset 」のエラー2カ所を 「false」から「true」に変更したところ
    —————————-
    Warning: Illegal string offset ‘name’ in /usr/home/aa1270sjls/html/test01/wp-content/plugins/usc-e-shop/functions/system_post.php on line 15

    Warning: Illegal string offset ‘sort’ in /usr/home/aa1270sjls/html/test01/wp-content/plugins/usc-e-shop/functions/system_post.php on line 19

    Fatal error: [] operator not supported for strings in /usr/home/aa1270sjls/html/test01/wp-content/plugins/usc-e-shop/functions/system_post.php on line 37
    —————————-

    上記のエラーに減ったのですが、その後、どう触っていいのかわかりません。
    申し訳ありませんが、解決方法を教えていただけますでしょうか?
    よろしくお願いいたします。

    #73237

    nanbu
    参加者

    こんにちは。

    PHPの対応バージョンの情報はこちらにございます。

    Welcart ドキュメンテーション

    エラーの原因かどうかはまだわかりませんが、Welcartは今のところPHP5.5には対応しておりません。

    #73293

    katayama
    参加者

    お返事ありがとうございます。
    変更してみたのですがうまく行きませんでしたが
    wordpressのバージョンを落とすと、問題なく動作いたしました。

    #73345

    nanbu
    参加者

    こちらでは、WordPress、Welcart共に最新版での動作に問題はありません。何か環境に違いがあるのではないかと思いますが、この場では推測ができません。必要でしたら調査(有償)をご依頼いただきたいと思います。

4件の投稿を表示中 - 1 - 4件目 (全4件中)

このトピックに返信するにはログインが必要です。