[未解決] 商品のメイン画像の上下が切れて表示されてしまいます

ホーム フォーラム 使い方全般 [未解決] 商品のメイン画像の上下が切れて表示されてしまいます

このトピックには10件の返信が含まれ、3人の参加者がいます。5 年、 1 ヶ月前 keitee さんが最後の更新を行いました。

11件の投稿を表示中 - 1 - 11件目 (全11件中)
  • 投稿者
    投稿
  • #52823

    keitee
    参加者

    動作に関するご質問の場合は必ずご記入ください。


    WordPress のバージョン:3.5.1

    Welcart のバージョン:1.3.2

    ご利用のテーマ:welcart default

    症状を確認したブラウザ:safari

    サーバー(会社名、サービス名):xserver

    SSLの利用: 無し | 専用SSL | 共用SSL

    WordPress のパーマリンク設定:投稿名


    商品ページの商品画像(メイン画像)の上下が切れて表示されてしまいます。

    サブ画像はクリックしても正常に表示されるのですがメイン画像に限って上下が切れてしまいます。

    改善策はございますか?

    #66924

    nanbu
    参加者

    こんにちは。

    サムネイルのことを仰っていますか?

    WordPressはデフォルトで、サムネイルを正方形にトリミングすることはご存知ですか?

    #66925

    keitee
    参加者

    nanbuさん

    ご返答いただきまして誠にありがとうございます。

    商品画像(メイン画像)についてですが、

    <?php usces_the_itemImage(0, 300, 300, $post); ?>の様に設定しましても

    表示される画像が横幅300px、縦幅が200pxになってしまうのです。

    正方形に画像が表示されなくて困っております。

    #66926

    takeda
    参加者

    こんにちは。横から失礼します。

    私もkeiteeさんと同じ状況で悩んでいます。

    ■現象

    <?php usces_the_itemImage(0, 300, 300, $post); ?>に設定

    表示される画像:横幅300px、縦幅が220px

    ■検証したこと

    どの画像がどのように読み込まれてるのか自分なりに調べてみたところ、プラグインの「Meteor Slides」が原因じゃないかと思いあたりました。

    スライドを「1000*220」で設定していたんですが、そうするとアップロードした商品画像が自動的に縦220pxで保存されます。

    例えば、商品画像A-0000.jpgをメディアよりアップロードした場合、サーバ上には以下のファイルが保存されてました。

    A-0000.jpg

    A-0000-150×150.jpg(これはwordpressのメディアで設定してるサムネイル画像のサイズっぽいです)

    A-0000-250×250.jpg(プラグインを有効にしてると自動的に保存されるようです)

    A-0000-300×220.jpg(スライドで設定した縦220pxが自動的に保存されるようです)

    そして、メイン画像は「A-0000-300×220.jpg」が読み込まれて表示されています。

    ■応急処置

    1. サーバ上の商品画像を全部削除

    2. スライドの設定サイズを「1000*300」に変更。(スライド画像は既に1000*220で保存しており、特に表示に問題なさそうでした。)

    3.「A-0000-300×220.jpg」が自動保存されなくなる

    4. メイン画像は「A-0000.jpg」が読み込まれ、300*300で表示される

    ■お願い

    もし他に原因があったり、よい対応方法があれば教えてください。

    「Meteor Slides」は「小さなECサイトのWordPress+Welcart導入・設定ガイド」で知りました。

    とても便利だと思って初めて使わせてもらっているので、できれば今後もWelcartと一緒に利用したいと思っています。

    Welcartを常に進化させていただいてありがとうございます!

    今後ともよろしくお願いします。

    #66927

    keitee
    参加者

    こんにちは。

    私もtakedaさんと同じでプラグインの「Meteor Slides」を使用しておりました。

    原因は分かりませんが、<?php usces_the_itemImage(0, 300, 300, $post); ?>の部分を

    <?php usces_the_itemImage(0, 301, 301, $post); ?>もしくは

    <?php usces_the_itemImage(0, 299, 299, $post); ?>という様に

    微妙に数値を変えたら正常に表示されました。

    理想的な解決策がございましたら教えて頂きたいです。

    #66928

    nanbu
    参加者

    Meteor Slidesが入っている環境で、画像のアップロードテストをしてみました。

    オリジナルのサイズは1260×2409

    メディアの設定は

    サムネイル150×150

    中サイズ300×300

    大サイズ1024×1024

    メテオの設定は

    W560×H100

    以上の設定でアップロードいたしましたところ以下のファイルができました。

    sample_i-150×150.jpg

    sample_i-156×300.jpg

    sample_i-250×477.jpg

    sample_i-535×1024.jpg

    sample_i-560×100.jpg

    sample_i.jpg

    そして商品詳細ページの

    <?php usces_the_itemImage(0, 300, 300, $post); ?>

    では、sample_i-156×300.jpgが採用されて表示されていました。

    このテストでは特に問題は見られなかったのですが、私の検証方法が見当違いでしたらご指摘ください。

    よろしくお願いいたします。

    #66929

    keitee
    参加者

    nanbuさん

    ご返答いただきまして誠にありがとうございます。

    nanbuさんのご説明の中にある

    「<?php usces_the_itemImage(0, 300, 300, $post); ?>

    では、sample_i-156×300.jpgが採用されて表示されていました。」

    という部分は300×300の画像ではなくて156×300の画像が表示されたといことでしょうか。

    #66930

    nanbu
    参加者

    はい。

    オリジナルの画像は縦長ですので、156×300の採用で正常です。

    WordPressのトリミングは150×150以下で行われます。

    従いまして、縦横比固定ではこのサイズで正解です。

    #66931

    keitee
    参加者

    nanbuさん

    ご連絡ありがとうございます。

    私の場合ですと<?php usces_the_itemImage(0, 300, 300, $post); ?>で設定して

    300×300の画像をアップロードしますと、

    Aという商品は300×300で正常に表示されて、

    Bという商品は200×300と表示されたりします。

    同じ条件で商品登録しているのに商品によって表示のされ方が違います。

    原因が分かりませんのでとりあえずは

    <?php usces_the_itemImage(0, 301, 301, $post); ?>で

    正常表示させてます。

    #66932

    nanbu
    参加者

    その、Bの商品のオリジナル画像のサイズはいくつですか?

    #66933

    keitee
    参加者

    nanbuさん

    ご返答ありがとうございます。

    A商品、B商品、共にオリジナル画像のサイズは300 x 300です。

11件の投稿を表示中 - 1 - 11件目 (全11件中)

このトピックに返信するにはログインが必要です。