国・言語・通貨設定で、データに不備がありますとエラーが出ます。

2012 年 11 月 20 日

ホーム フォーラム 使い方全般 国・言語・通貨設定で、データに不備がありますとエラーが出ます。

このトピックには6件の返信が含まれ、3人の参加者がいます。4 年、 11 ヶ月前 KC さんが最後の更新を行いました。

7件の投稿を表示中 - 1 - 7件目 (全7件中)
  • 投稿者
    投稿
  • #52015

    ezoris
    参加者

    動作に関するご質問の場合は必ずご記入ください。


    WordPress のバージョン:3.4.2

    Welcart のバージョン:Version 1.2.0.1209081

    ご利用のテーマ:なし(カスタマイズ)

    症状を確認したブラウザ:chrome

    サーバー(会社名、サービス名):さくら

    SSLの利用: ○無し | 専用SSL | 共用SSL

    WordPress のパーマリンク設定:


    フロントエンドの言語 ja

    通貨表示 中国

    住所氏名の様式 中国

    販売対象国 中国

    都道府県 中国 → この際に中国の都道府県にあたいする地域を記入

    したのですが、

    設定更新ボタンを押すと、毎回 データに不備がありますと出て

    上記の設定登録が完了できません。

    ご教示願います。

    #65823

    ezoris
    参加者

    自分で解決しました。

    /usc-e-shop/includes/initial.php

    に直接、

    $usces_states = array

    で地域を追加

    その後管理画面上で再度”中国”を選び保存すると反映されました。

    管理画面上では都道府県の入力フォームは空ですが、

    ソースをみると、反映されており、なぜかtype=”hidden”でフォームの中身が隠れていました。

    なぜtype=”hidden”で隠れているかは不明です。壊れていたのかもしれません。

    #65824

    KC
    参加者

    当件、管理者の見解を教えてください。

    私の方でも、同様の現象が発生しております。

    私の構想では、アメリカ合衆国、カナダ、マレーシア、香港など複数の販売対象国を想定しております。最初、複数の販売対象国で設定したのですが、「データに不備があります」が表示されるので、一つの国(この場合、カナダ)で設定しましたが、上記の通りです。

    下記、現象が確認できた環境を、ezorisさんの形式に則って記述いたしました。

    また、現象が確認できた画面も添付しておきます。


    WordPress のバージョン:3.4.2

    Welcart のバージョン:Version 1.2.1

    ご利用のテーマ:オリジナル

    症状を確認したブラウザ:mac版safari

    サーバー(会社名、サービス名):sixcore

    SSLの利用: ○無し | 専用SSL | 共用SSL

    WordPress のパーマリンク設定:


    フロントエンドの言語 en

    通貨表示 カナダ

    住所氏名の様式 カナダ

    販売対象国 カナダ

    都道府県 カナダ → この際に中国の都道府県にあたいする地域を記入したのですが、

    設定更新ボタンを押すと、毎回「データに不備があります」と出て

    上記の設定登録が完了できません。

    [attachment=8820,188] [attachment=8820,189]

    #65825

    yskysmr
    キーマスター

    こんにちは。

    KCさま。「フロントエンドの言語」を「Follow config.php」に設定してみてもらえますでしょうか。

    よろしくお願いいたします。

    #65826

    KC
    参加者

    yskysmr様、

    お返事いただきありがとうございます。

    ご指示の通り、フロントエンドの言語を「Follow config.php」に設定しましたが、

    結果は同じでございます。

    唯一変化したのは、設定変更のボタンを押した後、

    「Follow config.php」の部分が「ja」に変化した、という点です。

    引き続き、解決策のご提示宜しくお願いいたします。

    #65827

    yskysmr
    キーマスター

    失礼いたしました。フロントエンドの言語は「en」で結構です。

    こちらで同一バージョン、Mac Safari で確認いたしましたが、仰る現象は見られませんでした。

    もう一度、KC様の手順を確認させてください。

    ・「販売対象国」には複数の国を選択されましたか?

    ・選択された国全てに、都道府県を入力されましたか?

    ・「設定を更新」ボタンは、選択された国全てに、都道府県を入力された状態で押されましたか?

    #65828

    KC
    参加者

    yskysmr様、

    お返事いただきありがとうございます。

    下記、ご質問に対してご回答させていただきます。

    ・「販売対象国」には複数の国を選択されましたか?

    複数の国を指定してもだめだったので、

    一つの国、今回はカナダ、だけで選択してもダメでした。

    ・選択された国全てに、都道府県を入力されましたか?

    はい、複数の州を登録してもダメだったので、

    1つだけ、今回は任意で「all」と入力してもダメでした。

    ・「設定を更新」ボタンは、選択された国全てに、都道府県を入力された状態で押されましたか?

    はい、上記にも書きましたが、

    複数国を指定した場合も、一つだけの国を指定した場合もダメでした。

    ちなみに、yskysmr様のほうでもご検証いただいたとのことですが、wodpressのバージョンも同一なのでしょうか。

    引き続きアドバイスいただけますでしょうか。

7件の投稿を表示中 - 1 - 7件目 (全7件中)

このトピックに返信するにはログインが必要です。