[解決済み] 支払方法が反映されません

2010 年 9 月 8 日

ホーム フォーラム 使い方全般 [解決済み] 支払方法が反映されません

このトピックには11件の返信が含まれ、2人の参加者がいます。7 年、 3 ヶ月前 kikuchi さんが最後の更新を行いました。

12件の投稿を表示中 - 1 - 12件目 (全12件中)
  • 投稿者
    投稿
  • #49944

    kikuchi
    参加者

    お世話になります。

    初めて質問させていただきます。

    基本設定で入力した支払方法が、カートの発送・支払方法入力画面の支払方法に反映されません。

    支払方法には「まだお支払方法の準備ができておりません。

    管理者にお問合せいください。」と表示されています。

    サーバー名:speever

    wordpress:3.0.1

    welcart:0.7

    MySQL:5.0.22

    Apache:2.2.3

    よろしくお願いいたします。

    #60304

    nanbu
    参加者

    こんにちは。

    どの様に支払方法を登録したか教えていただけますでしょうか。

    「支払方法名」、「説明」、「決済種別」、「決済モジュール」

    #60305

    kikuchi
    参加者

    ご返答ありがとうございます。

    支払方法は2つです。

    1.代金引換 決済種別:代金引換 説明:集金代行システムである事。

    2.銀行振込 決済種別:振込前払い 説明:銀行名を記載

    後でクレジット決済を追加しようと思っています。

    さくらサーバーでサイトを構築しみて、Welcartが素晴らしかったので本サイトでも使用させていただこうと思いインストールしてみました。

    Welcartの設定を行い、商品を1つだけ登録し動かしてみました。

    よろしくお願いいたします。

    #60306

    kikuchi
    参加者

    お早うございます。

    Welcartのバージョンを0.6で試したところ動作しました。しかし、代引手数料の設定「6999円未満=300円、7000円以上=0円」が不正な数値として設定できませんでした。

    さくらサーバーのサイトもバージョン0.7にアップしたところメンバーyasu様と同じ状況になり0.6に戻しました。

    これは要望なのですが、支払方法にクロネコ@ペイメントの利用を考えています。支払方法の決済種別に任意の文字列を設定できるようにして頂ければと思います。出来ればモジュールがベストですが。

    よろしくお願いいたします。

    #60307

    nanbu
    参加者

    こんにちは。

    登録した支払方法が認識されないと言うご報告は他に無いので、もしかしたら何か環境によるものではないでしょうか。

    全く予期しない動きになる原因の一つとして、プラグインの動作テスト用のWordPress環境と言うのがあるようです。いろんなプラグインを試しているうちにデーターベースがおかしくなってくるみたいです。

    今回はWordPress の新規インストール環境での動作テストでしょうか。

    v0.6 で動作したとのことですが、v0.7 では依然ダメですか?

    他のユーザーの皆さんのためにも、このトピックは支払方法に終始させて頂きたいと思います。別のご質問は新たにトピックを投稿してください。

    よろしくお願いいたします。

    #60308

    kikuchi
    参加者

    ご迷惑をお掛けし申し訳ございません。

    新規インストールで他のプラグインは使用していません。最初にv7を管理画面からインストールしテストしてみましたが認識されませんでした。その後、無効化しフォルダを削除、ftpからアップロードして有効化しましたが同じ状況でした。

    よろしくお願いいたします。

    #60309

    nanbu
    参加者

    FTPクライアントを利用したファイルのPUTはしばしば取りこぼしが起きるので、極力管理画面のプラグイン新規追加から圧縮ファイルをアップロードする方法の方が良いかもしれません。

    もう一度v0.7 にアップグレードしていただけますでしょうか。

    よろしければこちらで見てみますので調査用のアカウント(管理者権限)を作って下記宛に送ってください。

    nanbuアットusconsort.com(アットは@)

    #60310

    kikuchi
    参加者

    お世話になります。

    zipファイルからインストールしてみましたが、同じく認識されませんでした。v0.6では正常に動きます。

    後ほどアカウントを作成しご連絡致します。

    現在はv0.6で他のプラグインを使用しています。

    よろしくお願いいたします。

    #60311

    kikuchi
    参加者

    お世話になります。

    Development Versionで試したところ認識されました。

    ありがとうございました。

    #60312

    nanbu
    参加者

    こんにちは。

    SSLの不具合がそんなところにまで影響していたのでしょうか。

    これは早く修正版を出した方がよさそうですね。

    最後にさくらサーバーでのテストをしてみたいので、それを確認してから修正版を出したいと思います。

    #60313

    nanbu
    参加者

    すみません。SSLはやはり関係なかったようです。

    以前のバージョンで登録して有った商品に対して、支払方法が反映されないと言う不具合を見つけました。

    Development Version を更新いたしました。

    よろしくお願いします。

    #60314

    kikuchi
    参加者

    素早い対応、本当に感謝の気持ちでいっぱいです。

    Development Versionでの当方の状況を連絡いたします。

    1.サーバー:スピーバー ドメインSSL

    2.サーバー:さくら 共有SSL

    Mozilla Firefox・Internet Explorerでテストしましたが、共に問題なく動作しています。お問い合せフォームでの警告も出ませんでした。

    また、何かありましたらご連絡差し上げます。

    ありがとうございました。

12件の投稿を表示中 - 1 - 12件目 (全12件中)

このトピックに返信するにはログインが必要です。